LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 09-06-2008, 08:13 PM   #1
yamaz
LQ Newbie
 
Registered: May 2006
Location: Ontario, Canada
Distribution: FC14
Posts: 18

Rep: Reputation: 1
Question 1080i Custom Modeline Problems


Hey guys

Trying to get a custom modeline to display say 1776x1000 to compensate for the overscan on my 1080i HDTV. I have had success with non-interlaced modes such as 1216x648, but for some reason I just can't seem to get the higher to take. I tried the TVOverscan option, but apparently it doesn't work. Here is the important block from my xorg.conf. Anybody see if I'm missing something?

PHP Code:
Section "Monitor" 
    
Identifier     "Monitor0" 
    
VendorName     "Unknown" 
    
ModelName      "CRT-1" 
    
HorizSync       28.0 85.0 
    VertRefresh     50.0 
75.0 
    Option         
"DPMS" 
EndSection 

Section 
"Monitor" 
    
Identifier     "Monitor1" 
    
VendorName     "Unknown" 
    
ModelName      "PANASONIC-MMD" 
    
HorizSync       15.0 68.0 
    VertRefresh     50.0 
61.0 
    Modeline       
"1776x1000" 74.166 1776 1899 1939 2200 1000 1036 1046 1125 +hsync +vsync interlace 
    Option         
"DPMS" 
EndSection 

Section 
"Device" 
    
Identifier     "Videocard0" 
    
Driver         "nvidia" 
    
VendorName     "NVIDIA Corporation" 
    
BoardName      "GeForce 7600 GT" 
    
Option         "IgnoreEDID" "True" 
    
BusID          "PCI:1:0:0" 
    
Screen          0 
EndSection 

Section 
"Device" 
    
Identifier     "Videocard1" 
    
Driver         "nvidia" 
    
VendorName     "NVIDIA Corporation" 
    
BoardName      "GeForce 7600 GT" 
    
Option         "IgnoreEdid" "True" 
    
BusID          "PCI:1:0:0" 
    
Screen          1 
EndSection 

Section 
"Screen" 
    
Identifier     "Screen0" 
    
Device         "Videocard0" 
    
Monitor        "Monitor0" 
    
DefaultDepth    24 
    Option         
"TwinView" "0" 
    
Option         "metamodes" "CRT: 1280x1024_60 +0+0; CRT: 1280x1024 +0+0" 
    
SubSection     "Display" 
        
Depth       24 
    EndSubSection 
EndSection 

Section 
"Screen" 
    
Identifier     "Screen1" 
    
Device         "Videocard1" 
    
Monitor        "Monitor1" 
    
DefaultDepth    24 
    Option         
"AddARGBGLXVisuals" "True" 
    
Option         "UseEdidFreqs" "false" 
    
Option         "ModeValidation" "NoEdidDFPMaxSizeCheck" 
    
Option         "FlatPanelProperties" "scaling = centered" 
    
Option         "TwinView" "0" 
    
Option         "TwinViewXineramaInfoOrder" "DFP-0" 
    
Option         "metamodes" "DFP: 1920x1080_60i +0+0; DFP: 1776x1000 +0+0" 
    
SubSection     "Display" 
        
Depth       24 
    EndSubSection 
EndSection 

Section 
"Extensions" 
    
Option         "Composite" "Enable" 
EndSection 
Any help would be greatly appreciated!
 
Old 09-07-2008, 03:19 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,529

Rep: Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622
I am assuming you are on Fedora 9 ( my Chrystal ball is not handy) and you installed the lvina
kmod-nvidia or the lvina akmod-nvidia .
and 2 GeForce 7600 GT ( from your xorg.conf)

Last edited by John VV; 09-07-2008 at 03:20 PM.
 
Old 09-07-2008, 06:46 PM   #3
yamaz
LQ Newbie
 
Registered: May 2006
Location: Ontario, Canada
Distribution: FC14
Posts: 18

Original Poster
Rep: Reputation: 1
LOL oops

Yeah, FC9 Distro and used livna repo for kmod-nvidia. It just seems like X11 (or perhaps the Nvidia settings program itself) refuses to see anything interlaced except for 1920x1080. When I pull up my metamodes in nvidia settings, the custom modeline is replaced by nvidia-auto-select even though it doesn't change it in the xorg.conf. When I get a chance I will post the server output as well. Perhaps that will help(?)

OH, and only one 7600...seems to me I could eliminate the second device section but just never really got around to it. Don't know whether it lists two just because I have two desktops and it keeps them seperate for dual head use or not.

Last edited by yamaz; 09-07-2008 at 06:50 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
1080i for HDTV KNx2 Debian 4 08-13-2007 08:53 PM
SAX2 - How to add a custom modeline? mr_r SUSE / openSUSE 2 07-13-2006 07:03 AM
Custom Kernel Problems Penguin of Wonder Ubuntu 13 03-14-2006 10:20 PM
problems installing custom 2.6.14 kernel (for SATA problems) Ekkume Ubuntu 0 12-29-2005 02:39 PM
Custom modeline mrsolo Linux - Laptop and Netbook 2 08-16-2003 01:53 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 11:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration