LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   [HOWTO] MP3 Support in XMMS + Rhythmbox (https://www.linuxquestions.org/questions/fedora-35/%5Bhowto%5D-mp3-support-in-xmms-rhythmbox-114094/)

contra 11-09-2003 11:23 AM

[HOWTO] MP3 Support in XMMS + Rhythmbox
 
okay...i said i'd most a faq once i figured out how to do it so here it is...

MY /etc/apt/sources.list FILE

Code:

rpm http://rpm.livna.org/ fedora/1/i386 stable 
# rpm-src http://rpm.livna.org/ fedora/1/i386 stable

# FreshRPMs Fedora Core 1
rpm http://ayo.freshrpms.net/fedora/ linux/1/i386 updates freshrpms
#rpm-src http://ayo.freshrpms.net/fedora/ linux/1/i386 updates freshrpms

# Misc Fedora Core 1
rpm http://mirrors.kernel.org/fedora/fedora/ fedora/1/i386 os updates stable
#rpm-src http://mirrors.kernel.org/fedora/fedora/ fedora/1/i386 os updates stable
rpm ftp://ftp.ussg.iu.edu/pub/linux/fedora/fedora/ fedora/1/i386 os updates stable
#rpm-src ftp://ftp.ussg.iu.edu/pub/linux/fedora/fedora/ fedora/1/i386 os update
rpm http://mirrors.usc.edu/pub/linux/fedora/fedora/ fedora/1/i386 os updates stable
#rpm-src http://mirrors.usc.edu/pub/linux/fedora/fedora/ fedora/1/i386 os updates stable

------------------

RHYTHMBOX

okay...i used synaptic (http://mirrors.usc.edu/pub/linux/fed....rh90.i386.rpm) to install all of the dependicies for rhythmbox which i believe are only xine and libid3tag (gstreamer not needed don't bother with it) then simply run:

Code:

su
rpm -e rhythmbox
rpm -iv http://ftp.freshrpms.net/pub/freshrp...-0.fr.i386.rpm

note: the board shortens the url...right click on the address and press "copy link location" to get the whole url

and that should install a *working* rhythmbox (if it asks for any more dependincies simply run synaptic again and install them.)

XMMS

download this: http://www.osnews.com/files/xmms-mp3-fc1.tar.gz
tar -zxvf xmms-mp3-fc1.tar.gz
Copy the two lib files (as root) to /usr/lib/xmms/Input
Restart xmms

laydros 11-09-2003 12:43 PM

sweet. i can't wait to try it. thanks!

GraemeK 01-26-2004 04:38 AM

i'm a bit new to all this... whats the sources.list FILE for?

i just want to play mp3's in xmms

will copying those two lib files to the xmms direcotry work?

cheers

G

mingmongfu 01-29-2004 12:30 AM

i just copied the .so file in to the directory and i can play mp3s in xmms

jonnycarlos 03-04-2004 11:42 PM

yay!! thank you contra for such a simple solution to xmms stuuupid mp3 block on fedora.

IeU 07-18-2004 12:14 PM

would like to know if this solution to play mp3 in fc2 will work with this file for fc1

thanks

gmcmaster 08-14-2004 05:55 PM

Or you could go to XMMS' site and download the latest RPM for Fedora Core(1) (works on 2 as well) and you can play your MP3s no problem with a newer piece of software. Bonus! :D

jlacroix 08-15-2004 03:26 PM

That worked perfectly but the version above is very old, do you have a solution for the newest version?

I tried 0.8.5 I think it was but once installed MP3's don't work, but the version posted on the first post in this thread works.

Fayte 09-02-2004 03:39 AM

Just install mad, libid3tag and the gstreamer mp3 plugins using yum:

# yum install libmad
# yum install libid3tag
# yum install gstreamer-plugins-mp3

That's all I did to get mp3 working in Rhythmbox. For XMMS, I did this...

# yum install xmms-mp3

the_tflk 10-12-2004 09:37 AM

Thanks muchly contra! Works like a charm.
- jON

misc 10-15-2004 09:03 AM

Why would you use old Red Hat Linux 9 packages for Fedora Core? It's also weird to delete a Fedora Core package and to replace it with a Red Hat Linux 9 package. Adding mp3 support is done with add-on packages.

http://rpm.livna.org provides clean and up-to-date extra packages for mp3 support, How to add that repository to your yum.conf or Apt-Rpm sources list? Read the main page.

irwinr 12-29-2004 02:57 AM

I'm also having problems with rhythmbox. I'm using Fedora Core 3. I've already created a thread on it under Linux Software. I just happened to run by this thread and see other people having problems.

Since I've already started a thread, I'll just link to it:
http://www.linuxquestions.org/questi...hreadid=271372

Basically, I've installed all the add on packages to enable mp3 support. But when I try to play them, rythmbox locks up.

-Jeremy

iamtheug 12-05-2006 09:18 PM

umm.....
 
...whats xmms? im a major newb to this linux thing...and dont have internet on it.... i have rhythmbox on my comp. with fedora 6 on it... and im not sure what to do. if its possible without connecting to the internet id like to install support for mp3, wma, mpg videos,and anyother plugin widows files would use.... im the only person i know realy that has linux...so no one here can help me.


All times are GMT -5. The time now is 09:38 PM.