-   Fedora (
-   -   [BOLD]wheel group and sudoers[/BOLD] (

minty33 06-18-2013 06:51 PM

[BOLD]wheel group and sudoers[/BOLD]
i just installed fedora and i forgot to check the box to add to administrators group. i tried to add myself to the wheel group but it doesn't seem to stick. my sudoers file is correct where as the %wheel=(ALL) All is uncommented. i tried to add my user to this group a couple ways. here is what i tried as root:

usermod -aG wheel username
usermod -G wheel -a username
usermod username -a -G wheel
gpasswd wheel -a username (this even said adding username to wheel group when it executed)

**none of these gave me errors and the last one actually said it was doing it. i also was going to do it via gui but on the gui it says i am in the wheel group already. at the commandline however i type "groups" and wheel is not showing as me belonging.
anyone know why this is happening or how to rectify?

slipstreamed 06-19-2013 02:26 AM


usermod -a -G wheel username
also are you getting any selinux notifications while running usermod?

you could also edit /etc/group and /etc/gshadow files as root and manually add <user> to the group wheel. Here is what my files look like

wheel:x:10:test, new
i've added <user> test via

usermod -a -G wheel test
and <user> new manually

wheel:::test, new
both users after running

list themselves as member of


minty33 06-20-2013 09:07 AM

thanks for the reply but i had it done already. i shoulda marked this solved before. actually all those things i tried in my first posr worked i just didn't realize they don't take effect until reboot. linux almost never requires a reboot for changes but this is one of those rare cases. even just ending the terminal session didn't do it i actually had to rebot the computer.

Lennie 06-20-2013 09:38 AM

You only need to log out and login again.

minty33 06-20-2013 01:38 PM

i did read that prior but i thought i did that. what happened actually was i have it set to require a log in after screensaver. i assumed that counted as logging back in but apparently not.

Lennie 06-20-2013 02:22 PM

Screensaver just locks the screen. It doesn't log you out, so therefore it can't let you login.

minty33 06-20-2013 02:48 PM

yea i realize that now, but when i did it i guess i was thinking it logged you out after a period not just locked you out. just a brain fart on my part.

All times are GMT -5. The time now is 04:45 PM.