LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Dragora GNU/Linux-Libre
User Name
Password
Dragora GNU/Linux-Libre This forum is for the discussion of Dragora Linux.

Notices


Reply
  Search this Thread
Old 02-21-2017, 09:12 AM   #1
san2ban
Member
 
Registered: May 2013
Location: Bengaluru / India
Distribution: Slackware14.1-64bit, Salix-XFCE, Dragora 2.2
Posts: 119

Rep: Reputation: Disabled
Unable to build package for GNU icecat45.5.1, asking for python 2.7 or above


The TEHNOETIC laptop shipped with icecat 10. Many websites are complaining that the browser is outdated. Downloaded the icecat45.5.1.tar.bz2 from fsf.org and converted it to .gz format
Followed the instructions on the webpage to build the package.
It is asking for python 2.7 or above, but my laptop has python2.6.9
Is it not possible to build this package?

bash-4.2$ ./configure --prefix=/usr --sysconfdir=/etc --infodir=/usr/info --mandir=/usr/man
which: no python2.7 in (/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/games:/usr/games:.:/usr/share/java/apache-ant/bin:/opt/jdk/bin:/opt/jdk/jre/bin)
./configure: eval: line 102: syntax error near unexpected token `('
./configure: eval: line 102: `Python 2.7 or above (but not Python 3) is required to run mach.'
bash-4.2$
 
Old 02-22-2017, 01:59 AM   #2
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: Debian, Crux, LFS, AntiX, NuTyX
Posts: 1,364
Blog Entries: 1

Rep: Reputation: 590Reputation: 590Reputation: 590Reputation: 590Reputation: 590Reputation: 590
No, if the configuration script explicitly asks for a particular version of an ancillary program, you need to have that version installed. Especially for a Mozilla build, which uses python a lot in its early stages.

In your place I would try to build an earlier version of Icecat. The jump from 10 to 45 is huge; there must be intermediate versions that would compile with your python and would still be a great improvement on your present setup. Just build the latest that you can.

I used to use Dragora. I gave it up partly because the software was so outdated.
 
Old 02-22-2017, 07:09 PM   #3
bateleur
LQ Newbie
 
Registered: Feb 2016
Distribution: Slackware
Posts: 25

Rep: Reputation: Disabled
I am not a Dragora user, but on their site there are instructions on how to install two Python versions on Dragora 2.2 [0]. Or you could also try to install a Python distribution [1] (although it might ship with non-free software, which would obviously defeat the purpose of Dragora). Or you could also just change the useragent of your browser to see if that helps. Create a user.js file and add it to your profile:

Code:
user_pref("general.useragent.override", "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36");
Although I am not sure whether that option is available in GNU Icecat 10.

[0] https://dragora.org/repo.fsl/doc/tru...honversions.md
[1] https://www.atlantic.net/community/h...ntos-anaconda/
 
Old 02-23-2017, 08:03 AM   #4
san2ban
Member
 
Registered: May 2013
Location: Bengaluru / India
Distribution: Slackware14.1-64bit, Salix-XFCE, Dragora 2.2
Posts: 119

Original Poster
Rep: Reputation: Disabled
On irc, it was suggested that firefox45ESR can be downloaded and used, ofcourse, without enabling the non-free add-on's. At the moment, done that and using the firefoxESR.
Looks like building the latest icecat is out of the question for now.
Thanks for the replies
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Manual Python build cannot beat Ubuntu build??? taihd Ubuntu 0 12-26-2013 07:28 PM
[SOLVED] E: Unable to locate package nova-comm E: Unable to locate package python-psycopq2 mint12 Linux - Virtualization and Cloud 2 01-05-2012 12:07 PM
Unable to build pidgin 2.10.1 package Cultist Slackware 6 12-16-2011 08:19 PM
Unable to install python-dev package on 64-bit Ubuntu Linux MahendraL Linux - Newbie 2 05-24-2011 06:05 PM
unable to build gspca from Alien Bob Slackbuilds package adityavpratap Slackware 5 08-03-2009 11:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Dragora GNU/Linux-Libre

All times are GMT -5. The time now is 04:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration