-   Debian (
-   -   Xorg Problems - Via Chip with OpenChrome - After Update via Synaptic (

deathawaits 09-22-2008 07:25 PM

Xorg Problems - Via Chip with OpenChrome - After Update via Synaptic

After I've gone well with Debian Lenny on my Desktop Computer,
I decided to use it on my notebook, too.
It had run well for a few days, but after I updated via Synaptic I wasn't able to start the X anymore. (I'm not Sure but I think there was also an update (or more) for Xorg or XServer-Xorg or any of it's parts, but I dont know exactly.)

I'm not sure if this is the right subsection, if not I'm sorry.

System: Medion MD96389
Core: Intel Pentium Dual-Core Prozessor T0280
Grafik-Card: VIA Chrome9 HC
Screen: 15,4" TFT WXGA (Resolution: 1280x800)
OS: Debian-Lenny, installed via

Grafik-Driver: Openchrome, build the way:




deb feisty main universe multiverse
deb-src feisty main universe multiverse

apt-get build-dep xserver-xorg-driver-via
apt-get install subversion autoconf automake1.9 libtool
cd openchrome
./ --prefix=/usr
make install

Section "Device"
Driver "openchrome"

git clone git://
cd drm
./ --prefix=/usr
make install
drm kernel modules
cd linux-core
make LINUXDIR=/lib/modules/`uname -r`/build DRM_MODULES=via
cp *.ko /lib/modules/`uname -r`/kernel/drivers/char/drm/
depmod -ae
modprobe drm
modprobe via

Tested with the following command
glxinfo | grep render
echo "drm" | sudo tee -a /etc/modules
echo "via" | sudo tee -a /etc/modules

When I logged in then, I get this error:


0: /usr/bin/X11/X(xf86SigHandler+0x7e)
1: [0xb7f63400]
2: /usr/bin/X11/X(main+0x2b1) [0x8074591]
3: /lib/i686/cmov/ [0xb7d07455
4: /usr/bin/X11/X(FontFileCompleteXLFD+0x21d) [0x8073a81]

Fatal server error:
Caught signal 11. Server aborting

giving up.
xinit: Connection reset by peer (errno 104): unable to connect to X server
xinit: No such process (errno 3): Server error.
I've searched google extensive for this errors, but only found topics relayed to unproper installed ati/co drivers, and even if I've made a mistake in my Openchrome install, I dont know where.

The second search for the error "no such process" hasn't been succesful, too. I just found some topics like "doesn't work when logged in as root, which isn't my case, nothing works, root, user acc.

- Deathawaits

deathawaits 09-22-2008 07:45 PM

So far
I may should add:
I already tried this:

1. Backuped the Xorg.conf file and then reset it to default and config it again.

2. Removed all Xorg packages via aptitude remove xorg Xorg-Xserver and all others of X and then reinstalled them, reinstalled openchrome then 1. again

Tried to run startx with vesa, via, openchrome

And now my idees have come to an end.

I dont know very mutch about X or Linux. I know enought to deal with small problems but this seems to be a little bit more complex.

radiodee1 09-23-2008 06:49 AM

If your sources.list is correct, you don't have debian, you have ubuntu. If you have debian, there's binary packages in the repository that you could try. One is called 'xserver-xorg-video-openchrome'. I don't know much about it, and I don't know if it exists in ubuntu. In debian I think it only exists in lenny. You should probably go to an ubuntu forum. If on the other hand you wanted to install debian from scratch, I think there's a sticky on this site for doing exactly that. There's no way I know to change an already installed system from ubuntu to debian. Trying this would be very bad. I hope this helps. :)

deathawaits 09-23-2008 10:34 AM

I've Debian. I needed this sources to compile the openchrome driver. This FAQ I used is for Debian and Ubuntu and I found it in a Debian forum, since Ubuntu is based on Debian.
Also it worked.

And I dont need a guide for a debian install. I got it running on my Desktop PC and my Laptop, and the package you're proposing doesn't work.

I've read some books and other information about debian, so I got it running // got no problems on my pc, I only got a Problem with the via-chipset and the openchrome drivers...

Also: I know which OS I've.

deathawaits 09-24-2008 09:31 PM

No one knows anything?
Ok, then I'll make a new install.

All times are GMT -5. The time now is 03:01 AM.