-   Debian (
-   -   xorg monopolizes resources (

mpyusko 04-20-2010 10:40 AM

xorg monopolizes resources
For some reason after the computer is on and idle for a little while, xorg starts using all available CPU resources. When I come back to use the computer, the screensaver will either be running nice and smooth, or the screen will be black. Either way, I won't be able to get back into X. I'll ctrl+alt+F1 into the console (or ssh if it's still not responsive) and "top" shows me xorg is hogging all the available CPU. I'll kill -3 <xorg> and it the computer will come back to the kdm login screen. What the %^&*??? It's a little irritating. I'm using Bouncing Cows and Seti@home when idle, but both do their job and close when they detect a key press. Even via ssh when I already tried waking up the computer with a key press, it shows the screensaver closed and seti is idle.

I have Debian/Lenny installed with all the latest updates and ATI's driver installed with direct rendering enabled (350fps for the cows, >2000fps for glxgears). FWIW, it's a Dell Inspiron 8600, 1.8GHz, 2GB Ram, 80GB HD, ATI 9600pro/128MB.

Idea's??? Thanks.

Mr-Bisquit 04-21-2010 07:47 PM

You need to slim down your system. Don't run any animated screen saver. Better to have a screen that blanks out.

adamk75 04-21-2010 07:48 PM

Well I would first have to point out that the Xserver and drivers you are using are well over a year old. It's quite possibly a bug in one or the other than has since been fixed.


replica9000 04-23-2010 04:55 PM

I used to have this issue back when Etch was in testing. Turns out it was caused when SuperKaramba was monitoring my hard drives. I had set a script to kill and restart SuperKaramba every 30 minutes to avoid the issue. Also, at one time, leaving an open window in Iceweasel also caused this. In both cases, using 'top' only showed it was Xorg using all my CPU power, and not the programs that were actually causing the issue. Chances are, you have something running under X that is causing this, but I'm not sure if you can use 'top' or another app to pinpoint the issue.

mpyusko 07-02-2010 12:01 AM

Some symptoms I noticed.....

If I have IceWeasel open and X appears unresponsive, it really isn't.
Mouse motion still operates, but button clicks do not.
I can type and use keyboard controls to navigate the browser, open and close tabs, but if I close the browser, it just sits there dead.
I can ctrl+alt+Fx and switch freely back and forth between console and X, but the active window's title bar is solid black and will not drag or resize.
I can kill kmail, firefox-bin, & Xorg signal 3 (in that order) and everything is saved and I get back to the KDM login screen.
I log back in and everything runs fine for an unknown amount of time, but at some point, after I walk away for a little while, it acts screwy again.

I try to keep up on all the updates (synaptic manager) but it still keeps happening. Did I mention I'm using KDE 3.5.10 on Debian Lenny?

mpyusko 07-02-2010 12:03 AM


Originally Posted by replica9000 (Post 3945676)
... I had set a script to kill and restart SuperKaramba every 30 minutes to avoid the issue...

I had to do a similar cron on my Slackware box to kill artsd every hour otherwise it boggs down the system.

Can you post your script and info about how to set it up? I do have SuperKaramba monitoring my hard drive. Temp, SMART status and Space.

mpyusko 07-27-2010 04:29 PM

So my system has been somewhat stable for a couple days now. Apparently rsyslogd was logging every time my Superkaramba theme sudo' for SMART status, but mainly hard disk temperature. All successful pollings were logged to auth.log and would eventually fill up the /var partition causeing issues with running programsn. I edited the rsyslogd.conf file and comented out the auth.log section and resarted rsyslogd. It has been fine ever since.

I'd rather not have the auth disable, but I don't need it to log all successful sudos. Is there some way I can log only unsuccessful to auth.log? For my system it's more valuable to see failed attempts.


All times are GMT -5. The time now is 07:52 PM.