-   Debian (
-   -   xmms-wma makes xmms to exit while try playing .wma (

deepclutch 11-30-2005 05:10 PM

xmms-wma makes xmms to exit while try playing .wma
I use sarge with xmms version :xmms 1.2.10 + cvs20050209-2 with a rpm coverted to deb
using alien; xmms-wma tried other versions also) is dpkg -i installed.but when i try to play .wma files xmms simply exits..shows Segmentation Fault...ofcourse i enabled wma support in preferences ....please help...

arrenlex 11-30-2005 06:28 PM

I recommend downloading a real debian version of XMMS and trying that instead. Try it out and tell us what you get. the way, this forum probably isn't the best place to have that signature. Just saying.

halvy 12-01-2005 02:28 AM

i agree with your advice on the computer stuff, ...

but i disagree with your remark about his 'signature'.

as long as sigs are 'allowed', i don't see where it is anyones right to control what is said or not said.

i mean, this forum is NOT about sigs.. and i'm sure the mods/admins know how to approach something if they don't like it.

of course you have your opinion as well, which i'm sure you wouldn't want someone telling you not to express it.. (as does the poster with the sig you think is 'inapropriate')

i'm sure bill gates would love to censor my remarks,

no hard feelings :)

deepclutch 12-01-2005 08:46 AM

i reinstalled the sarge version of xmms and the plugin is not working here too.

regarding signature,it was not me who started these sort of sigs,
as i wrote this sig bcoz i saw few gooses like the guy who started this thread:
Quote: have sigs against my religion + and they are getting me and lot others irritated..i wrote to mod to ban that sig.but mod said each and everyone can express their own views here as i have no other options but to put my own sig to defend/offend it AND this is my personal view only....perhaps there are umpteen supporters too. FYI i edited my sig ..

arrenlex 12-01-2005 01:13 PM

As you like.

In my experience, xmms segfaulted on start when I turned on the composite extension of, but if your xmms physically starts, and crashes only when you try to play a .wma file, I can't help you further.

Where did you get the wma plugin? Try installing the xmms-dev package from debian repositories and then downloading the source for the wma plugin and installing it from there.

deepclutch 12-01-2005 07:17 PM

XMMS crashes only when try playing .wma.....b/w i use a backported version of Xorg on My Sarge..

halvy 12-01-2005 07:24 PM

make sure your sound is working correctly.

and then make sure xmms is set to whatever output is correct (ie alsa, oss, etc).

good luck, luttuce know :)

deepclutch 12-02-2005 02:42 AM

If i try any sound servers viz alsa,esd,arts,oss all fails and exit :(

VyRuZ 12-02-2005 05:55 AM

just do it the simple way... get vlc ;)
If VLC doesn't work, then i have no clue...

halvy 12-02-2005 12:20 PM

when you say 'segmenation fault' error, where are you seeing this?

ie. do you load xmms from a terminal (which is a great way to help diagnos, because you see all the spurious info fire up in the terminal, as the x program is loading and running).

or does a message just 'pop up' in kde or whatever window program you use?

also look into compiling xmms on your system.

ALOT of times that will help solve your problems with ornery applications like xmms.

i don't know if your familiar with compiling, but it is more scarry than hard to do ;)

it's bascially 3 commands.

the great thing about compiling (other than you can 'usually' get your app to work premo), is that it points out deficiances BEFORE it will let you compile, so that you can adjust other programs to make your program run, AND run top-notch.

during and after compiling, it is rare to have any error messages (but possible).

those error messages can be delt with almost %100 of the time then.

the problem you might have, is that when you add/upgrade other programs that the compiler says xmms needs, that you may/can break other programs (and possibly your whole distro).

sooo, just be careful and patient..and most of all have a GOOD BACKUP of your os, so you can revert back when your done working.

another option of course is to use another program in place of xmms.

however, the program SHOULD work, so probably something is just amis, that compiling will point you to :)

once again, good luck and lettuce know what happens!

deepclutch 12-02-2005 05:28 PM

I got this 'seg fault' error when i ran xmms from terminal..waiting for a sloution....

halvy 12-02-2005 06:00 PM

well have you tried compiling yet?

have you ever done this with other programs?

you need to get the bz or gz version (ie. NOT the binary installable version).

but if you don't want to do that yet, try an older version of xmms first.

also, the way you are doing it, using the 'alien' feature is not the best way..

i have a feeling you'll need to take that jump, and compile..

it's really not a big deal (and it makes you feel real 'haxor' like ;) lol

hang in there man.. you'll get it.

deepclutch 12-02-2005 06:53 PM

hei hei now it is working !Thanks to All:) don know how this suddenly worked!
yeah.i know i do compile from source already compiled n installed various packages/kernel compiling..etc...did u know more about checkinstall?how do we use it for compiling..
Thank You :)

All times are GMT -5. The time now is 11:58 AM.