LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 01-30-2004, 01:34 AM   #1
toovato
Member
 
Registered: Jul 2003
Location: Ft Lauderdale, FL
Distribution: debian
Posts: 48

Rep: Reputation: 15
xfree86 4.3.0 exp ati radeon 8500 dri


Thanks in advance for your reply:

hour 24 and the coffee is losing its glamour

xfree86 4.3.0 experimental v5
ati radeon 8500 All in Wonder
DRI compiled from:
http://dri.sourceforge.net/snapshots/README.Debian

xfree86 loads okay?:
II) RADEON(0): [drm] installed DRM signal handler
(II) RADEON(0): [DRI] installation complete
(II) RADEON(0): [drm] Added 32 65536 byte vertex/indirect buffers
(II) RADEON(0): [drm] Mapped 32 vertex/indirect buffers
(II) RADEON(0): [drm] dma control initialized, using IRQ 11
(II) RADEON(0): [drm] Initialized kernel GART heap manager, 5111808
(II) RADEON(0): Direct rendering enabled

but glxinfo shits itself:
noc:/home/admin# glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_SGI_make_current_read, GLX_SGIS_multisample
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
GLX_ATI_render_texture
GLX extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 Mesa 5.0.2
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess


I believe my libraries are correct - but there must be a problem here????
noc:/home/admin# ldd /usr/X11R6/bin/glxinfo
libGLU.so.1 => /usr/X11R6/lib/libGLU.so.1 (0x4002c000)
libGL.so.1 => /usr/X11R6/lib/libGL.so.1 (0x400a7000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x4012b000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x4013a000)
libpthread.so.0 => /lib/libpthread.so.0 (0x40201000)
libm.so.6 => /lib/libm.so.6 (0x40252000)
libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0x40274000)
libc.so.6 => /lib/libc.so.6 (0x4032d000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x4045f000)
libdl.so.2 => /lib/libdl.so.2 (0x40468000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

my relevant X config:

Section "Module"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
EndSection


Section "Device"
Identifier "Radeon"
VendorName "ATI"
Driver "radeon"
# Option "NoDCC"
Option "AGPMode" "4"
BusID "PCI:1:0:0"
EndSection

Section "DRI"
Mode 0666
EndSection


Thanks again
Brian
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
DRI not working on XFree86 4.0 with ATI Radeon Mobility nef Linux From Scratch 1 03-13-2004 02:24 AM
ati 8500ve - ati Radeon 8500 ve - suse 9.0 pro linuxgamer Linux - Hardware 0 11-30-2003 06:29 PM
Will ATI Radeon 8500 XFree86 4.2 driver work with Xfree86 4.3? Stevetgn Linux - Hardware 1 06-24-2003 07:16 PM
Radeon 8500 LE DRI freezes X aton Linux - Hardware 0 04-04-2003 10:50 AM
XFree86 fatal error (Radeon 8500) TheDreamX Linux - General 12 05-16-2002 08:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 10:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration