LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   xfce weather app stopped working and shows 'no data' (https://www.linuxquestions.org/questions/debian-26/xfce-weather-app-stopped-working-and-shows-no-data-4175682144/)

dilbert_uk 09-15-2020 01:03 AM

xfce weather app stopped working and shows 'no data'
 
This is the second time I got problems with the xfce weather app on the xfce panel.

I got xfce on one laptop with Debian and on one PC with Ubuntu.

First time, a few month ago, both computers showed 'no data'. I followed the suggestions to uninstall it and re-install it again and this cured the issue on both computers.

Now, this xfce weather app only stopped working on the laptop running Debian 10 Buster. On the PC, the same xfce weather app still keeps working.

Both, laptop and PC are connected via Ethernet to the same switch.

Anyone knows how to search for apart from uninstalling and re-installing, changing locations and similar hints? (Because I tried all this already ...)

remmilou 09-15-2020 03:53 PM

Yeah... met too. Had it running on my MX19. It stopped, but after some time it worked again.
Now just changed to "pure" Debian Buster, it does not work, on a fresh install.
Puzzled...
Indeed, reconfigure and reinstall did not solve it.
Googling for a solution it has been an issue before.
One thing to check is if you have more then one profile for the app in your home dir. That seemed to be a bugger before.

sgosnell 09-15-2020 08:28 PM

I just started it, and it showed no data when it had my location, but I reset the location to a nearby airport with weather reporting capability, and it started working fine. I assume it works by getting the METAR report from an airport, but it needs to know what airport to use.

dilbert_uk 09-15-2020 10:51 PM

Well, Lima/Peru has already an international airport and I changed it now just for fun to London Gatwick Airport where it says explicitly "airport". The same thing, it has no data.

Why is this thing such a black box? And why is it still working with xfce on Ubuntu 20.04 on another PC?

There are lots of solution to this on the web of simply un- and re-installing, compiling from scratch and the like. This may be a quick solution but on the other side one can waste lots of time with simply shooting into the dark.

First time, I could imagine, that may be the URLs to retrieve information where outdated or got corrupted by any not up-to-date libraries or so. But now, there is no simple way to "debug" this problem?

ondoho 09-17-2020 01:29 AM

Quote:

Originally Posted by dilbert_uk (Post 6166305)
Why is this thing such a black box?

Agreed.
There's some documentation here, and it mentions that it uses https://api.met.no/ for weather data (and not METAR, which is US only). It also mentions, in one changelog from 2017: "Change more URLs from http://yr.no to https://met.no". Whatever that means internally...
Looking at the source, "yr.no" is only mentioned in comments, not in actual code.
"met.no" is mentioned much more often, esp here.

If the plugin doesn't work for you, you should first try to open https://api.met.no/weatherapi in your browser - how's that?

dilbert_uk 09-17-2020 06:08 AM

The tests available on the web site on the link to the weatherapi work fine. Getting closer to this, I now saw that the xfce on my PC with xubuntu uses the latest version of this xfce-weather-plugin 0.10.1.

Debian on my laptop still has version 0.8.10 as its latest version. That's the version in the Synaptic package manager and I'm not getting a newer version by adding the line "deb http://ftp.de.debian.org/debian sid main" to the file "/etc/apt/sources.list" (suggestion from https://packages.debian.org/sid/amd6...lugin/download).

If I download the package "xfce4-weather-plugin_0.10.1-1+b1_amd64.deb" then the Synaptic packet manager tells me that I got a broken package.

Right-clicking on that .deb file or launching the command "sudo dpkg -i xfce4-weather-plugin_0.10.1-1+b1_amd64.deb" tells me that it depends on a version of libc6 that is >= 2.29. But the only available version of libc6:amd64 would be 2.28-10.

I am not sure if it's only the older version on Debian but this app doesn't give any meaningful error messages like URL not found or any HTTP status codes.

sgosnell 09-17-2020 11:52 AM

From the XFCE site, about the weather plugin:
Quote:

Known Issues
The temperature and/or other values reported are not correct

In short: Given that the chosen location parameters are correct, this is caused by the quality of the datasource used (met.no), and there is nothing the plugin can do about it.

Long explanation: When the former maintainer started rewriting the plugin to switch from weather.com to another weather data provider, the choice of free data providers was really scarce for the given criteria. The decision was made for met.no, which provides weather data globally. However, that free weather data a bit later only turned out to be forecast data. So in fact, what the 0.8.x versions of the weather plugin show as current weather is actually fake, derived from forecast data. Yes, the weather plugin is cheating! In most cases and for many locations however, that data is sufficiently good. Keep in mind that often values provided by other (even local) providers differ a bit from those at your actual location, some are even more than half an hour old. For some locations though, or for some times/days the results will be quite off from the real temperature. Sorry about that.

Of course, the current author is aware that this is not an optimal solution, and today certainly better solutions are available. Therefore, future 0.9.x versions of the plugin will use data from openweathermap.org. However, work on such a new version has not began yet, and will take a while because it includes other necessary tasks like migration from gtk2 to gtk3.

ondoho 09-17-2020 01:25 PM

^ I saw that, but it doesn't seem to apply to OP's "stopped working and shows 'no data'".

@dilbert_uk: you don't want to create a Frankendebian. Unless you're willing to run sid full on, I recommend to remove that line from sources.list again, remove all packages you might have installed with it, do an 'apt install -f'.

You described & analysed the situation perfectly. That's where you stand.
I guess that the last remnants of "yr.no" in the code of 0.8 stopped working.

Maybe you can get a backported version of the weather plugin, maybe you can compile it for Debian 10. Otherwise you just have to get your weather differently. Do NOT try to upgrade libc6.

dilbert_uk 09-17-2020 03:28 PM

I think I saw somewhere a list of library files. So, I could try to compile the app stand-alone. But that seems to me too much of a hassle at the moment.

sgosnell 09-17-2020 04:14 PM

I just installed version 0.8.10.1 on a Debian Buster system, and I get no data no matter where I set the location. With version 0.10.1-1+b1 I get data wherever I set the location. It appears that the older version is broken, but the newer one works well on my Sid installation.


All times are GMT -5. The time now is 10:34 AM.