-   Debian (
-   -   X Server Won't Start on Fresh Install (

Thray 04-02-2004 12:31 PM

X Server Won't Start on Fresh Install
Alright, after having problems installing many other distros, I tried Debian at the suggestion of someone on this forum.
The install was iritating, but using good guesses and occasionally reading the stuff it said, I got through it okay I think.

Anyway, it installed both Gnome and KDE, and thus I assume it installed X.
However, on startup it says that it can not load the X server. It also claims that if I click yes, it will show me information. Doing so really just leads to a completely blank page of nothingness. Amazing.

Any suggestions? I only have experience with administering IRCDs and name servers over SSH, no idea how to make anything else work, and X isn't telling me anything.

I get the feeling after reading some other posts that some of you will try to get me to use another distro. I'm running out of CDRs, but what the hell. If you think I should try another distro please keep in mind that I need something that won't cause Sig 11s (Mandrake, Red Hat, Fedora, Slackware all failed).

Thray 04-02-2004 12:41 PM

Occured to me after the initial post that specs would probably help. I'm going to go ahead and blame my video card even though it may not be the problem.

P3 900 MHZ
128 MB RAM
nVidia Vanta AGP2x 16MB

ac1980 04-02-2004 05:02 PM

Try installing (apt-get install) xserver-xfree86, then running xf86config. Maybe the old xserver-svga (i.e. xfree86 3.3) is used. This might be enought...
Sorry, debian woody is pretty old. I recommend upgrading to testing (edit /etc/apt/sources.list, then apt-get update && apt-get dist-upgrade). I should have said this before: Sarge also has a much nicer installer, still at this point you don't need to reinstall from scratch.

souljah 04-02-2004 11:12 PM

'dpkg-reconfigure xserver-xfree86' is much nicer than stinky old xf86config. Just my opinion, Enjoy.

vectordrake 04-04-2004 05:28 PM

I don't think that you should try to install any other distro, since you have tried the major ones already. Your vid card is not the olny link in the "X" chain. You may have to even edit your /etc/X11/XF86Config-4 file yourself. THIS is a sample XF86Config file that I posted to my website for times like this. I got it from a Gentoo install I was doing (one day I will succeed with it). There are a lot of comments in the file so one can figure out what to do.

Here's basically what you need for X to work:

1)You need a mouse section. Usually yours will work no probs with the 4.x servers
2)You need a keyboard section. Default 104 keys will likely work (unless you need another locale/language)
3)You need your vid card identified properly (get it working and then go for 3d). You have an NVidia so your card likely has some drivers right on the NVidia site.
4)Your monitor must be identified correctly. The horizontal sync and the vertical refresh rates must be within the ranges your monitor allows (DPMS is a good option here, so it'll auto detect).
5)Your resolution and color depth must match your vid card/monitor combo.

Debian was the first distro that actually worked for me. I agree that the installer is a bit of a pain, but, believe me, if you have to reinstall ever again, you can use the Debian-installer for Sarge (the 'testing' distro, which is near prime-time now - as in the overly careful Debian developers think its almost completely unbreakable). It asks almost nothing of you (I had to configure my own network, as I don't do DHCP with my router - took an extra 20 sec). By the way, if you haven't already, install synaptic after X works. Its a nice front-end for apt-get/dpkg. It does the same things as the command line with the advantage of being more readable (and you can use your mouse, if you prefer it :D).

Look in /var/log/XFree86.0.log and see what errors may have shown up (you'll need to be root to see this file. Post it here if you don't understand it and can't get things to work as is. If you could post your /etc/X11/XF86Config-4 file as well (perhaps the parts about your mouse,vid card,monitor and hsync/vrefresh at least), that will help to figure thigs out as well.

All times are GMT -5. The time now is 06:09 AM.