-   Debian (
-   -   X Server says "No Core Pointer" (

extigyro 09-01-2004 12:44 PM

X Server says "No Core Pointer"
Package: XFree86
Version: 4.3.0.dfsg.1-4

When I invoked 'startx' for the first time after installation, it worked perfectly but when i run the X Server for the third time without arguments (just type
'startx') from an ordinary shell prompt it returns "No Core Pointer" (my mouse was and is correctly connected, i have it for sure), rather than the expected (as the first time without errors). I didn't change any settings between these three X sessions (and reboots). And to be sure that isn't my mistake i've installed the system three times and it goes the same way.
I am using Debian GNU/Linux 3.1, kernel 2.6.7-1 (default) and haven't made any package upgrades.

m_yates 09-01-2004 12:56 PM

Did you try adding "mousedev" and "psmouse" to /etc/modules? These seem to be needed with the 2.6.x kernel, but the Sarge installer doesn't put them there automatically for some reason.

HansOlo 09-01-2004 01:54 PM

I like mouse on my console and in X, so I did the following:

apt-get install gpm
dpkg-reconfigure xerver-xfree86

and select "gpmdata" for the mouse

coondognd 03-04-2007 07:04 PM

Adding "mousedev" and "psmouse" to /etc/modules did the trick for me. Thanks!

All times are GMT -5. The time now is 05:52 PM.