LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 06-21-2003, 09:29 PM   #1
Jehoven
LQ Newbie
 
Registered: Jun 2003
Posts: 3

Rep: Reputation: 0
X Monitor/Video device issues


This problem is really driving me insane.
My X server won't start, with the No Screens Found error.
Found Screen(s), but no usable configurations.
It also says a lot of: Not using default mode <various resolutions> (hsync out of range) or (bad mode clock/interlace/doublescan).

I've tried 2 different monitors and all the hsync options in xf86config. I've tried reinstalling debian, and still this error occurs.

Please, someone tell me what I can do about this, before something violent happens to my monitor/computer/office.

Thanks in advance,
Joacim
 
Old 06-21-2003, 09:37 PM   #2
Jehoven
LQ Newbie
 
Registered: Jun 2003
Posts: 3

Original Poster
Rep: Reputation: 0
I might add that I'm using a Nokia 447L monitor, if it's any help at all.
 
Old 06-21-2003, 11:17 PM   #3
ezmac
LQ Newbie
 
Registered: Jun 2003
Posts: 3

Rep: Reputation: 0
have you tried to look up the horizsync and vertrefresh for your monitor?
 
Old 06-22-2003, 06:26 PM   #4
stony
Member
 
Registered: Jun 2003
Location: Europe / Germany / Saarland / Neunkirchen
Distribution: Debian (SID), Gentoo
Posts: 131

Rep: Reputation: 15
Hi,

if you get these errors, try to decrease the size of hsync and try again. That would help you i guess. Normally this error appears if you've chosen the wrong hsync for your monitor, or an freuqency which your card can't handle.

Try to play a little bit with the frequencies. as long as you don't go above 80 Hz (60 Hz with older monitors) you can't destroy anything. If your monitor can do more, try it, after the 60/80 Hz are running

BUT BEWARE:

if you're setting a refreshrate that is higher as the one your monitor can handle, then you can DESTROY your monitor if X can't figure out what's goin on !!!

cu

Last edited by stony; 06-22-2003 at 06:27 PM.
 
Old 06-23-2003, 03:18 AM   #5
footfrisbee
Member
 
Registered: Apr 2003
Distribution: Debian Sarge
Posts: 259

Rep: Reputation: 30
What video card are you using?
 
Old 06-23-2003, 03:59 AM   #6
rdanda
Member
 
Registered: Feb 2003
Location: Newnan, Georgia
Distribution: Slackware -current
Posts: 40

Rep: Reputation: 15
X Monitor/Video

I had some problems with a standard stable install and an old Nvidia TNT2 in a spare box. If I tried to use framebuffers it would not work at all. I turned off frame buffers and everything worked great. You may want to try that.
 
Old 06-23-2003, 02:30 PM   #7
Jehoven
LQ Newbie
 
Registered: Jun 2003
Posts: 3

Original Poster
Rep: Reputation: 0
I'm not sure how to disable my frame buffers. I'm using a built in intel graphics controller (i810).

If you let me know how to disable the frame buffers, I'll give it a try, thanks
 
Old 06-23-2003, 06:32 PM   #8
stony
Member
 
Registered: Jun 2003
Location: Europe / Germany / Saarland / Neunkirchen
Distribution: Debian (SID), Gentoo
Posts: 131

Rep: Reputation: 15
Hi,

if you're using those i810 gfx card then you need the agpgart support in the kernel, 'cause this card uses system-memory as gfx-ram . Check if you've build in this in your kernel or if there's a modul you can load (agpgart.o)

cu
 
Old 06-24-2003, 12:42 PM   #9
Swive
LQ Newbie
 
Registered: Feb 2002
Location: Annandale, Minnesota
Posts: 8

Rep: Reputation: 0
Question

I am getting the same error after install. I ran XF86config but that didn't work either. I looked up some stuff on the net and I'm going to try poking around again tonight, but in the mean time...

Can somebody tell me what version of XFree86 I need with a GeForce MX 32 MB card?

Also, is there anybody out there who is running on an Abit BP6? I'm going to need help getting the SMP to work correctly once I can get X running.

Thanks in advance.

-KP
 
Old 06-24-2003, 07:13 PM   #10
stony
Member
 
Registered: Jun 2003
Location: Europe / Germany / Saarland / Neunkirchen
Distribution: Debian (SID), Gentoo
Posts: 131

Rep: Reputation: 15
Hi,

smp support on a bp6 isn't a problem, just compile your kernel with smp support (worked fine on my bp6 with dual celeron 433).

To run a GeForce MX the actually used 4.2 packages should work fine

cu
 
Old 06-25-2003, 08:18 AM   #11
Swive
LQ Newbie
 
Registered: Feb 2002
Location: Annandale, Minnesota
Posts: 8

Rep: Reputation: 0
Question

Stony, thanks for the reply. I have several more questions, but only a couple of pertinant ones. I was reading the documentation for NVidia drivers on their FTP and I think I found the answer, but I'm a little unsure about how to proceed.

Here's the situation:
I tried to install the NVidia drivers and the install package tells me that it can't find the kernel header. Now, there's a way to force it to use a specific location to find the kernel headers. Would you happen to know the location for them? Also, what kernel does Debian use as a default?

Also, it's kind of strange...I can't use startx to load X however, if I type 'XFree86 -configure' it will take me into X but I have no mouse.

I'm very clueless so far and consider it an accomplishment that I even have Linux running on this system at all.

Thanks again.

-KP
 
Old 06-25-2003, 09:35 AM   #12
stony
Member
 
Registered: Jun 2003
Location: Europe / Germany / Saarland / Neunkirchen
Distribution: Debian (SID), Gentoo
Posts: 131

Rep: Reputation: 15
Hi,

i guess i'll write a faq 'bout all those questions

first of all:

your kernel headers can be found by doing an:

apt-get search kernel | grep headers

after that you should see lots of header packages

now you have to check out which kernel is installed, just do a:

uname -r

and now you see the kernel-version.

if you would do an

apt-cache search $(uname -r)

then you'll find the packages you need. the kernel headers are inside the header package, after an

apt-get install kernel-headers-$version

you can find your kernel headers in /usr/src/$(uname -r)

and now you've got your kernel headers to compile the nvidia module.

BUT:

you should do all that the debian way with make-kpkg:

first of all if you need a few packages to build the modules (kernel):

1. required packages
=================
the following packages are required...

ncurses-dev, gcc, g++, make, kernel-package,dpkg-dev, fakeroot, xlibmesa3, xlibmesa3-dev and bison

do an:

apt-get install ncurses-dev gcc g++ bison make kernel-package dpkg-dev fakeroot xlibmesa3 xlibmesa-dev

to install them. There has to be the non-free option in your sources.list in /etc/apt, check this, if not run apt-setup to change it.

also you have to remove the old glide libs:

apt-get remove '.*glide.*'

if you don't want to build your own kernel skip this step and go on with step 3

2. Building Kernel
==============

download the latest kernel source from ftp.kernel.org (or a mirror near you)

USE A STABLE ONE (2.4)

f.e.: wget ftp://ftp.kernel.org/pub/linux/kerne...2.4.21.tar.bz2

after that put your tarball to /usr/src and untar it

f.e.: mv linux-4.2.1.tar.bz2 /usr/src && tar xvfj linux-2.4.21.tar.bz2

now you have to link to the kernel directory:

ln -s /usr/src/linux /usr/src/linux-2.4.21

change to the directory

cd linux

and do a:

make menuconfig

now configure your kernel and save the new kernel config.

2. building NVIDIA Drivers
======================

now run an:

apt-get install nvidia-glx-src nvidia-kernel-src

after that you should find two packages in /usr/src:

nvidia-glx_1.0.4349-1.tar.gz
nvidia-kernel-src.tar.gz

change to /usr/src

cd /usr/src

and untar them by running:

tar xvfz nvidia-*.gz

now you have a directory called modules where the nvidia kernel module resides in

now change back to /usr/src/linux

and do a:

make-kpkg buildpackage

after that, the kernel and the modules will be build with the whole documentation and so on ...

if you just want to build the nvidia kernel package do a:

make-kpkg modules_image

so only the modules will be build that reside in /usr/src/modules

ok, so far...

after the packages are build you have to build the nvidia glx package

change to /usr/src/nvidia-glx-$version

and do a

dpkg-buildpackage -us -uc -rfakeroot

now dpkg builds the glx package for the X servers

after everything is done fine you can find lots of packages in /usr/src

change there

cd /usr/src

and do a

dpkg --install kernel-image*.deb

after dpkg has installed the kernel image and you have answered the questions of dpkg correctly you can install the nvidia kernel and glx module with

dpkg --install nvidia-*.deb

now the kernel and the X module have been installed.

After (!) you've got a running X with the normal nv driver (try to setup your X with xf86config on the command line)

you have to change the following in the /etc/X11/XF86Config file:

comment out the lines with "dri" in it (if they exist)
change the Driver option from "nv" to "nvidia" in the Graphics device section

and load the module "glx" in the modules section (it should be already there and you only have to comment it out)

after that, login as normal user and try a startx

that's it enjoy the NVIDIA logo that appears everytime you start X and have a lot of fun

cu
 
Old 06-25-2003, 09:58 AM   #13
Swive
LQ Newbie
 
Registered: Feb 2002
Location: Annandale, Minnesota
Posts: 8

Rep: Reputation: 0
wow....

Ok. Thanks a lot!

-KP
 
Old 06-26-2003, 07:40 AM   #14
Swive
LQ Newbie
 
Registered: Feb 2002
Location: Annandale, Minnesota
Posts: 8

Rep: Reputation: 0
Ok, first of all...I have to say thank you very much, Stony. It would have taken me weeks to figure out what you posted.

I got as far as dpkg-buildpackage -us -uc -rfakeroot

and it starts trying to download 'NVIDIA_GLX' by attempting to connect to 205.158.109.140

Only problem...I don't have an internet connection on that machine. Is there a way to get the file it needs without being online? and what would be the command then?

Thanks again, Stony. I owe you a beer or five.

-KP
 
Old 06-26-2003, 07:49 AM   #15
stony
Member
 
Registered: Jun 2003
Location: Europe / Germany / Saarland / Neunkirchen
Distribution: Debian (SID), Gentoo
Posts: 131

Rep: Reputation: 15
Hi,

you have to download the file from the server

do a
wget http://download.nvidia.com/XFree86/L....0-4349.tar.gz

and put the file to /var/tmp (there it will be located by the makefile )

and then rebuild the package

cu
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Video Capture Device wmeler Linux - Hardware 1 05-04-2005 11:34 AM
Two X servers, one for my monitor, one for my TV using s-video out from video card? ateam Linux - Hardware 3 02-11-2005 02:43 PM
device issues uvone Mandriva 2 11-07-2003 02:44 PM
No video device found thiru Linux - Hardware 0 08-14-2003 07:02 AM
monitor issues ray_ca Linux - Hardware 3 09-01-2002 01:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 02:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration