-   Debian (
-   -   Working on getting up... (

thedu 07-28-2006 05:19 AM

Working on getting up...
To start this is one of the best forums I've ever been on, I've been able to learn a great deal through it...

Getting on with it...

My computer hardware is:

VA-503+ Motherboard
S3 Virge Generic in PCI slot 1
Soundblaster 16 in ISA slot 3
33.6 modem Sportster-works on the ttyS1, in ISA slot 2
CD-ROM 52X Creative
1.44 Floppy Drive
30 GB Western Digital Harddrive

I have the sarge version installed with GRUB as the installer

I used the i386 iso image download to install the os
as a desktop Stable(I believe)

Kernel: 2.4.27-2-386

I'm trying to get my soundcard up and running, I've read a few times that it's supported, but I'm begining to wonder if I need to install a diff kernel(I'm hoping not:) I went with the mentioned kernel because I'm new and don't really know anything about packaging kernels and the diff between. No matter this has been a excellent challenge. Well getting back to the point..

I'm trying to load a module for my soundcard

while logged in as root I-

#apt-get install alsaconf

which installed the alsa-base and the alsa-utils

I then ran the #alsaconf

which spit back-

modinfo: snd: no module by that name
" " "
" " "
" " "
" " "


Unloading ALSA sound driver modules: (none loaded)
isapnp: Scanning for PnP cards...
isapnp: SB audio device quirk - increasing port range
isapnp: Card 'Creative ViBRA16C PnP'
isapnp: 1 Plug & Play card detected total
Building card database...

I then get the message

No Supported PnP or PCI card found.
Would you like to probe legacy ISA sound cards/chips?

<yes> <no>

i pick yes then

Probing legacy ISA cards might make your system unstable.

<yes> <no>

what the hell life isn't without risk, i pick yes then

modinfo: snd-op13sa2: no module by that name found
modinfo: snd-cs4236: no module by that name found
modinfo: snd-cs4232: no module by that name found
modinfo: snd-cs4231: no module by that name found
modinfo: snd-es18xx: no module by that name found
modinfo: snd-es1688: no module by that name found
modinfo: snd-sb16: no module by that name found

then back to the command prompt, there seems to be a trend going on there:)

so then i read about trying

#depmod -a

the cursur hangs for a couple of sec's then bam the command line pops back

i then typed #modprobe snd

and it returned

modprobe: Can't locate module snd

then tried #alsaconf again no luck

so i then tried

#apt-get install alsa-utils
#apt-get install alsa-base

and the computer returns they are already the newest versions. So I tried...

#apt-get install alsa-modules

but that has been replaced with alsa-base from what the computer tells me

next step i read was try #lspci:

0000:00:00.0 Host bridge: VIA Technologies, Inc. VT82C598 [Apollo MVP3] (rev 04)

0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro13 3x AGP]

0000:00:07.0 ISA bridge: VIA Technologies, Inc. VT82C586/A/B PCI-to-ISA [Apollo VP] (rev 47)

0000:00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)

0000:00:07.3 PCI bridge: VIA Technologies, Inc. VT82C586B ACPI (rev 10)

0000:00:08.0 VGA compatible controller: S3 Inc. 86c325 [ViRGE] (rev 06)

not real sure what that was for assuming it was to tell me or u whats in the pci slots? correct me if I'm wrong, I'm curious.

My soundcard is plugged up in my ISA-3 slot.

Oh i also tried #apt-get install sndconfig

but that was a deadend, it's obsoleted, [B]E: Package sndconfig has no installation candidate[/B.

I geuss alsaconf replaces that?

Thanks in advance for any advice or help u can give me.:)

Oh I also tried #alsamixer

gave me back

alsamixer: function snd_ctl_open failed for default: No such device

b0uncer 07-28-2006 05:32 AM

Hmm..well for the module-hunting, if you're feeling a lucky punk (in the good way :) heh) and "know your enemy", the chip I mean, try


modprobe -l | less
Then scroll down down down, line by line, and when you see a filename that sounds familiar and could be The One for your sound card, write the name down (filename without the dot-something, like ".ko"). Once you're finished the list, try to load it/them:


modprobe modulename
where modulename is the name you hopefully found from the list. After this try your sound device again, hopefully with a better luck.

That should work in the case the appropriate module for the soundcard is not in the kernel, but is available for you. If that's not the case, but there really is a kernel module (but you just lack it), there's this option for recompiling the kernel yourself. It's not as difficult as it may sound; basically you just extract the current config from the running kernel, if possible, then download stock kernel sources, edit the configuration (=add the needed module), recompile, copy the kernel to /boot and reboot. Well it's even easier than the text above sounds, but I hope you'll do without it for a while anyway :)

Good luck,


thedu 07-28-2006 03:50 PM

hmm, what is the symbol between -l less i can't seem to find it on my keyboard and is that how i'm supposed to type it

i ran ran just #modprobe -l

and it came a list but all i get to see is the tail end the rest flashes by to fast


rickh 07-28-2006 04:22 PM


Kernel: 2.4.27-2-386
I'd try installing a 2.6 kernel from

If your computer is not a critical production system, the best solution is to move from Sarge to Etch. Etch (testing) is a very stable system, and generally better suited for hobby systems than Sarge.

thedu 07-28-2006 06:02 PM

I'd really rather exhaust every possibility for trying to get my sound card working with what i have before putting a new kernel in or switching from sarge to etch.

It seems to me the modules or not loading or are not in the right place.

i would like to know what that symbol between -l & less is, and if it's crucial to the modprobe command

i've seen it before on other post and can't seem to find it on my keyboard

also how do you get your computer to keep stuff from scrolling off the screen before u have a chance to read it


luis14 07-28-2006 11:42 PM


i would like to know what that symbol between -l & less is
vertical line/pipe/broken bar ( | ) ( ) you can find it on the key directly below the backspace key. It's the colon looking symbol above the backslash symbol

also how do you get your computer to keep stuff from scrolling off the screen before u have a chance to read it
I don't know if you can freeze the display, but you can use your keyboard to scroll up and down the display with Shift + Page Up and Shift + Page Down.
Hopefully these tips will serve you well. Good luck with your sound card.

rickh 07-28-2006 11:57 PM


how do you get your computer to keep stuff from scrolling off the screen before u have a chance to read it
That's what "| less" will do.

luis14 07-29-2006 12:06 AM


That's what "| less" will do.

TigerOC 07-29-2006 05:02 AM

As root open a consol and do modconf. If it says not found do apt-get install modconf. This should bring up a menu. Go down the list until you find something like /kernel/sound/isa there may be separate listing /kernel/sound/isa/sb or it may be under generic isa but you need to select the relevant module and install. The tool will configure everthing for you. You should then be able to configure your sound system. That is really old hardware though.

thedu 07-29-2006 08:43 AM

i ran #modprobe -l | less

and it gave me back these prospects


so i ran #modprobe sb and #modprobe sb_lib

both just pop back to the command line

and then I ran #alsaconf

it does the same thing as before can't seem to find modules

so I then ran #apt-get install modconf

and then #modconf

i didn't see anything like /kernel/sound/isa or /kernel/sound/isa/sb but there was kernel/drivers/pnp-Drivers for plug and play so selected that and enebled isa-pnp +ISA Plug and Play

then i selected kernel/drivers/sound - Sound Cards and made sure sb_lib - Support for OPTi, MAD16 and/or & sb - 100% Sound Blaster compatibles were enabled which they were i then exited the program

ran #alsaconf again no change

i ran #modinfo snd

modinfo: snd: no module by that name found

i ran #modinfo sound

filename: /lib/modules/2.4.27-2-386/kernel/drivers/sound/sound.o
description: "OSS Sound subsystem"
author: "Hannu Savolainen, et al."
license: "GPL"
parm: dmabuf int
parm: dmabug int

i then ran #modprobe snd

modprobe: Can't locate module snd

i then ran #modinfo soundcore

filename: /lib/modules/2.4.27-2-386/kernel/drivers/sound/soundcore.o
description: "Core sound module"
author: "Alan Cox"
license: "GPL"

i ran #alsamixer again also

[B]alsamixer: function snd_ctl_open failed for default: No such device[B]

there was antoher command I ran but I can't rember it at the moment, oh well it will come to me

thanks for all ya'lls help so far

thedu 08-02-2006 02:47 AM

Well i exhausted every possibilty to get the sond card up and running so i upgraded...

I went on and and 256mb of DIMM Ram to the system, added a K6 400 cpu,&also added a Kingston Technology EtherRx 10/100BBase-Tx Ethernet card Model number KNE110TX to speed up the security update process(previously it took 9hrs, now with my DSL acess it took 20min) Due to a great shop here town that sells older computer parts I was able to do this for about $30.:)

I then reinstalled Sarge Debian, at the boot prompt i entered Linux26 to get a 2.6 kernel and went to town. It reconized the ehternet card no problem so if anybody lookings for a good cheap card to use on a older machine i def recommend it.

Once the machine was up I ran #alsaconf and with no problen it found the SoundBlaster 16 Card and installed the required drivers. Works great now. I'm still not sure if I understand why it would run on 2.6 kernel and not the 2.4 kernel but that will come in time.:)

Thanks again for all ya'lls help help and advice on this problem.:)

All times are GMT -5. The time now is 11:11 PM.