-   Debian (
-   -   Wireless switch doesn't work after upgrade/dist-upgrade (

angelofhope 12-29-2007 06:03 PM

Wireless switch doesn't work after upgrade/dist-upgrade

After the last upgrade/dist-upgrade the wireless switch (Fn-F2) on my
Asus W7j doesn't seem to be able to switch on the wireless anymore, it
does still togle the bluetooth but at max only lets the wireless led blink.

I can get the wireless led on with echo 1 > /proc/acpi/asus/wled, but
that doesn't make the card work
When I cat that file before and after pressing the switch combination it
always says 0.

I'm using debian lenny, atm 2.6.22-3-amd64, wireless card:
06:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG
Network Connection (rev 02)

Also, the switch seems to work during the startup, untill just before gdm starts (but it probably isn't gdm, since that didn't start at first because I had to reinstall nvidia module, and then the wireless switch didn't work either)
During poweroff sequence it seems to work also
This seems particulary strange to me

Any ideas where to look for a solution?


MoonMind 12-29-2007 06:17 PM

Sorry to ask something like that, but did you check if the connection actually worked while the LED didn't? I read something similar just recently - it appears to be happening sometimes with Intel chipsets... (I think it was Ubuntu and not Debian, though).

If that's not the case I'd say look at the output of lsmod, iwconfig and possibly ifconfig to determine to what extend things work or don't...


angelofhope 12-29-2007 06:23 PM

Yes, it doesn't work.
lsmod |grep 3945 gives:
ipw3945 209316 1
ieee80211 38600 1 ipw3945
firmware_class 15360 1 ipw3945

lo no wireless extensions.

eth1 no wireless extensions.

eth2 no wireless extensions.


eth1 Link encap:Ethernet HWaddr 00:18:f3:6a:60:9d
inet addr: Bcast: Mask:
inet6 addr: fe80::218:f3ff:fe6a:609d/64 Scope:Link
RX packets:14224 errors:0 dropped:0 overruns:0 frame:0
TX packets:11826 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:12664098 (12.0 MiB) TX bytes:1611779 (1.5 MiB)
Interrupt:17 Base address:0xc000

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:14 errors:0 dropped:0 overruns:0 frame:0
TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:700 (700.0 B) TX bytes:700 (700.0 B)

I'm connected through eth1 now, this is wired.
Normally (and as it seems to do so on startup), the wireless connection is renamed to eth2 (from eth0 if I'm not mistaking)
ifup eth2

Any ideas where it might go wrong?


Oh, it seems I was mistaking, the bluetooth doesn't seem to switch either atm...

MoonMind 12-30-2007 05:23 AM

The renaming (and reordering) of the devices is strange enough as it is (where's eth0 - have you done ifup eth0 just for the sake of trying); anyhow, the kernel modules are there, and complete, at that (including firmware) - did you check if the modules are okay (they sure should be)?

Whatever happens here seems to happen early - try dmesg | grep eth (you can also grep for "ipw"). But frankly, I don't see why something like this should happen. At least, kernel-wise, everything seems to be okay, networking's basically working... Maybe some hardware recognition conflict (too many tools in place)? Does all other hardware work as expected?


angelofhope 12-30-2007 05:40 AM

ifup eth0 doesn't do anything:

Ignoring unknown interface eth0=eth
ifup eth2 seems to bring up an interface, but iwconfig doesn't show it and when I go in system>administration>network it shows as a "wired connection", off course I can't connect to my wireless router like that:

# ifup eth2
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit

Listening on LPF/eth2/00:18:de:88:7c:76
Sending on  LPF/eth2/00:18:de:88:7c:76
Sending on  Socket/fallback
DHCPDISCOVER on eth2 to port 67 interval 3
DHCPDISCOVER on eth2 to port 67 interval 5
DHCPDISCOVER on eth2 to port 67 interval 13
DHCPDISCOVER on eth2 to port 67 interval 15
DHCPDISCOVER on eth2 to port 67 interval 18
DHCPDISCOVER on eth2 to port 67 interval 7
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
if-up.d/mountnfs[eth2]: lock /var/run/network/mountnfs exist, not mounting
# iwconfig
lo        no wireless extensions.

eth1      no wireless extensions.

eth2      no wireless extensions.
# ifconfig eth2
eth2      Link encap:Ethernet  HWaddr 00:18:de:88:7c:76 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:18 Base address:0x6000 Memory:fe9ff000-fe9fffff

The mac-adress seems to be the one, if I remember correctly...if that is of any help

Output of dmesg:

# dmesg |grep eth
eth0: RTL8168b/8111b at 0xffffc200005fc000, 00:18:f3:6a:60:9d, IRQ 17
udev: renamed network interface eth0 to eth1
udev: renamed network interface eth0 to eth2
r8169: eth1: link up
r8169: eth1: link up
device eth1 entered promiscuous mode
audit(1199010028.118:2): dev=eth1 prom=256 old_prom=0 auid=4294967295
eth1: no IPv6 routers present
ADDRCONF(NETDEV_UP): eth2: link is not ready

# dmesg |grep ipw
ipw3945: Intel(R) PRO/Wireless 3945 Network Connection driver for Linux, 1.2.2dmpr
ipw3945: Copyright(c) 2003-2006 Intel Corporation
ipw3945: Detected Intel PRO/Wireless 3945ABG Network Connection
ipw3945: Detected geography ABG (13 802.11bg channels, 23 802.11a channels)
ipw3945: Radio Frequency Kill Switch is On:
ipw3945: Radio Frequency Kill Switch is On:
ipw3945: Radio Frequency Kill Switch is On:
ipw3945: Radio Frequency Kill Switch is On:
ipw3945: Radio Frequency Kill Switch is On:

What I find strange is:
udev: renamed network interface eth0 to eth1
udev: renamed network interface eth0 to eth2
Is it correct that it seems to rename the same interface twice?

What I also tried:

# echo 0 > /sys/bus/pci/drivers/ipw3945/0000\:06\:00.0/rf_kill
# cat /sys/bus/pci/drivers/ipw3945/0000\:06\:00.0/rf_kill

# echo 1 > /sys/bus/pci/drivers/ipw3945/0000\:06\:00.0/rf_kill
# cat /sys/bus/pci/drivers/ipw3945/0000\:06\:00.0/rf_kill

After this I did an ethdown and ethup, but it didn't seem to change anything

Thanks for the sugestions already

Oh, and I didn't notice anything else not working (except the webcam, that didn't work to start with), only a warning sometimes about a low capacity of my battery and that it might be broken, which is very strange. And my processors seem to run at 1Mhz at the moment, but this just adjusts itself when I open more processes, so no worries there.
One odd thing is that my bar that shows the open programs minimized (gnome-panel?), seems to stop working sometimes... quite annoying.

MoonMind 12-30-2007 05:57 AM

Yes, udev acts strangely: It seems to "recognize" the Intel chipset as a RealTek one if I'm not mistaken. After that, it tries to rearrange devices - "working" ones first (eth0 can't go to eth1 since that place is already taken by the ethernet device, thus landing the wireless one on eth2). That at least can be seen as "logical" (why it should be of any help remains a mystery). The whole point seems to be that at the moment of network configuration, the kernel module for the Intel chipset is still missing. However installing it later should have made the chipset work - but maybe the device is still "configured" by the wrong driver - lsmod | grep rtl may reveal that. If it's the case, try modprobe -r the module ("rt(l)8168(b)" something?).


angelofhope 12-30-2007 06:29 AM

lsmod | grep rtl doesn't give anything, just to be sure I did lsmod:

Module                  Size  Used by
nls_iso8859_1          9600  1
nls_cp437              11392  1
vfat                  17920  1
fat                    58160  1 vfat
nvidia              8118232  26
i2c_core              31488  1 nvidia
rfcomm                49448  0
button                13472  0
ac                    10376  0
battery                15496  0
acpi_cpufreq          13704  0
cpufreq_userspace      9472  0
cpufreq_conservative    12424  0
cpufreq_powersave      6272  0
cpufreq_ondemand      13328  2
cpufreq_stats          10400  0
freq_table              9600  3 acpi_cpufreq,cpufreq_ondemand,cpufreq_stats
ipv6                  296840  16
fuse                  50608  1
dm_snapshot            21704  0
dm_mirror              26240  0
dm_mod                64112  2 dm_snapshot,dm_mirror
coretemp              12544  0
hidp                  29824  3
hid                    31360  1 hidp
l2cap                  32768  14 rfcomm,hidp
asus_acpi              23084  0
firewire_sbp2          18180  0
loop                  23044  0
joydev                15616  0
tsdev                  13312  0
snd_hda_intel        311968  2
snd_pcm_oss            48288  0
snd_mixer_oss          21376  2 snd_pcm_oss
snd_pcm                89992  2 snd_hda_intel,snd_pcm_oss
ipw3945              209316  1
snd_timer              28424  1 snd_pcm
sdhci                  22668  0
ieee80211              38600  1 ipw3945
ieee80211_crypt        11008  1 ieee80211
snd                    65896  7 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
iTCO_wdt              15824  0
hci_usb                22684  3
mmc_core              34824  1 sdhci
serio_raw              11780  0
evdev                  15232  8
psmouse                45468  0
pcspkr                  7680  0
\intel_agp              32032  0
soundcore              13088  2 snd
firmware_class        15360  1 ipw3945
bluetooth              64516  8 rfcomm,hidp,l2cap,hci_usb
snd_page_alloc        15376  2 snd_hda_intel,snd_pcm
ext3                  137232  2
jbd                    68080  1 ext3
mbcache                13832  1 ext3
ide_cd                44832  0
cdrom                  39848  1 ide_cd
sd_mod                33280  5
generic                10372  0 [permanent]
piix                  14980  0 [permanent]
ata_piix              19844  4
ide_core              147728  3 ide_cd,generic,piix
firewire_ohci          22784  0
firewire_core          49728  2 firewire_sbp2,firewire_ohci
crc_itu_t              6656  1 firewire_core
ata_generic            13188  0
libata                132528  2 ata_piix,ata_generic
scsi_mod              164536  3 firewire_sbp2,sd_mod,libata
ehci_hcd              37900  0
uhci_hcd              29856  0
r8169                  36488  0
thermal                19600  0
processor              39912  2 acpi_cpufreq,thermal
fan                    9992  0

I don't really see anything that could be replacing ipw3945, but maybe I don't really know what I'm looking for :s

Oh, wait, the realtek is the wired connection it seems:
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
06:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)


MoonMind 12-30-2007 11:18 AM

Okay, now I'm definitely at a loss. You're right about the wired/wireless chipsets, so from what you report, everything *appears* to be in order. But since it doesn't work, it isn't :/ Besides, the Realtek NIC's module is "r8169", which is a bit confusing, but seems to be correct.

The only hunch I've left is that there's something wrong with the module loading on boot up, but it beats me why this should happen or not be corrected later, respectively. I'm afraid we'll have to ask someone else to sort this out... I'm sorry.


angelofhope 12-31-2007 08:31 AM

No problem, a big thank you for trying to help!

Is there anyone with other sugestions? The problem still remains


norobro 01-01-2008 09:39 PM

eth2 says it is up and listening but has received no dhcpoffers.

Just a thought: do you have MAC address filtering enabled on your router? I get messages like that if I have to change out a card and forget to add the new MAC address to the router's list.


angelofhope 01-02-2008 05:46 AM

It's not a router problem, I can't even get the card to show up in iwconfig. If it would be a router problem, the card would show up in iwconfig and I could scan for routers with iwlist. At least that's what makes sense to me...
Thanks already, more sugestions still welcome

All times are GMT -5. The time now is 07:20 PM.