LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 01-30-2006, 01:17 PM   #1
mrlucio79
Member
 
Registered: Jun 2003
Posts: 55

Rep: Reputation: 15
Cool why why why?


Why do I always get this error message when I update my kernel?

Kernel Panic: VFS: Unable to mount root fs on 00:00

I am upgrading from the Sarge Stock kernel to 2.6.15.1. I have been tinkering with linux for years now, but I am no guru at the kernel. It's a downer everytime i see this error message. I have seen this error in my past installs of redhat, slackware, and debian. I go to this linux workshop from time to time and the only answer i get from them is to "reinstall the OS" Well that is not the answer i am looking for, I want to know what causes this kernel panic. why why why? Thanks!
 
Old 01-30-2006, 01:38 PM   #2
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
I wish I knew too. I've been trying to install several distributions on a cheap pc back home, and this far I've only been able to use RedHat 8 and 9 and Fedora 4 with it (Fedora 1-3 did install, but didn't work that nicely). All the others (Ubuntu, Arch, Vector..just pick a book and name it) give out that "Unable to mount root fs on ..." -message. I can't understand for my life what causes it..and the most fancy thing in it is that it gets printed when I try to start the installation program - before I've even updated anything. I've tried several possible modules to be loaded into the kernel (or out?), and nothing has helped..

And nobody seems to know exactly why. Tell me if you get lucky..
 
Old 01-30-2006, 02:18 PM   #3
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,618

Rep: Reputation: 104Reputation: 104
Quote:
Originally Posted by mrlucio79
Why do I always get this error message when I update my kernel?

Kernel Panic: VFS: Unable to mount root fs on 00:00

I am upgrading from the Sarge Stock kernel to 2.6.15.1. I have been tinkering with linux for years now, but I am no guru at the kernel. It's a downer everytime i see this error message. I have seen this error in my past installs of redhat, slackware, and debian. I go to this linux workshop from time to time and the only answer i get from them is to "reinstall the OS" Well that is not the answer i am looking for, I want to know what causes this kernel panic. why why why? Thanks!
Debian has changed the way the initrd's are made it is possible that if all you upgraded was the kernel itself you did not get the supporting packages needed. So did install anything else besides the kernel? You may also want to check in your /boot directory to make sure that the initrd matching the kernel is there and your /etc/lilo.conf or /boot/grub/menu.lst depending on which you are using is setup to boot with an initrd. What is causing your problem is that you have no support for your /root filesystem available when it goes to load it, this is where the initrd (inital root device I believe it is short for) comes into play it loads the module needed to mount the file system unless of course you have built your own kernel with the support compiled in then it is not needed.
 
Old 01-30-2006, 03:03 PM   #4
saman007uk
Member
 
Registered: Dec 2003
Location: ~root
Distribution: Debian
Posts: 364

Rep: Reputation: 33
You know, a better subject might help. "why why why?" isn't that much useful.
 
Old 01-30-2006, 04:38 PM   #5
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Rep: Reputation: 49
Quote:
Originally Posted by mrlucio79
Why do I always get this error message when I update my kernel?

Kernel Panic: VFS: Unable to mount root fs on 00:00

I am upgrading from the Sarge Stock kernel to 2.6.15.1. I have been tinkering with linux for years now, but I am no guru at the kernel. It's a downer everytime i see this error message. I have seen this error in my past installs of redhat, slackware, and debian. I go to this linux workshop from time to time and the only answer i get from them is to "reinstall the OS" Well that is not the answer i am looking for, I want to know what causes this kernel panic. why why why? Thanks!

Once you install your kernel do this:

Code:
mkinitrd -o /boot/initrd.img-2.6.8 2.6.8
Just substitute 2.6.8 with your own kernel version. And I think that should solve your problem. Make sure to add the initrd lines in your grub/lilo conf file.
 
Old 01-30-2006, 07:32 PM   #6
mrlucio79
Member
 
Registered: Jun 2003
Posts: 55

Original Poster
Rep: Reputation: 15
Cool

just added the init image and still no luck:

VFS: Cannot open root device "hda1" or unknown-block(0,0)
Please append a correct "root=" boot option
kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)


When i create my kernel using kpkg what processor architure should it be designed as. Looks like it is being packaged as a 386. It is a pentium 4.
 
Old 01-30-2006, 07:36 PM   #7
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Rep: Reputation: 49
Quote:
Originally Posted by mrlucio79
just added the init image and still no luck:

VFS: Cannot open root device "hda1" or unknown-block(0,0)
Please append a correct "root=" boot option
kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)


When i create my kernel using kpkg what processor architure should it be designed as. Looks like it is being packaged as a 386. It is a pentium 4.

Can you post your menu.list or lilo.conf file?
 
Old 01-30-2006, 07:54 PM   #8
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,618

Rep: Reputation: 104Reputation: 104
Quote:
Originally Posted by mrlucio79
just added the init image and still no luck:

VFS: Cannot open root device "hda1" or unknown-block(0,0)
Please append a correct "root=" boot option
kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)


When i create my kernel using kpkg what processor architure should it be designed as. Looks like it is being packaged as a 386. It is a pentium 4.
i686 and you need to compile in support for the file system you are using plus the chipset on the motherboard here is a guide it is for a 2.4 kernel but the principal is the same the names of the modules may have changed a bit though.
 
Old 01-31-2006, 07:24 PM   #9
mrlucio79
Member
 
Registered: Jun 2003
Posts: 55

Original Poster
Rep: Reputation: 15
title Debian GNU/Linux, kernel 2.6.15.1
root (hd0,0)
kernel /boot/vmlinuz-2.6.15.1 root=/dev/hda1 ro
initrd /boot/initrd.img-2.6.15.1
savedefault
boot

title Debian GNU/Linux, kernel 2.6.15.1 (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.15.1 root=/dev/hda1 ro single
initrd /boot/initrd.img-2.6.15.1
savedefault
boot

title Debian GNU/Linux, kernel 2.4.27-2-386
root (hd0,0)
kernel /boot/vmlinuz-2.4.27-2-386 root=/dev/hda1 ro
initrd /boot/initrd.img-2.4.27-2-386
savedefault
boot

title Debian GNU/Linux, kernel 2.4.27-2-386 (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.4.27-2-386 root=/dev/hda1 ro single
initrd /boot/initrd.img-2.4.27-2-386
savedefault
boot


hopefully this helps.... Thanks you all for the quick responses
 
Old 01-31-2006, 08:18 PM   #10
lestoil
Member
 
Registered: Apr 2004
Location: new york
Distribution: win2k,ubuntu,sw13,arch,centos5.3
Posts: 815

Rep: Reputation: 31
www.hydrus.org explains that going from stock 2.4x sarge kernel to 2.6.10 or higher causes problem with ramdisk formation hence the error messages. Before going to 2.6.14 or 2.6.15 kernel ,2.4x should be upgraded to 2.6.8x then to higher kernel number. It is similar story in potatoe going from 2.2x to 2.6x w/o going thru 2.4 from sarge.
 
Old 02-01-2006, 04:47 AM   #11
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
Quote:
Originally Posted by mrlucio79
just added the init image and still no luck:

VFS: Cannot open root device "hda1" or unknown-block(0,0)
Please append a correct "root=" boot option
kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)


When i create my kernel using kpkg what processor architure should it be designed as. Looks like it is being packaged as a 386. It is a pentium 4.
You didn't do the initrd image correctly, how do I know? Because I ran into the same problem when recently updating from 2.6.8 to 2.6.15 and didn't even realize that I had to make an initrd image from the new kernel. So maybe you should read more carefuly and do your initrd image properly and you'll fix the problem I promise.

Here is a pervious thread to the same problem:
http://www.linuxquestions.org/questi...d.php?t=403178
 
Old 02-07-2006, 05:01 PM   #12
JamesKelson
LQ Newbie
 
Registered: Nov 2005
Location: My bedroom
Distribution: Slackware
Posts: 24

Rep: Reputation: 15
intersting tidbit:

initrd stands for initial ram disk
its used if you happen to have a kernel already installed and compiled, and it does not have your filesystem compiled into the kernel

your kernel must be supported in module form though
it is just a fake root partiton with the ability to load modules, and reload the root on your hd

personally i recomed not even monkeying around with initrd, just recompile your kernel with support and wolla no more use for initrd

another interesting tidbit:

as i understand it the slackware site recommends loading your root partiton WITH initrd, which goes against every other online tutorial i can find

as for your question, why why why, not being able to load the superblock is a pretty serious thing to panic about lol. you should be panicking too
no usually this is just because the kernel doesnt have filesystem or hardware support

but what do i know? neither way works for mine lol, as of now, i'm stuck on the 2.4 kernel
will find the problem though, most likly just havent loaded the right modules for my ide board
 
Old 02-13-2006, 03:52 PM   #13
truks
LQ Newbie
 
Registered: Feb 2006
Posts: 1

Rep: Reputation: 0
I caused myself this problem...

In building a hardened kernel for a firewall, I turned off the ram disk capability, thereby making the initrd image file useless! The file was being created, but the kernel couldn't load or use it.

I suppose I should make the changes to bypass the need for the image file, since I am compiling the fs drivers in, and not using modules for those.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 01:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration