LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   Where is my xorg.conf gone (https://www.linuxquestions.org/questions/debian-26/where-is-my-xorg-conf-gone-384451/)

NNP 11-18-2005 03:46 PM

Where is my xorg.conf gone
 
Hey, im trying to edit my xorg.conf file but i cant find the damn thing. There is no trace of it in /etc/X11/ at all. An ls of the directory gives
Code:

debian:/etc/X11# ls -al
total 92
drwxr-xr-x  13 root root  4096 2005-08-07 16:10 .
drwxr-xr-x  102 root root  4096 2005-11-18 19:52 ..
drwxr-xr-x    2 root root  4096 2005-11-12 22:15 app-defaults
drwxr-xr-x    2 root root  4096 2005-08-07 16:06 cursors
-rw-r--r--    1 root root    13 2005-08-07 16:10 default-display-manager
drwxr-xr-x    7 root root  4096 2005-08-07 16:06 fonts
lrwxrwxrwx    1 root root    6 2005-08-07 16:03 gdm -> ../gdm
-rw-r--r--    1 root root 17371 2005-06-01 06:56 rgb.txt
drwxr-xr-x    4 root root  4096 2005-08-07 16:07 rstart
drwxr-xr-x    2 root root  4096 2005-08-07 16:10 sysconfig
lrwxrwxrwx    1 root root    20 2005-08-07 16:07 X -> /usr/bin/X11/XFree86
-rw-r--r--    1 root root  3223 2005-08-07 17:43 XF86Config-4
drwxr-xr-x    2 root root  4096 2005-08-07 16:08 xinit
drwxr-xr-x  10 root root  4096 2005-08-07 16:08 xkb
drwxr-xr-x    2 root root  4096 2005-08-07 16:08 Xresources
drwxr-xr-x    2 root root  4096 2005-08-07 16:07 xserver
-rwxr-xr-x    1 root root  3456 2005-06-01 06:59 Xsession
drwxr-xr-x    2 root root  4096 2005-08-07 16:10 Xsession.d
-rw-r--r--    1 root root  217 2005-06-01 06:59 Xsession.options
drwxr-xr-x    2 root root  4096 2005-08-07 16:08 xsm
-rw-------    1 root root  773 2005-08-07 16:07 Xwrapper.config
debian:/etc/X11#

I've tried using locate for anything to do with xorg but no luck at all.

Any ideas?

makuyl 11-18-2005 03:57 PM

Umm, are you sure you're using xorg instead of xfree?
Looks like XF86Config-4 is your config.

NNP 11-18-2005 06:34 PM

yes, thats it cheers. On the same topic, the reason i wanted to edit this file is that for some reason if i click on the option to set my screen resolution i cant select anything higher than 1024*768, i've tried editing the section in the X11 config file mentioned above but there are still no extra options... here is what that part looks like now

Code:

Section "Screen"
        Identifier      "Default Screen"
        Device          "Generic Video Card"
        Monitor        "___:ffff"
        DefaultDepth    24
        SubSection "Display"
                Depth          1
                Modes          "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth          8
                Modes          "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth          15
                Modes          "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth          16
                Modes          "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth          24
                Modes          "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection

The only options i get to select though are 1024x768 and down. Does anyone have any ideas as to how i might fix this.

XavierP 11-18-2005 06:42 PM

What make of video card do you have? At the moment, you are using the onboard basic generic drivers. If you have an Nvidia, Ati or Intel card, you should go to the site and download the full drivers. This should fix your resolution problem.

junkman4547 11-18-2005 10:51 PM

You monitor vertical and horizontal sync frequencies are also important.
If they are not high enough, you won't have higher resolutions. In any case ... try this code as root

#dpkg-reconfigure xserver-xfree86

remember to have your monitor sync freqs. ready.

makuyl 11-19-2005 08:31 AM

Might as well change this: DefaultDepth 24
to this: DefaultDepth 16

NNP 11-21-2005 02:50 PM

I tried to update to nvidia gfx drivers but i keep getting wierd errors. Initially if i just do
Code:

sh NVIDIA-name-of-driver
I get some erros about not having a kernel interface, it offers to download one but then says it cant find a compatible one. Then it says it cant create one eithre as it cant find my kernel tree or some such. It recommend i specify where my kernel source was so i did like so

Code:

sh Nvidia-name-of-driver --kernel-source-path /usr/src/kernel-source-2.4.27.tar.bz2
but it gave the exact same errors as above and then at the end said something about the path i had given not existing.

ANy ideas?

Cheers,
NNP

makuyl 11-21-2005 03:26 PM

How about:
su
cd /usr/src
tar xjf kernel-source-2.4.27.tar.bz2
ln -s name-of-untarred-source linux
sh NV......

btw, the source must match the running kernel.

lpd 11-21-2005 03:43 PM

The nvidia drivers need an unpacked linux-kernel, not a tar file.
It needs to read from header files that detail what options your kernel support and how to call them. If you're using a precompiled kernel you can install the package kernel-headers-XXX where XXX has the same name and number as the kernel you are running.
The kernel headers will be unpacked in /usr/src/kernel-headers-XXX and you can point the nvidia-installer to that directory.
There are also debian packaged of the nvida-drivers and preferably you should use those.

NNP 11-28-2005 01:02 PM

hmm, i got the correct headers after a little looking as well as the nvidia package.

Its running ok but there's no output.

Code:

debian:/usr/src/modules/nvidia-kernel/nv# make SYSINCLUDE=/usr/src/kernel-headers-2.4.27-2/include
Should it say something? Or what am i supposed to do?

CHeers

By the way, this is whats in the folder where the nvidia package source was after running the makefile

Code:

debian:/usr/src/modules/nvidia-kernel/nv# ls
conftest.sh          Makefile.nvidia  nv-misc.h  os-interface.c
gcc-version-check.c  nv.c            nvtypes.h  os-interface.h
makedevices.sh      nv.h            nv-vm.c    os-registry.c
makefile            nv-kernel.o      nv-vm.h    pat.h
Makefile            nv-linux.h      os-agp.c  README
Makefile.kbuild      nv-memdbg.h      os-agp.h  rmretval.h
debian:/usr/src/modules/nvidia-kernel/nv#


dastrike 11-28-2005 01:20 PM

Regarding the installation of the NVIDIA's proprietary display drivers, please see the documentation I have written about that: Debian NVIDIA proprietary display driver installation

And as for higher resolutions not being available, a common cause for that is that the horizontal sync and vertical refresh values for the monitor are set too low. Look in your monitor's manual to find out what the ranges are supposed to be for your monitor.

NNP 11-28-2005 02:04 PM

*sigh*

I've followed your tutorial to the letter and its still not working.

I've created the symlink etc.. here is the output of ls

Code:

nnp@debian:~$ ls -l /lib/modules/$(uname -r)/build
lrwxrwxrwx  1 root root 36 2005-11-28 19:47 /lib/modules/2.4.27-2-686/build -> /usr/src/kernel-headers-2.4.27-2-686
nnp@debian:~$

Then when i run the installer it seems to ignore the symlink completly and tells me /lib/modules/2.4.27-2-686/build is not a valid path or something similar.

I then tried to specify where the headers were again using

Code:

sh Nvidia etc... --kernel-source-path /usr/src/kernel-headers-etc
And it tried to tell me that /include/linux/kernel.h doesnt exist at that location, but guess what... it does.

Code:

nnp@debian:~$ ls /usr/src/kernel-headers-2.4.27-2-686/include/linux/ | grep kernel.h
devfs_fs_kernel.h
kernel.h
nnp@debian:~$

EDIT: Off topic but anyways, say i had misplaced my monitors manual ;) is there any reliable way to find out its horizontal sync and vertical refresh values? Its a dell 19inch flat screen, i could get the model number i'd imagine but how helpful are dell?

dastrike 11-28-2005 03:25 PM

Hm. Peculiar issue. I cannot say that I have encountered that one before. Have you tried with the other installation method, the one involving installing it through apt-get and building the kernel module with make-kpkg? It is a bit more involved due to the many small steps, but it is worth trying out too.

And regarding the monitor frequencies, a search on google for
horizontal sync vertical refresh monitor brand monitor model
or some variation thereof should give some reasonable results. Or try to find the specs online on the manufacturer's website.

farslayer 11-28-2005 03:46 PM

I ran into a problem with the 2.6.8 kernel when trying to install the nVidia drivers.. 2.6.8 was incompatible with the GCC version on my machine..(don't ask me how.. but it was) once I Installed the 2.6.12 kernel I had no trouble compiling and installing the nVidia drivers. Wierd I know but that's what happened. it is a peculiarity to that kernel version in Debian i believe.


as for the monitor specs.. if you pull up the On Screen Menu on the monitor you know where you adjust horizontal & vertiocal size, contrast, brightness etc.. does it list the frequency ranges of the monitor ? I have several monitors that do. Just athought.

NNP 11-28-2005 05:18 PM

I found the specs on teh dell site
http://support.dell.com/support/edoc...P/en/specs.htm

and update my XF86config accordingly
Code:

Section "Monitor"
        Identifier      "___:ffff"
        HorizSync      30-80
        VertRefresh    56-76
        Option          "DPMS"
EndSection

It still doesnt present the option to set it into 1280X1024 mode though so i guess i'll struggle on with this driver lark. Cheers


All times are GMT -5. The time now is 02:50 PM.