-   Debian (
-   -   Wheezy netinstall can't configure DHCP (

penyuan 11-30-2011 12:55 PM

Wheezy netinstall can't configure DHCP

I am reinstalling my Debian system with the Wheezy netinstall image on a USB drive.

I have a wireless router that also comes with ethernet ports, so I could either connect to my LAN via wifi OR ethernet.

The installer was able to detect my wireless (wlan0) and wired (eth0) interfaces, but one of the following always happens:

(1) If I try network autoconfiguration for eth0, the process would always fail at the DHCP autoconfigure step (i.e. can't get IP address?). Please note that this works on the machine right before the re-install I am attempting.

(2) If I try network autoconfiguration for wlan0, it successfully authenticates with my wifi network via WPA2, and configures DHCP successfully. However, I get an error saying there is no "default route" setup. What does "default route" mean?

I have tried to cancel/delete all DHCP leases and restarting my router to no avail. I also tried getting into the shell (which is ash) but there's no ifconfig etc. that I could access.

Can anyone help with troubleshooting this problem? Thanks.

62chevy 11-30-2011 09:02 PM

You may need some drive that isn't supplied with Debian but you didn't say it asked for a driver first.

Anyways you should be able to give it a static IP and then switch it over to dhcp after the install.

penyuan 12-01-2011 12:56 PM

Squueze installer works
OK, so after lots of attempts, including trying to use a static IP, I gave up and switched to the Squeeze installer.

The Squeeze installer configured DHCP fine!

Looks like this is an issue with the daily Wheezy net install images?

62chevy 12-01-2011 05:10 PM

I've been using the business card installer that was build on Nov 23 2011. Nice thing about the business card is you can install Stable, Testing and Unstable with it. It's worked on a couple different computers so far but have gotten ones that will not work for various reasons. Testing is Testing after all.

Brains 12-02-2011 09:03 PM

I've always used Debian testing, currently Wheezy. I did a reinstallation on my desktop that was shelved for eight or so months and used the 200+ MB net install CD image off USB. It did the same, it could not configure eth0. So I did the base installation from what it could do off that CD image, rebooted after it finished into command line (as there was no desktop environment) and continued on from there. I always choose this route anyway as Debian's default desktop is Gnome but I prefer KDE.
Anyway, possibly due to not having necessary networking packages in the net install ISO, it did not load the driver for the NIC automatically. A quick command: lspci showed this for the NIC: Ethernet controller: Broadcom Corporation NetXtreme BCM5751. A quick Google search on another computer suggested it uses tg3 driver. Another command: modprobe tg3 loaded the proper driver, then the command: dhclient eth0 got it connected. After slapping in my favorite sources.list, I updated and continued the installation from command line as I usually do.

Although I don't remember where in the Debian installer process, there is the option to go to command line when things are not going well, it is here you can figure out what NIC you have, and at some point down the line if not at this point, you can apply the driver and bring it up with the dhclient command and continue the installation.

penyuan 12-05-2011 01:32 PM

It finally worked. The netinstall image from a couple days ago was able to obtain dynamic IP from my router via DHCP, hopefully it will stay functional for future builds...

All times are GMT -5. The time now is 05:06 AM.