-   Debian (
-   -   weird gnome 2.6 problem: no window title bars, limited mouse actions (

rosslaird 07-08-2004 12:11 PM

weird gnome 2.6 problem: no window title bars, limited mouse actions
I've recently installed gnome from testing ('m using the 2.4.24 kernel) on my Debian Xandros system to compare it with KDE, which works beautifully. The Gnome install from apt went fine (I used init 1 from KDE, then ran apt), and Gnome seems to work: it doesn't crash, and all the applications function.

BUT it's unusable because of two oddities:

1. There are no window title bars on any of the application windows.

2. I cannot use my mouse to resize windows or move them with the alt key. I thought I would work around the no-title-bars problem by moving windows around using alt-drag, but the mouse neither moves nor resizes windows. It works -- all the mouse actions in Firefox work fine, for example -- but nothing happens to the cursor when I hover over a window edge or try to move a window. I've tried it in all kinds of ways.

When Gnome starts a new application, it puts the window in the top left of the screen, covering the applications menu. (I know I can change the location of the menu.) I can't move or resize the window, and therefore can't get at any other applications easily. It's pretty weird. I had to add a logout icon to the taskbar -- that's all I seem to be able to do effectively, is login and logout.

What's going on?



pe2338 07-08-2004 05:31 PM

I don't know how you did it but I feel that you didn't install an appropriate window manager.

Try apt-getting gnome-core as it should drag sawfish or metacity, unless you have another problem

rosslaird 07-08-2004 05:36 PM

I have metacity installed, and I have reinstalled various parts of gnome repeatedly without success. I think the problem is with metacity, but I don't know how to debug it.

macondo 07-09-2004 06:27 PM

What do the people at the Xandros forums say?

Remember, eventhough it is based on Debian, it is tweaked by the Xandros developers for ease of use and package management.

rosslaird 07-09-2004 06:35 PM

Actually, I haven't asked over there. Xandros doesn't support gnome, and virtually all the users are KDE afficianados. I did look around on the forums and didn't find anything, so I thought I'd try here. I also asked on the gnome support forums, but so far nothing.

rosslaird 07-09-2004 11:35 PM

I worked on this a bit -- and finally discovered that I needed to delete all the gnome files in my user directory (all hidden files). That worked. After logging in again, all is well.

p_e_c 11-16-2004 05:34 PM

For those who find this thread thru a search -- Like I did -- thought I'd add that, at least under RH AS3, the responsible file for this behavior was found in ~/.gnome2/session. Removing that file did the trick. Side effect: Apps/Windows that were saved to re-open on login (thru the "Save Current Setup" option at Logout, were lost.


Noostroi 12-09-2004 07:37 PM

I have a feeling that metacity wasn't being run when gnome started...

I think this may have happenned to me, but I just ran metacity (metacity --display=:0) from a console (either a new one, or ssh / rsh into the box in question) and it worked

If you dont use metacity, simply replace metacity with whatever window manager you use, and it may work (or look at the man page to find what its specific "--display" command is)


All times are GMT -5. The time now is 11:28 AM.