-   Debian (
-   -   Webmin: Error - Access Denied (

maerong 01-05-2005 10:34 AM

Webmin: Error - Access Denied
I have done an apt-get install of webmin on to Sarge. Now I am trying to access the web interface from another box on the same network, ie


First I am asked if I want to accept the (default) security certificate, so I say yes. And now, I get

Error - Access Denied for

What have I done wrong?

masand 01-05-2005 02:50 PM

hi there

do u have some kind of firewall running

try turning that off first


maerong 01-06-2005 07:37 AM

I have solved this problem now. It wasn't a firewall issue, the webmin server and client are on the same local network and I wasn't trying to access it from outside.

Turns out the answer is in the documentation:


Basically the default configuration on debian is set to only allow access from listed IP addresses, and the only listed IP address is, ie the webmin server itself.

To edit the configuration, I first installed the lynx web-browser, since I'm not running a desktop on the webmin server, and used that to access webmin:

apt-get install lynx

lynx https://localhost:10000

From there I was able to login and add my local network ( to the allowed list via Webmin Configuration -> IP Access Control. I did get a bit bored of the "unknown security certificate" dialogue popping up on every page, so next time I would choose "Always Accept" the first time it asks.

FInally, restart webmin with

/etc/init.d/webmin restart

and I can now login to webmin from my PC!


masand 01-06-2005 07:51 AM

good that it is working now

and thanks for sharing the info!!


ghight 01-06-2005 08:41 AM

Thats a nice way of doing it but you can also just manually edit the /etc/webmin/miniserv.conf file. All you do is comment out or add your local network on the 'allow' line. It will look something like this:



rajeshb12 12-02-2015 12:16 AM

thanks for the reply @masand .I was also facing the same problem .I looked into miniserv.conf located at /etc/webmin/miniserv.conf file. At the end of the file I found
`allow` parameter and hence I added my ips to which I want to allow webmin interface.
It looks like this:



nathan wells 10-25-2016 07:39 PM

just wait for
wait for
60 secs
u will have all of it.....i mean the login still

All times are GMT -5. The time now is 11:12 AM.