-   Debian (
-   -   Web start java not working (java works fine) (

powadha 05-31-2004 05:34 AM

Web start java not working (java works fine)
I'm using java j2re1.4 - Blackdown Java(TM) 2 Runtime Environment, Standard Edition and it works fine in Mozilla 1.6. Trying to download a file true happy puppy doesn't work. I get an applet stating I need the web start plugin. Googling only points me to j2re which I've already installed. Is there someway to enable the web start in Mozilla so I can download files from


mrcheeks 05-31-2004 07:28 AM

add a symbolic link of the java plugin to mozilla plugin directory.

powadha 06-02-2004 11:54 AM

Well I tried to use /usr/bin/JavaPluginControlPanel where I changed the Java runtime environment with the advanced tab to the installed: JRE 1.4.1
In mozilla a popup opens when downloading from happypuppy what to do with the file. It's suggest the plugin in jre1.4.1 itself but another popup just keeps displaying ' loading plugin' and nothing happends....
Can it reallly work with the blackdown from deb? And could you be a bit more specific how to get it going please.

edit (to be more clear) the popup (saying loading pluging is already there) mozilla states:

The file " localpeer13.jnlp" is of type application/x-java-jnlp-file, and Mozilla does not know how to handle this file type. This file is located at:

What should Mozilla do with this file?

* Open it with /usr/lib/j2se/1.4/jre/lib/i386/ 'choose....'
* save to disk
* Always perform this action when handling files of this type

Choosing the provided option results in a quick download after which nothing happends.....


powadha 06-03-2004 04:09 PM

no clues?

mrcheeks 06-03-2004 05:00 PM


Originally posted by powadha
no clues?
add this to the end of your ~/.mailcap
application/x-java-jnlp-file;/locationOfjre/javaws/javaws %

powadha 06-05-2004 12:57 PM

Well, that is in short what worked. In fact I downloaded (hadn't seen your post) the software seperatly. It asks for the location of java and installs what normally happens online. It auto updates ~/.mailcap and the test links on sun all work. So problem solved....well, partly. I still get an error at asking me to mail the error messages I get in Mozilla. Same happens in Opera so I guess it's really the website.
Shame to have to boot win to get my files from happypuppy (I prefer it over fileplanet) but perhaps the'll fix it.

All times are GMT -5. The time now is 10:41 AM.