LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 11-22-2011, 07:19 AM   #1
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Rep: Reputation: 50
very loud "BEEP" during Shutdown and Restart


Hi

I have wheezy installed on the notebook DELL Vostro and I get very loud short "BEEP" during Shutdown or Restart.
I have tried to add:
Code:
blacklist pcspkr
in /etc/modprobe.d/blacklist.conf, but it doesn't help.

My lsmod:
Code:
# lsmod
Module                  Size  Used by
parport_pc             22395  0 
ppdev                  12763  0 
lp                     17270  0 
parport                31929  3 parport_pc,ppdev,lp
rfcomm                 33848  0 
bnep                   17615  2 
acpi_cpufreq           13009  1 
mperf                  12453  1 acpi_cpufreq
cpufreq_userspace      12576  0 
cpufreq_powersave      12454  0 
cpufreq_conservative    13147  0 
cpufreq_stats          12862  0 
binfmt_misc            13040  1 
uinput                 17469  1 
fuse                   66430  1 
nfsd                  260662  2 
nfs                   259369  0 
lockd                  71503  2 nfsd,nfs
fscache                36721  1 nfs
auth_rpcgss            37204  2 nfsd,nfs
nfs_acl                12511  2 nfsd,nfs
sunrpc                172969  6 nfsd,nfs,lockd,auth_rpcgss,nfs_acl
loop                   22711  0 
uvcvideo               61887  0 
joydev                 17262  0 
videodev               66713  1 uvcvideo
media                  18184  2 uvcvideo,videodev
v4l2_compat_ioctl32    16567  1 videodev
snd_hda_codec_hdmi     26321  1 
snd_hda_codec_idt      53749  1 
arc4                   12458  2 
ath9k                  72885  0 
mac80211              182631  1 ath9k
i915                  342883  7 
ath9k_common           12682  1 ath9k
snd_hda_intel          26140  2 
dell_wmi               12477  0 
dell_laptop            12943  0 
snd_hda_codec          72699  3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
ath9k_hw              261156  2 ath9k,ath9k_common
drm_kms_helper         27216  1 i915
drm                   163280  3 i915,drm_kms_helper
snd_hwdep              13186  1 snd_hda_codec
ath3k                  12671  0 
ath                    21453  2 ath9k,ath9k_hw
evdev                  17558  18 
btusb                  17462  0 
dcdbas                 13256  1 dell_laptop
i2c_i801               16870  0 
sparse_keymap          12795  1 dell_wmi
snd_pcm                68104  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
i2c_algo_bit           12850  1 i915
i2c_core               23909  6 videodev,i915,drm_kms_helper,drm,i2c_i801,i2c_algo_bit
snd_seq                45208  0 
snd_timer              22581  2 snd_pcm,snd_seq
snd_seq_device         13137  1 snd_seq
bluetooth             114376  11 rfcomm,bnep,btusb
cfg80211              132564  3 ath9k,mac80211,ath
snd                    52823  13 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_seq,snd_timer,snd_seq_device
rfkill                 19080  5 dell_laptop,bluetooth,cfg80211
psmouse                55656  0 
serio_raw              12846  0 
intel_ips              17694  0 
soundcore              13152  1 snd
snd_page_alloc         13043  2 snd_hda_intel,snd_pcm
video                  17707  1 i915
battery                13109  0 
ac                     12624  0 
button                 12930  1 i915
power_supply           13475  3 dell_laptop,battery,ac
wmi                    13243  1 dell_wmi
processor              27942  5 acpi_cpufreq
ext4                  313917  4 
mbcache                13066  1 ext4
jbd2                   62574  1 ext4
crc16                  12343  2 bluetooth,ext4
sg                     25985  0 
sd_mod                 36259  6 
crc_t10dif             12348  1 sd_mod
ahci                   25089  5 
libahci                22767  1 ahci
libata                149043  2 ahci,libahci
scsi_mod              162442  3 sg,sd_mod,libata
r8169                  42411  0 
mii                    12675  1 r8169
ehci_hcd               40090  0 
thermal                17426  0 
thermal_sys            17949  3 video,processor,thermal
usbcore               128338  5 uvcvideo,ath3k,btusb,ehci_hcd
 
Old 11-22-2011, 08:37 AM   #2
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,089
Blog Entries: 5

Rep: Reputation: 1139Reputation: 1139Reputation: 1139Reputation: 1139Reputation: 1139Reputation: 1139Reputation: 1139Reputation: 1139Reputation: 1139
The tone is probably not coming from the pcspkr device anyway. Have a look in alsamixer and see if there is a "beep" volume level you can turn down.

If it's just the gnome or gdm3 login beep then have a look at this thread at the debian forums: http://forums.debian.net/viewtopic.php?f=5&t=65327
 
Old 11-22-2011, 06:17 PM   #3
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Original Poster
Rep: Reputation: 50
Quote:
Originally Posted by caravel View Post
The tone is probably not coming from the pcspkr device anyway. Have a look in alsamixer and see if there is a "beep" volume level you can turn down.

If it's just the gnome or gdm3 login beep then have a look at this thread at the debian forums: http://forums.debian.net/viewtopic.php?f=5&t=65327
In alsamixer "beep" volume is completely down and this problem still exists.
BTW in the link you posted is other problem, I don't have a problem with startup beep.
My problem is at Shutdown/Restart a very loud Beep.
 
Old 11-22-2011, 06:53 PM   #4
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Original Poster
Rep: Reputation: 50
uncomment this line:
Code:
set bell-style none
in /etc/inputrc seems to solve this problem.
 
Old 04-04-2012, 11:09 AM   #5
avalancha.libre
LQ Newbie
 
Registered: Apr 2012
Posts: 3

Rep: Reputation: Disabled
Quote:
uncomment this line:
Code:

set bell-style none

in /etc/inputrc seems to solve this problem.
Dell Latitude e6410 Debian wheezy here. Works perfect for me too, that beep with headphones is horrible.

Just some detail, te line stop any notificatión on gnome-terminal too, the little configurable beep sound when you delete on the terminal (ie.).

Thanks for help.
 
Old 04-04-2012, 11:15 AM   #6
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Original Poster
Rep: Reputation: 50
Glad to help, but I don't know if to edit /etc/inputrc is it best solution, depends of how important pc speaker is.

BTW you can try to set BEEP down using alsamixer as well, I didn't try yet.

Last edited by cccc; 04-04-2012 at 11:18 AM.
 
Old 04-04-2012, 01:58 PM   #7
avalancha.libre
LQ Newbie
 
Registered: Apr 2012
Posts: 3

Rep: Reputation: Disabled
Quote:
Glad to help, but I don't know if to edit /etc/inputrc is it best solution, depends of how important pc speaker is.
May I've not put in the right way, but with "this" uncomment line i've just stop the BEEP sound when appear GDM3 and when you turn the laptop off, only that, the pc speaker and sound still working ok on the gnome session.

About Alsa: Wheezy has adopted PulseAudio over Alsa so, on alsamixer you can turn off volume to beep, but PulseAudio doesn't offer you that option.

Resuming: Discomment this line you have "no BEET on gdm3 or restartin/turning off your laptop", BUT you lose the little configurable beep sounds on gnome. The audio for music, videos, etc still working fine.

Best regards,
 
Old 04-04-2012, 11:25 PM   #8
Xeratul
Senior Member
 
Registered: Jun 2006
Location: UNIX
Distribution: FreeBSD
Posts: 2,357

Rep: Reputation: 213Reputation: 213Reputation: 213
what was the solution then?

could you please give us a short post of the procedure to follow since it is solved? thank you (if possible)
 
Old 04-05-2012, 10:57 AM   #9
avalancha.libre
LQ Newbie
 
Registered: Apr 2012
Posts: 3

Rep: Reputation: Disabled
The original post says:

Quote:
Hi

I have wheezy installed on the notebook DELL Vostro and I get very loud short "BEEP" during Shutdown or Restart.
I have tried to add:
This is true on Wheezy using PulseAudio.

Quote:
uncomment this line:
Code:

set bell-style none

in /etc/inputrc seems to solve this problem.
Really, this solve the issue when you just shutdown/restart or gdm3 window restart.


Not Solved: Doing this, you stop the issue, but y gnome-terminal you stop to receive the action sounds configured for the terminal.

Regards.
 
Old 04-05-2012, 12:59 PM   #10
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Original Poster
Rep: Reputation: 50
On squeeze you can try alsamixer:

http://stevenrosenberg.net/blog/linu..._shutdown_beep

greetings
cccc
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I disable "shutdown" and "restart" options in KDE logout screen for all users? maxgsp Linux - Distributions 1 12-12-2008 03:18 PM
Lost "Shutdown" and "Restart" From system menu in FC6 Nader1 Linux - Software 3 02-12-2007 04:40 PM
"Shutdown" and "Restart" option missing after upgrade hansalfredche Mandriva 8 11-02-2006 07:23 AM
How to disable the warning sound "beep, beep" ICO Red Hat 1 04-04-2006 01:59 AM
Gnome 1.4: howto set ATX-shutdown/restart support in the "logout"-dialog? Debianewb Linux - Software 1 11-08-2002 07:36 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 11:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration