LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 11-21-2003, 10:35 AM   #1
Freija
LQ Newbie
 
Registered: Jul 2003
Location: Milwaukee, Wisconsin, USA
Distribution: Debian 3.0 "woody"
Posts: 17

Rep: Reputation: 0
Question USB Mouse - XWindows


Hello everyone! Before I begin, I apologize if this quetion has been asked before. I've tried researching it, but have found nothing specific to my problem.

I recently installed Debian 3.0r1 (Woody) with the default kernel. I setup everything without a problem, except the mouse. Whenever I try loading up XWindows (startx), I get an error that states XWindows cannot load because not all of the core devices can be initialized (the mouse being the culprit). It's a two-button, scrolling USB mouse. I setup XWindows to point to /dev/input/mice for the mouse, which I think is the problem. A friend told me that I need to find the USB Mouse module for the kernel and add it, because Debian doesn't initially install it. He told me to run "modprobe", but I am unfamiliar with that command and cannot find resources on it. So here's my question:

How do I install the module into the kernel for a USB Mouse?

If anyone knows of a general tutorial/FAQ for adding modules in Debian, a hyperlink to one of those would more than suffice.

Thank you for your help!

P.S. Once I fix this problem, will KDE (the default GUI I chose) load up right away instead of Debian giving me a text login prompt? If not, how do I make it so I can login graphically? Thanks!

Last edited by Freija; 11-21-2003 at 10:41 AM.
 
Old 11-21-2003, 11:08 AM   #2
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
The command for Debian is modconf from root. This will present a menu. You must then scroll down the menu and install support for usb and UHCI devices. If you issue the command cat /dev/input/mice and move the mouse you should then see wierd characters. The fact that usb devices are installed should also be reported in your /var/log/syslog (cat /var/log/syslog)
 
Old 11-21-2003, 11:23 AM   #3
baskew91
LQ Newbie
 
Registered: Nov 2003
Distribution: debian
Posts: 14

Rep: Reputation: 0
x

"P.S. Once I fix this problem, will KDE (the default GUI I chose) load
up right away instead of Debian giving me a text login prompt? If
not, how do I make it so I can login graphically? Thanks!"

not sure about debian (as i've never used it) but with most other distros, you can edit your /etc/inittab file for the line like this

id:3:initdefault

and change 3 to a 5, that will start you in X upon booting, which works with most distros ive used, redhat, slackware....

as far as your mouse problem if all the appropriate modules are loading then when you cat /dev/input/mice you should see a bunch of weird chars. then make sure you have a section in your /etc/X11/XF86Config file under InputDevice that points to your USB mouse like

Section "InputDevice"
Identifier "USB Mice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
EndSection

i use IMPS/2 for my logitech usb wheelmouse, and the ZAxisMapping is so i can scroll.
and be sure under ServerLayout you have a section saying something like this

InputDevice "USB Mice" "SendCoreEvents"

then when starting x it should stop complaining

hope this helps
 
Old 11-21-2003, 01:16 PM   #4
Freija
LQ Newbie
 
Registered: Jul 2003
Location: Milwaukee, Wisconsin, USA
Distribution: Debian 3.0 "woody"
Posts: 17

Original Poster
Rep: Reputation: 0
Smile Thank you!

Thank you for your input! Next time I have access to the machine (it's a school project) I'll try your ideas out. This forum is absolutely great! A genuine response in half an hour! Kudos to all of you!
 
Old 11-22-2003, 06:45 AM   #5
llamakc
Member
 
Registered: Nov 2003
Distribution: Debian & Ubuntu
Posts: 402

Rep: Reputation: 31
Debian's default runlevel is 2, not 3. If you install kdm you won't have to edit /etc/inittab at all.

As stated above, use modconf as root. Make sure you have edited /etc/modules to include your modules you wan't loaded at boot-time. Here's mine (this is for a home-rolled kernel btw)

# /etc/modules: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line. Comments begin with
# a "#", and everything on the line after them are ignored.

usb-uhci
input
usbkbd
keybdev
tulip
mousedev
hid
usbmouse
radeon


Good luck.

PS: I always apt-get install hotplug. This solves alot of tinkering for me, but I am quite lazy too.
 
Old 11-24-2003, 01:16 PM   #6
Freija
LQ Newbie
 
Registered: Jul 2003
Location: Milwaukee, Wisconsin, USA
Distribution: Debian 3.0 "woody"
Posts: 17

Original Poster
Rep: Reputation: 0
Editing config file

Can I edit the xfree86 config file without having to use a config program? I want to just simply type in the values.
 
Old 11-24-2003, 01:18 PM   #7
llamakc
Member
 
Registered: Nov 2003
Distribution: Debian & Ubuntu
Posts: 402

Rep: Reputation: 31
Yes you may. But you'll have to use emacs. (Just kidding). edit /etc/X11/XF86Config-4 and you'll be good to go.

Good luck!
 
Old 11-24-2003, 03:24 PM   #8
Freija
LQ Newbie
 
Registered: Jul 2003
Location: Milwaukee, Wisconsin, USA
Distribution: Debian 3.0 "woody"
Posts: 17

Original Poster
Rep: Reputation: 0
Ugh sorry that was a question I could have looked up. Thanks for helping a newbie anyways!
 
Old 11-28-2003, 04:14 AM   #9
8nasmith
Member
 
Registered: Oct 2003
Location: Cornwall, UK
Distribution: Fedora Core 4
Posts: 268

Rep: Reputation: 30
this may be a stypid question but whats x windows
 
Old 11-28-2003, 08:57 AM   #10
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
The base system XFree86 which gives GUI capability to all the window managers like kde and gnome.
 
Old 12-03-2003, 12:48 AM   #11
powadha
Member
 
Registered: Nov 2003
Location: Zwolle
Distribution: Arch
Posts: 651

Rep: Reputation: 31
Seems I have the same problem but the above for some reason doesn't fix it. I installed Debian using netinstall with no problems. Starting X works fine but I can't get the mouse to work. I use a Logitech cordless trackball which works fine in Slackware (tried Knoppix to be sure and works fine) I configured the kernel as said above and tried all the different settings for the mouse but still nothing. I went from ttsy0 to ttsy3 (or something similair) and tried all the others. Startx, move the mouse, nothing, logout, reconfigure, startx etc....I didn't reboot after changing settings in x btw. Strange thing is that when I gave up and rebooted to WinXP (using Lilo) to get back on the forum, my mouse didn't work in XP either. I noticed that every time I boot to Debian and reboot to XP I need to change the usb plug to another free one and all is fine. Could this be a bios setting?
Any clues on how to get my trackball working?

Regards
 
Old 12-03-2003, 02:32 AM   #12
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Check /var/log/syslog and see whether kernel support for usb is being loaded at boot. Also check /var/log/XFree86.0.log to see exactly what X is configuring.

Last edited by TigerOC; 12-03-2003 at 02:37 AM.
 
Old 12-03-2003, 02:43 AM   #13
powadha
Member
 
Registered: Nov 2003
Location: Zwolle
Distribution: Arch
Posts: 651

Rep: Reputation: 31
Stupid question, but how do I open these files to check them (can't work in X)? I guess Debian will have an editor installed.
 
Old 12-03-2003, 05:40 AM   #14
llamakc
Member
 
Registered: Nov 2003
Distribution: Debian & Ubuntu
Posts: 402

Rep: Reputation: 31
you can do

cat /var/log/syslog

or

nano /var/log/syslog

If the modules are loaded (check with the command lsmod) you can do

cat /dev/input/mice

and move the mouse around. You should see garbage output to the screen.

As I mentioned before, get those modules loaded via modconf and then apt-get install hotplug. Edit /etc/X11/XF86Config-4 with the above snippet posted by baskew91 and this will work.

The default installed editor on Debian is nano, a pico clone.
 
Old 12-03-2003, 08:23 AM   #15
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
syslog is generally quite long so you will need to do cat /var/log/syslog | more which will give line by line display.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xwindows can't detect the mouse fatblueduck Linux - Software 1 04-20-2005 11:40 PM
Starting Mouse without Xwindows longnam Debian 2 03-22-2005 12:34 PM
mouse xwindows naminator Linux - Newbie 1 08-18-2003 01:48 PM
No mouse... No Xwindows MasterC Linux - General 14 07-15-2002 10:22 AM
Xwindows mouse problem syxxpac023 Linux - Newbie 3 10-29-2001 10:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 10:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration