LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   USB camera Debian Etch (https://www.linuxquestions.org/questions/debian-26/usb-camera-debian-etch-401541/)

chestnut1969 01-10-2006 06:01 AM

USB camera Debian Etch
 
Hello

I'm having trouble using a Canon Ixus camera as normal user via USB.

If I run gthumb as normal user I receive error:

An error occurred in the io-library ('Could not claim the USB device'): Could not claim interface 0 (Operation not permitted). Make sure no other program or kernel module (such as sdc2xx, stv680, spca50x) is using the device and you have read/write access to the device.

Note that gthumb detects & loads kernel module ok for camera.

If I run gthumb as root, camera connects with no problem.

Question is, how can I make camera connect as a normal user, and mount to a point such as /media/camera? I suspect it is a permission problem. I have added my user to the camera group.

I also cannot find the camera mounted anywhere, or any device present, ie. nothing under /dev/sd* or /media


lsusb displays:
Bus 001 Device 014: ID 04a9:30bf Canon, Inc. Digital IXUS 40

I am running a new net install of Debian Etch on 2.6.12 kernel using udev 0.76-6


Any suggestions appreciated.
Many thanks

dmartins 01-10-2006 06:28 AM

if you check your output from dmesg after you've plugged the camera in it will say what device node it has been assigned to. for example:

Code:

usb 1-4: new high speed USB device using ehci_hcd and address 2
scsi0 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
  Vendor: Samsung  Model: YP-C1            Rev: 2001
  Type:  Direct-Access                      ANSI SCSI revision: 04
SCSI device sda: 1011712 512-byte hdwr sectors (518 MB)
sda: Write Protect is off
sda: Mode Sense: 38 00 00 00
sda: assuming drive cache: write through
SCSI device sda: 1011712 512-byte hdwr sectors (518 MB)
sda: Write Protect is off
sda: Mode Sense: 38 00 00 00
sda: assuming drive cache: write through
 sda: sda1
sd 0:0:0:0: Attached scsi removable disk sda
sd 0:0:0:0: Attached scsi generic sg0 type 0
usb-storage: device scan complete

If you don't get this kind of output i would think you have an issue with kernel drivers. I compiled my own kernel as soon as i had debian installed because i couldn't stand all the extra that was in there so i don't really know how the default kernels are setup. are the modules sd_mod and usb-storage loaded?

Also, you can check the output from udevmonitor when you plug the camera in. This might give you some hints. Mine looks like this:

Code:

UEVENT[1136895699.113559] add@/devices/pci0000:00/0000:00:0b.2/usb1/1-4
UEVENT[1136895699.113707] add@/devices/pci0000:00/0000:00:0b.2/usb1/1-4/1-4:1.0
UEVENT[1136895699.113723] add@/class/scsi_host/host1
UEVENT[1136895699.113735] add@/class/usb_device/usbdev1.3
UDEV  [1136895699.114318] add@/devices/pci0000:00/0000:00:0b.2/usb1/1-4
UDEV  [1136895699.119400] add@/devices/pci0000:00/0000:00:0b.2/usb1/1-4/1-4:1.0
UDEV  [1136895699.193155] add@/class/scsi_host/host1
UDEV  [1136895699.232579] add@/class/usb_device/usbdev1.3
UEVENT[1136895704.112636] add@/devices/pci0000:00/0000:00:0b.2/usb1/1-4/1-4:1.0/host1/target1:0:0/1:0:0:0
UEVENT[1136895704.114668] add@/block/sda
UEVENT[1136895704.148789] add@/block/sda/sda1
UEVENT[1136895704.148847] add@/class/scsi_device/1:0:0:0
UEVENT[1136895704.148862] add@/class/scsi_generic/sg0
UDEV  [1136895704.159058] add@/devices/pci0000:00/0000:00:0b.2/usb1/1-4/1-4:1.0/host1/target1:0:0/1:0:0:0
UDEV  [1136895704.219241] add@/class/scsi_device/1:0:0:0
UDEV  [1136895704.263360] add@/class/scsi_generic/sg0
UDEV  [1136895704.314787] add@/block/sda
UDEV  [1136895704.390673] add@/block/sda/sda1

I'm assuming that your camera acts as a usb storage device, as most do. The output that i've posted is from a mp3 player that acts like this. The device nodes /dev/sda and /dev/sda1 are owned by root and their group is floppy on my system.
I have a line in my /etc/fstab "/dev/sda1 /media/mp3 vfat rw,users,noauto 0 0"

When you get this working have a look at http://www.reactivated.net/writing_udev_rules.html to see how to write a rule so your camera always gets the same device node.

Hope this helps

michapma 01-10-2006 06:34 AM

You are trying to connect to the camera itself, right? It may not help, but check out the package gphoto2.

$ apt-cache show gphoto2

HappyTux 01-10-2006 12:11 PM

Make sure you are a member of the camera with the groups command if not the as root adduser user_name camera then logout and back in for the changes to take effect.

chestnut1969 01-10-2006 02:44 PM

Thankfully it was a simple fix, thanks for all the suggestions.

I just needed to add my user to the camera group, with a log-out & log-in. With this fix I can atleast use my camera on my desktop PC.

Going back to the actual device node itself, running udevmonitor & turning on camera results in:

UEVENT[1136925687.841598] add@/devices/pci0000:00/0000:00:10.0/usb1/1-1
UEVENT[1136925687.851989] add@/devices/pci0000:00/0000:00:10.0/usb1/1-1/1-1:1.0
UDEV [1136925687.886776] add@/devices/pci0000:00/0000:00:10.0/usb1/1-1
UDEV [1136925687.943272] add@/devices/pci0000:00/0000:00:10.0/usb1/1-1/1-1:1.0

dmesg results in:

usb 1-1: new full speed USB device using uhci_hcd and address 9

It looks like I may not have SCSI emulation on. I'll check my kernel config, and recompile of required.


Now for the ipod..

Cheers


All times are GMT -5. The time now is 09:00 AM.