LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 09-21-2004, 05:47 PM   #1
everest
Member
 
Registered: Aug 2003
Posts: 44

Rep: Reputation: 15
USB and gphoto on Debian Woody 3.0?


Simple question but I don't know the answer - is there support for USB on either the first Debian Woody 3.0 CD (or the second or the third - those are the three CD's I have) and what is the name of the program so I can download it, and is there some version of gphoto on the first three CD's? I want to connect my Canon A60 to a USB port with Debian Woody as the operating system.
 
Old 09-22-2004, 03:05 AM   #2
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
USB HID will be in your kernel; do modconf as root and you will be presented with a menu. Go down to USB and install HID. I would also suggest installing hotplug. apt-get install gphoto2. Suggest looking for a howto for your camera.
 
Old 09-22-2004, 04:00 PM   #3
everest
Member
 
Registered: Aug 2003
Posts: 44

Original Poster
Rep: Reputation: 15
Smile USB and gphoto on Debian Woody 3.0?

Thanks TigerOC - that's just the information I was looking for!
 
Old 09-22-2004, 04:32 PM   #4
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Good luck. I use digikam as the gui and it worked really well with Woody. Since upgrading to Sarge I have permissions issues with gphoto2 which I have never resolved but it works fine under root so I go in as root to download the images.
 
Old 09-24-2004, 04:40 PM   #5
everest
Member
 
Registered: Aug 2003
Posts: 44

Original Poster
Rep: Reputation: 15
TigerOC says "USB HID will be in your kernel; do modconf as root and you will be presented with a menu. Go down to USB and install HID." Problem though - I can see no sign of USB or HID in that menu. So I need an alternative means of installing it. Does anyone know if it on the first three Woody 3.0 CDs, or can I perhaps download and install it from the internet? What actually is it that I need - is it a driver or a program that enables the USB - does it have a specific name?
 
Old 09-24-2004, 04:48 PM   #6
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Which kernel are you using? If its a std kernel then the module should be there.
 
Old 09-24-2004, 06:57 PM   #7
everest
Member
 
Registered: Aug 2003
Posts: 44

Original Poster
Rep: Reputation: 15
TigerOC - I have no idea what kernel I am using - I simply installed Debian clicking on whatever seemed like the most appropriate options! Do you know if the appropriate module has a specific name? If there is more than one kernel on the first Woody CD maybe I should reinstall it and choose a different module option? I have no personal files on the hard drive so I can easily reinstall.
 
Old 09-25-2004, 03:05 AM   #8
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
If you did a regular install then you probably have the default 2.2 kernel. I would suggest that you do a new install using the 2.4 kernel. When you boot the install cd and you get the prompt do bf24 (check the options which I think is F3) or alternatively since sarge is about (next month) to become the new stable perhaps think about downloading the new installer and install sarge.
 
Old 09-25-2004, 03:35 PM   #9
everest
Member
 
Registered: Aug 2003
Posts: 44

Original Poster
Rep: Reputation: 15
Okay thanks TigerOC - I'll try a reinstall and see what happens. By the way, do you know how people keep track of threads on LinuxQuestions forums? Some forums elsewhere send automatic notification emails whenever someone posts onto a thread one is following but I couldn't find that facility on LQ.
 
Old 09-25-2004, 03:53 PM   #10
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Go to User CP and then go to edit options and check the yes box for e-mail notification.
Re upgrading the simpler route is just to apt-get install a new kernel. If you go this route make sure you have a boot disk in case you mess up lilo if you are using it. It would be a lot quicker than a new install. To decide which flavour kernel you need do apt-cache search kernel-2.4.18

Last edited by TigerOC; 09-25-2004 at 04:02 PM.
 
Old 09-25-2004, 05:07 PM   #11
everest
Member
 
Registered: Aug 2003
Posts: 44

Original Poster
Rep: Reputation: 15
Thanks TigerOC - that will save me the pain of a full reinstall, and thanks also for the advice on email notification - having to find lost threads to check on whether anyone has posted was a nuisance.
 
Old 10-08-2004, 01:11 AM   #12
otoomet
Member
 
Registered: Oct 2004
Location: Tartu, Ċrhus,Nürnberg, Europe
Distribution: Debian, Ubuntu, Puppy
Posts: 619

Rep: Reputation: 45
An easy way to change usb-related priorities in kernel 2.6 is simply by configuring /etc/fstab accordingly. In /etc/fstab you should find a line like (only for 2.6 kernels)

usbfs /proc/bus/usb usbfs defaults,devmode=0666 0 0

Note the devmode=0666 _should_ give everyone the usb write access, necessary for gphoto. However, due to a kernle bug, it does not work before 2.6.8 AFAIR. At least it works on 2.6.8.1 and did not work on 2.6.5. The simplest way to find out which kernel you are using is by

$ uname -a

The better way (according to gphoto documentation) to set the permissions is by using hotplug. Unfortunately I didn't get it to work on my RH9, so I upgraded the kernel. Now I have to find out what to do with sarge/kernel 2.6.7/Canon PS A75.

Best,
Ott
 
Old 10-08-2004, 11:19 AM   #13
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Quote:
Originally posted by otoomet
An easy way to change usb-related priorities in kernel 2.6 is simply by configuring /etc/fstab accordingly. In /etc/fstab you should find a line like (only for 2.6 kernels)

usbfs /proc/bus/usb usbfs defaults,devmode=0666 0 0

Note the devmode=0666 _should_ give everyone the usb write access, necessary for gphoto. However, due to a kernle bug, it does not work before 2.6.8 AFAIR. At least it works on 2.6.8.1 and did not work on 2.6.5. The simplest way to find out which kernel you are using is by

This is working with the 2.6.3 kernel for anyone interested. Have been struggling to get users working, so thank you otoomet.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't mount USB Flash Drive on debian woody Chrysalid Linux - Hardware 1 07-31-2005 07:37 AM
Gphoto FC3 Usb only kedman Linux - Hardware 0 01-18-2005 04:14 PM
usb printer install in debian woody heathpitts Debian 4 12-12-2003 01:07 PM
Debian (woody) and MS Blue USB mouse nirva Linux - Hardware 1 06-29-2003 02:01 PM
gphoto and USB issue loke137 Linux - Software 0 03-26-2003 04:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration