-   Debian (
-   -   Urgent: Installing debian etch on a new hdd but grub won't install (fatal error) (

MrInept 09-14-2006 01:16 AM

Solved: Installing debian etch on a new hdd but grub won't install (fatal error)
Oh no.

I was running etch for a while and was running a dual boot windows on hda and etch on hdb (single partition, plus swap and small fat32 partition). I was running out of space on this old small hard drive (hdb) and decided to upgrade, so i bout a 80GB SATA one.

My M/B has SATA support directly, so i plugged it in and then i noticed that on turning on the pc nothing would work, there was a grub error (i think 26) So i plugged in the old hard drive, and it worked again. Anyway I fiddled with trying to copy the old partition to the new drive but couldn't do it in GParted cos i had to unmount my drive, on which i was running etch (and GParted). Grrrr. So i just thought bugger it i'll reinstall. I did a netinstall and i'm still there, I got to the etch Grub install part and it keeps failing, it won't work, i can't get it to install on either hda (which is default) or sda (my new sata drive) or even a floppy!?!?!?!?! AAAAAHHH!

I don't won't to exit cos i'm scared it won't work if i try to reboot what should i do?! I'm sitting here with my pc now. so quick help would really be appreciated.

Dutch Master 09-14-2006 03:01 AM

You can always boot from a rescue CD, like Knoppix or so.

Ok, what filesystem did you choose, 'cause Grub has known problems installing on an XFS partition. Use ReiserFS for the /boot partition, all others can be XFS (I know it can, that's what I have done ;))

Did you compile booting from SATA/SCSI support in your kernel, or into your initrd image? In Etch it should work 'out-of-the-box' but apparently it doesn't.

rickh 09-14-2006 06:50 AM

I have seen people reporting error like this before. I have installed Etch on SATA hardware with no problems. I wonder if you could be a little more specific about Grub's "failure."

Do you get the message that it sees your Windows partition, and would you like to install Grub on the MBR? Is there any kind of error message at the point of the failure?

A nit-picking point: Many people are insulted by threads which include "Urgent" in the title. If you have a clearly explained problem, which you do, it won't help you get any quicker attention.

MrInept 09-14-2006 08:45 AM

sorry i'll edit it if i can, it was urgent because i was afraid to reboot, i didn't know if i could reboot safely without killing my window install and getting killed by my family.

Grub gives virtually no error, it does detect my win install and ask if i wanna install on mbr, (win is on hda) but gives a "fatal" error. then if i so no to installing on mbr and choose sda or fd0 it fails as well (without even reading the floppy). It should be noted that grub gave an error on boot (it wouldn't load) as soon as i had disconnected hdb and now that i have hda, hdb, and sda it is fine to boot either hda or hdb. I was really confused so i tried ctrl+alt+f4 and found the text console behind the gui (i did install gui) and it says it can't find /sbin/grub-install the actual error is:


running chroot /target /sbin/grub-install --recheck "(hd0)"
chroot: error cannot run /sbin/grub-install: file or directory not found

but thats cos grub-install isn't in /target/sbin its in /target/usr/sbin...


MrInept 09-14-2006 08:54 AM

OMG it works! I copied grub-installer from /target/usr/sbin to /target/sbin and it worked! I think i'm gonna have to report that as a pretty major error, lol, don't know why it never happened b4. thanks for your help!

All times are GMT -5. The time now is 01:35 PM.