LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   Upgrading Firefox on Debian (https://www.linuxquestions.org/questions/debian-26/upgrading-firefox-on-debian-305515/)

tripwire45 03-24-2005 10:53 AM

Upgrading Firefox on Debian
 
"Dumb question" time again. I went to the mozilla-firefox site and downloaded Firefox 1.0.2 onto my Debian box. I moved the firefox-1.0.2.installer.tar.gz file to /tmp and then typed

tar -xzvf firefox-1.0.2.installer.tar.gz

The files extracted and created a firefox-installer directory. I typed cd firefox installer and found both a firefox-installer and firefox-installer-bin file (among others). I didn't see a README.txt file. I *thought* I could just type firefox-installer-bin to begin the installation but all I get is a command not found response. I'm logged in a root and root is the owner of these files. I've tried to google the answer without success (get mostly information about RPM packages). What am I missing here? Thanks.

zuralin 03-24-2005 10:57 AM

you probably need ./firefox-installer-bin because "." isnt in your $PATH (and it is bad practice to have it in your $PATH)

tripwire45 03-24-2005 12:55 PM

Here's what happened:

tripwire:/tmp/firefox-installer# ./firefox-installer-bin

(firefox-installer-bin:2651): Gtk-WARNING **: cannot open display:
tripwire:/tmp/firefox-installer#

Moloko 03-24-2005 01:25 PM

Root has no Xauthority if you are logged in as a user (as you should). Copy ~/.Xauthority to /root/ and try again. You will have to do this every time you want to run something graphical as root, the .Xauthority file is recreated upon login.

zuralin 03-24-2005 01:37 PM

Quote:

Originally posted by Moloko
Root has no Xauthority if you are logged in as a user (as you should). Copy ~/.Xauthority to /root/ and try again. You will have to do this every time you want to run something graphical as root, the .Xauthority file is recreated upon login.
There has to be another way to do that. I can't remember if I ever had the same problem and just fixed it, (it's been 2+ years since I have installed Debian on this box) but I don't have to do that in order to run anything graphical as root.

dastrike 03-24-2005 02:39 PM

1. Install gksu by apt-get install gksu

2. Install Firefox with that installer through gksu ./firefox-installer-bin as a regular user.



(or install Firefox through apt-get... If you are using 'woody' there is one at backports.org)

Moloko 03-24-2005 04:46 PM

Quote:

Originally posted by zuralin
There has to be another way to do that.
I never checked for another way, since I never run anything graphical as root, but did you do something with "xhost"? Might be the answer.

Quote:

it's been 2+ years since I have installed Debian
It just won't stop :) same here

Moloko 03-24-2005 05:01 PM

$ xhost +local:root
$ non-network local connections being added to access control list

:D

tripwire45 03-25-2005 11:07 AM

Quote:

Originally posted by dastrike
[B]1. Install gksu by apt-get install gksu

2. Install Firefox with that installer through gksu ./firefox-installer-bin as a regular user.

Installed gksu and followed the above instructions while logged in as a regular user. Unfortunately, the result is as follows:

user@tripwire:/tmp/firefox-installer$ gksu ./firefox-installer-bin

(gksu:23906): Gtk-WARNING **: cannot open display:
jmpyles@tripwire:/tmp/firefox-installer$

Will keep plugging away at it.

tripwire45 03-25-2005 11:15 AM

Quote:

Originally posted by Moloko
Root has no Xauthority if you are logged in as a user (as you should). Copy ~/.Xauthority to /root/ and try again. You will have to do this every time you want to run something graphical as root, the .Xauthority file is recreated upon login.
I must be misunderstanding what you are saying here. It looks like you are saying for me to use the cp command to copy ~/.Xauthority to /root/. Here's the result:

tripwire:~# cp ~/.Xauthority /root/
cp: `/root/.Xauthority' and `/root/.Xauthority' are the same file
tripwire:~#

Moloko, could you flesh out how I'm supposed to implement:
Quote:

$ xhost +local:root
$ non-network local connections being added to access control list
here? Just typing it returns a command not found
error. Thanks.

:scratch:

Moloko 03-27-2005 11:26 AM

The xhost command is part of the xbase-clients package:$ dpkg -l xbase-clients to see if you have it. I read that using xauth (same package) is a better way (more secure).

liquidtenmilion 03-27-2005 01:17 PM

type in as root

cp /home/username/.Xauthority ~

tripwire45 04-01-2005 02:07 PM

I cheated. As root I typed:

apt-get install mozilla-firefox

Firefox 1.0.1 installed automatically and was added in the Applications -> Internet menu. I added it as a panel item. Nothing else seemed to be working (at least for me) however I do appreciate everyone's time and effort. Thanks.

I tried your suggestion Moloko and got this:

tripwire:~# dpkg -l xbase-clients
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii xbase-clients 4.3.0.dfsg.1-8 miscellaneous X clients
tripwire:~#

samael26 04-01-2005 02:26 PM

Hi, I just upgraded to Firefox 1.0.2 using a simple apt-get update/upgrade tonight.
Did you configure your sources right in your /etc/apt/sources.list ?
Could save you loads of trouble..
I never install from tarballs or rpms .. Why bother ?
In Debian, use apt-get, properly configured . In Mandrake urpmi, and
you're done :D

f1dave 04-01-2005 11:00 PM

I'm with the apt-get solution myself.

Isn't there a "click here to update firefox" option in the browser itself as well?


All times are GMT -5. The time now is 03:42 PM.