-   Debian (
-   -   Unable to use VirtualBox after update (

michalng 04-11-2011 10:26 AM

Unable to use VirtualBox after update
Just updated wheezy 2.6.35-2-amd64 from to 2.6.38-2-amd64 and noticed that virtualbox-3.2 stopped working.

Tried reinstalling using apt-get and shown this error message

Preconfiguring packages ...
Selecting previously deselected package virtualbox-3.2.
(Reading database ... 100104 files and directories currently installed.)
Unpacking virtualbox-3.2 (from .../virtualbox-3.2_3.2.12-68302~Debian~squeeze_amd64.deb) ...
Selecting previously deselected package libsdl-ttf2.0-0.
Unpacking libsdl-ttf2.0-0 (from .../libsdl-ttf2.0-0_2.0.9-1_amd64.deb) ...
Setting up virtualbox-3.2 (3.2.12-68302~Debian~squeeze) ...
addgroup: The group `vboxusers' already exists as a system group. Exiting.
Stopping VirtualBox kernel modules:done..
Uninstalling old VirtualBox DKMS kernel modules:done..
Trying to register the VirtualBox kernel modules using DKMS:
Error! Bad return status for module build on kernel: 2.6.38-2-amd64 (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/vboxhost/3.2.12/build/ for more information.

Failed, trying without DKMS ... failed!
Recompiling VirtualBox kernel modules:
Look at /var/log/vbox-install.log to find out what went wrong ... failed!
Setting up libsdl-ttf2.0-0 (2.0.9-1) ...
Processing triggers for python-central ...

Looking at /var/lib/dkms/vboxhost/3.2.12/build/make.log gets

DKMS make.log for vboxhost-3.2.12 for kernel 2.6.38-2-amd64 (x86_64)
Mon Apr 11 23:13:48 SGT 2011
make: Entering directory `/usr/src/linux-headers-2.6.38-2-amd64'
LD /var/lib/dkms/vboxhost/3.2.12/build/built-in.o
LD /var/lib/dkms/vboxhost/3.2.12/build/vboxdrv/built-in.o
CC [M] /var/lib/dkms/vboxhost/3.2.12/build/vboxdrv/linux/SUPDrv-linux.o
In file included from /var/lib/dkms/vboxhost/3.2.12/build/vboxdrv/include/VBox/types.h:30,
from /var/lib/dkms/vboxhost/3.2.12/build/vboxdrv/linux/../SUPDrvInternal.h:35,
from /var/lib/dkms/vboxhost/3.2.12/build/vboxdrv/linux/SUPDrv-linux.c:31:
/var/lib/dkms/vboxhost/3.2.12/build/vboxdrv/include/iprt/types.h:97:31: error: linux/autoconf.h: No such file or directory
make[4]: *** [/var/lib/dkms/vboxhost/3.2.12/build/vboxdrv/linux/SUPDrv-linux.o] Error 1
make[3]: *** [/var/lib/dkms/vboxhost/3.2.12/build/vboxdrv] Error 2
make[2]: *** [_module_/var/lib/dkms/vboxhost/3.2.12/build] Error 2
make[1]: *** [sub-make] Error 2
make: *** [all] Error 2
make: Leaving directory `/usr/src/linux-headers-2.6.38-2-amd64'
and /var/log/vbox-install.log shows

Uninstalling modules from DKMS
Attempting to install using DKMS

Creating symlink /var/lib/dkms/vboxhost/3.2.12/source ->

DKMS: add Completed.

Kernel preparation unnecessary for this kernel. Skipping...

Building module:
cleaning build area....
make KERNELRELEASE=2.6.38-2-amd64 -C /lib/modules/2.6.38-2-amd64/build M=/var/lib/dkms/vboxhost/3.2.12/build....(bad exit status: 2)
Failed to install using DKMS, attempting to install without
Makefile:170: *** Error: /usr/src/linux (version 2.6.38) does not match the current kernel (version 2.6.38-2-amd64). Stop.
Where have I gone wrong?

AlucardZero 04-11-2011 10:31 AM

Did you install the linux-headers-2.6.38-2-amd64 package?

qrange 04-12-2011 03:59 AM

I have the same problem.
linux-headers-2.6.38-2-amd64 are installed.

bathory 04-12-2011 04:02 AM

Have a look here

qrange 04-12-2011 04:14 AM

I solved my problem by installing virtualbox4.

All times are GMT -5. The time now is 08:17 PM.