LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 12-07-2004, 09:23 PM   #1
andymadigan
Member
 
Registered: Aug 2004
Location: Rochester, NY
Distribution: Debian Sid
Posts: 59

Rep: Reputation: 15
Unable to suspend under Sid


I have a Dell Lattitude CPx5000 with Debian Sid (upgd from Sarge) and kernel 2.6.9. Before I upgraded to Sid, I had kernel 2.4.27 and when I closed the lid/screen of the laptop, it suspended (I think to ram). When I upgraded, the kernel didn't change, but it was re-installed and the install did something to screw up sound + suspend. Upgrading to 2.6.8 fixed sound, but suspend was still broken, so I tried 2.6.9, same problem. I tried running 'apm -s', and it said "no apm support in kernel". I thought all of the debian stock kernels were compiled with apm, but in the apmd package, it said I needed to add an "apm=on" to the kernel options. I added this to the 'kopts' line in /boot/grub/menu.lst and ran update-grub. Still no luck.

Here are the kernel versions available at the boot menu, * means sound works.
2.6.9-1-686 *
2.6.8-1-686 *
2.4.27-1-386

Here are the relevant sections in menu.lst:
Code:
title		Debian GNU/Linux, kernel 2.6.9-1-686 
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.9-1-686 root=/dev/hda1 ro apm=on 
initrd		/boot/initrd.img-2.6.9-1-686
savedefault
boot

title		Debian GNU/Linux, kernel 2.6.9-1-686 (recovery mode)
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.9-1-686 root=/dev/hda1 ro apm=on single
initrd		/boot/initrd.img-2.6.9-1-686
savedefault
boot

title		Debian GNU/Linux, kernel 2.6.8-1-686 
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.8-1-686 root=/dev/hda1 ro apm=on 
initrd		/boot/initrd.img-2.6.8-1-686
savedefault
boot

title		Debian GNU/Linux, kernel 2.6.8-1-686 (recovery mode)
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.8-1-686 root=/dev/hda1 ro apm=on single
initrd		/boot/initrd.img-2.6.8-1-686
savedefault
boot

title		Debian GNU/Linux, kernel 2.4.27-1-386 
root		(hd0,0)
kernel		/boot/vmlinuz-2.4.27-1-386 root=/dev/hda1 ro apm=on 
initrd		/boot/initrd.img-2.4.27-1-386
savedefault
boot

title		Debian GNU/Linux, kernel 2.4.27-1-386 (recovery mode)
root		(hd0,0)
kernel		/boot/vmlinuz-2.4.27-1-386 root=/dev/hda1 ro apm=on single
initrd		/boot/initrd.img-2.4.27-1-386
savedefault
boot
This has got me stumped, acpid and acpi (installed *after* problems began) are both installed, as are apmd and apm. I'd prefer not to recompile the kernel, but I will if I have to.

Last edited by andymadigan; 12-07-2004 at 09:26 PM.
 
Old 12-08-2004, 01:17 AM   #2
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
you likely have acpi support enabled now. apm *should* be in the debian stock kernel. if it is - boot with the kernel command line option "acpi=off" to go back to apm. however acpi might give you better control about powermanagement - it can do the same as apm ...& more.
pm would be just the same - execpt "acpid" is now responsible for putting your laptop to sleep ("apmd" for apm).

sl mritch.
 
Old 12-08-2004, 06:59 AM   #3
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,241

Rep: Reputation: 77
Did you try:
Code:
modprobe apm
Or check to see if the apm module is loaded:
Code:
lsmod
apm is built as a module. You may have to add "apm" to /etc/modules to make sure it is loaded at boot time.
 
Old 12-08-2004, 06:06 PM   #4
sebyte
LQ Newbie
 
Registered: Jan 2004
Location: London
Distribution: Debian
Posts: 15

Rep: Reputation: 0
I've a Dell Latitude L400 and am running Debian Sarge with 2.6.7. acpi didn't work for me at all, in fact my processor overheated a couple of times! apm works but only once between reboots for some reason! If I try it a second time it hangs.

apm needs RTC support (whatever that is). Check for /dev/rtc or 'lsmod | grep rtc'. I know that your BIOS must be set to 'Suspend to RAM' but beyond that I can't help I'm afraid. Good luck though.

Seb
 
Old 12-08-2004, 08:30 PM   #5
andymadigan
Member
 
Registered: Aug 2004
Location: Rochester, NY
Distribution: Debian Sid
Posts: 59

Original Poster
Rep: Reputation: 15
Partially fixed

Using acpi=off works, but I have to 'modprobe apm' once I login. When I do this, the system suspends annd I have to bring it back up, at which time the computer seems to type '~' until I hit backspace. This happens every time I come out of suspend (under kernel 2.6.9), haven't tied under 2.6.8 (about to). Any other ideas?
 
Old 12-08-2004, 08:44 PM   #6
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
sometimes apm needs to be started at early boot to work propperly. there is a kernel option "start apm at boot" which has to be selected. should be anyway.
install the apmd(eamon) "ps aux | grep apmd" to see if it's running. maybe tweak apm's configuration in /etc/apm. 2.6.9 has a acpi-rewrite which *should* give you better support - and i wasn't lucky with 2.6.8 in some cases - ymmv.

sl mritch.
 
Old 12-08-2004, 09:08 PM   #7
andymadigan
Member
 
Registered: Aug 2004
Location: Rochester, NY
Distribution: Debian Sid
Posts: 59

Original Poster
Rep: Reputation: 15
Autoload APM?

It's working better under 2.6.8 (slightly). I think the system needs to modprobe for apm at boot (I think the last posts said that, too). I don't think my laptop supports ACPI very well, but apm works, any ideas on automatically loading the module at boot? My current kernel options are apm=on acpi=off.
 
Old 12-09-2004, 01:14 AM   #8
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
put into /etc/modules

# echo "apm" >> /etc/modules

sl mritch.
 
Old 12-09-2004, 05:00 PM   #9
andymadigan
Member
 
Registered: Aug 2004
Location: Rochester, NY
Distribution: Debian Sid
Posts: 59

Original Poster
Rep: Reputation: 15
It Worked

Thanks, everything seems to be working fine now, 2.6.8 is great!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
will the ltmodem drivers work in debian sid (knoppix sid) maximalred Debian 5 05-29-2009 10:44 AM
What our the differences between debian (Sid) and knoppix 3.4 (Sid)? maximalred Debian 6 06-06-2004 08:39 PM
Unable to logon on as non-root user after update as unable to set executable context pls198 Fedora 2 04-09-2004 11:41 AM
Volume control is unable to run correctly. Unable to open audio device '/dev/mixer'. sevenreams Slackware 1 05-16-2003 07:29 PM
suspend that won't go away ronald_fancher Linux - General 3 07-14-2002 09:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 03:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration