LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   unable to mount root fs (again) (https://www.linuxquestions.org/questions/debian-26/unable-to-mount-root-fs-again-211551/)

EcceVery 07-30-2004 01:32 PM

unable to mount root fs (again)
 
I'm still struggeling with boot problems. I've make a thread about that about a month ago. Now I need help again, so here we go:

I'm using Debian (testing), have downloaded the 2.4.26 kernel och compiled it. Wehen booting the new kernel I get the following msg:

Code:

hda1: bad access, block=2, count=3
end_request: I/O Error, dev: 03:01 (hda), sector 2
EXT3-fs: unable to read superblock

hda1: bad access, block=2, count=3
end_request: I/O Error, dev: 03:01 (hda), sector 2
EXT2-fs: unable to read superblock

hda1: bad access, block=2, count=3
end_request: I/O Error, dev: 03:01 (hda), sector 2
FAT: unable to read superblock

isofs_read_super: bread failed, dev 03:01, iso_blknum=16, block=32
Kernel Panic: VFS: Unable to mount root fs on 03:01

So, does anyone know EXACTLY what needs to be compiled with the kernel to mount EXT3 filesystems? I read somewhere that initrd is involved in this, used to mount root fs before the real root fs is mounted.

I have compiled EVERYTHING in the kernel as static, using no modules at all. I have root=/dev/hda1 in lilo.conf, and it works with the kernel that comes along with Debian - so it MUST be something I've made wrong compiling my own kernel I guess.

Can it have something to do with:

1. Does it matter witch version of gcc you use? I'm not sure witch one I have actually, but since i've made a dist-upgrade it should be the latest...?

2. Does it matter if you have X running?

3. Does it matter if you're root thoughout the whole process? Normally I'm just running 'make modules_install' as root.

macondo 07-30-2004 02:30 PM

i don't know the answer, but isn't it easier to install a debian kernel-image (pre-compiled) and install it? no compiling mistakes there.

init 07-30-2004 03:13 PM

Code:

  <*> Ext3 journalling file system support                   
      [ ]  Ext3 extended attributes                         
      [ ] JBD (ext3) debugging support 

[*] Kernel support for ELF binaries                   
  <*> Kernel support for a.out and ECOFF binaries           
  <*> Kernel support for MISC binaries

An initrd would only be helpfull if you were installing ext3 support as a module.

Make sure you compile you file system support directly into the kernel and not as a module.

that should get your ext3 file system working. do a make clean save your .config to a "safe" place than do a make mrproper


X does not need to be running, does not make a difference

Yes create you kernel and modules as root.

EcceVery 07-30-2004 04:56 PM

YES!

it worked. But I have no idea what i've just done, what does 'make mrproper' do?

init 07-30-2004 09:51 PM

technicaly I dont no.

To "dumb it down" it cleans out all the left over garbage in previous compiles.

EcceVery 07-31-2004 07:39 AM

OK, now that I have a working kernel I started to add support for all the hardware I use, one by one. It all worked fine until I got to SATA (Silicon Image 3112A).

I have two SATA drives set up in a RAID-0 config. These disks contain a Windows XP installation and all the other stuff I have stored. Linux is running from an ordinary IDE disk (hda1).

With support för SIl3112A added to the kernel I was back at where I started: Unable to mount root fs. I've tried using make clean and make mrproper, but it didn't help. However, this time the output (dmesg) is somewhat different. Is the system trying to boot off the SATA drives now before hda1? I have also noticed that it doesn't detect all my drives correctly, hda1 has only two partitions (linux native and swap, there's an logical FAT32 partition as well), and hdd (YAMAHA CDRW-unit) is not detected at all.

Here's what I've added to the kernel:
Silicon Image Chipset support
Multiple devices driver support (RAID and LVM)
RAID support
RAID-0 (striping) mode
Support for IDE RAID controllers
CMD/Silicon Image Medley Software RAID

jomen 07-31-2004 08:05 AM

What could be happening here is that the kernel now tries to access your linux-partition with the wrong driver - the one you intended to use for your Windows and raid-setup.
you will have to tell your boot-loader to append a command that tells the kernel to use the ide-driver for your linux-partition.

Maybe someone can help with how this is done - I'm using lilo but I'm not sure how to do it...
Try "man lilo" or rather "man lilo.conf" and see how it is supposed to be done.

Or - even easier - compile the SATA-stuff as module - so the kernel does not have it available while booting, but later you could still use it.

EcceVery 07-31-2004 09:09 AM

OK, now I have two modules in drivers/ide/raid, araraid.o and medley.o.
Here's what happened:

Code:

ariel:/home/merlin/linux-2.4.26/drivers/ide/raid# insmod ataraid.o
ariel:/home/merlin/linux-2.4.26/drivers/ide/raid# insmod medley.o
medley.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg

Here the last part of dmesg output:

Code:

EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Freeing unused kernel memory: 100k freed
Adding Swap: 530136k swap-space (priority -1)
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,1), internal journal
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module  1.0-6106  Wed Jun 23 08:14:01 PDT 2004
spurious 8259A interrupt: IRQ7.
Medley RAID: No usable RAID sets found

now what? I have never used modules before, so help me out here...

jomen 07-31-2004 09:43 AM

...so this means you can boot o.k. now, right?
What is the problem now ? That you cannot access your Windows-on-raid setup?

The loading of medley.o failed - I cannot tell you why.

Is it the right driver with the right options (sometimes modules need to be given parameters to load them properly - as the message tells you)?

You do know, that it could be dangerous to your WindowsXP to mount it from linux - read/write that is - and only when the filesystem im WinXP is ntfs - do you ? There is no problem when you are accessing fat32 partitions.

I know almost nothing about raid - someone else will need to help here!

EcceVery 07-31-2004 09:52 AM

Yes, the system itself boots up properly. And yes, the problem is that I cannot access the raid-disks. I'm not using NTFS partitions since I don't use it's features, FAT32 is good enough for me.

I found this page but I didn't get any useful info from it.

What has to be loaded before medley.o? ataraid does, that I figured out myself.
What options could be passed to the medley driver?
Where's the raid drivers device file? /dev/md0? /dev/hde? /dev/ataraid....?

jomen 07-31-2004 10:21 AM

please edit the link in your last post - as it is now - I get to http://www.microsoft.com/ ! cannot be right - can it?

The features, cababilities and options are usually described within the kernel-source - since they are built there - look for it there.
I don't know nothing about raid...

EcceVery 07-31-2004 01:52 PM

Link is edited... it was 2x http:// .... very strange that it lead to microsoft, they've got their hands everywhere.

EcceVery 07-31-2004 02:00 PM

I think I need to get some things straight before I go on:

1. Is software RAID different from RAID using it's own chipset with BIOS and stuff?
2. Do you have to re-write the partition table to access RAID volumes? Read that somewhere...


All times are GMT -5. The time now is 07:27 AM.