-   Debian (
-   -   unable to login as user; can login as root. (

rksanders 03-02-2005 11:14 PM

unable to login as user; can login as root.
After installing all of the packages needed to compile kernel 2.6.8, and after successful installation of the new kernel, and after successfully booting the new kernel, I am unable to login using my username.
I can login as root with no problem. I have a single user system, but I login as root only when necessary.
All of the files in my /home/user directory are intact. The information in passwd is unchanged. I just can't login as user.
Using adduser I added a new user and password. Same thing.
I have upgraded my kernel several times and never had any problem.
At the login prompt I type in my username and get a message "System bootup in progress-please wait." And then, "incorrect login." The request for password never appears. I type in root and get the same System bootup...message, but I also get a "Password:" prompt.

Any ideas anybody.


Engmar 03-03-2005 03:42 AM

Out of curiosity...did you do this recompile to get ATI drivers working? What other adjustments were made? I have seen this problem before, and both times were after installs of video drivers or updates to desktop environments. In both cases the installers had changed the permissions on crucial directories, and the user did not have access to them anymore.

When logged in as root, can you su into another user?

Can you log the user in into a different desktop environment?

As root, have you checked the user's group memberships and made sure they were not changed somehow? You could also check the groups themselves and make sure they were not altered.

This may be the wrong track to follow, but it is all I can think of at the moment. By the way, have you tried booting into your old kernel?

doc.nice 03-03-2005 07:50 AM

seems as if the script /etc/init.d/rmnologin is never started,
maybe you removed /etc/rc?.d/S99rmnologin or set default runlevel to single user (1) instead of 3 (mutliuser, network, console) or 5 (multiuser, network, X)

when the file /etc/nologin exists, its message is shown when a normal user tries to log in and the login is cancelled. only superuser can login while this file exists... (try deleting it manually for a test, but this will not fix your problem, the file is created by /etc/init.d/ at bootup and deleted by /etc/init.d/rmnologin as last "boot job"


EliotK 03-03-2005 10:03 AM

I use root all the time to be honest, it's easier to do system stuff.

utanja 03-03-2005 10:16 AM


Originally posted by EliotK
I use root all the time to be honest, it's easier to do system stuff.
that can be quite a disaster......better to log in as a user and sudo to the adimin processes you need

EliotK 03-03-2005 10:21 AM

Not as long as you know what your doing, what can happen?

*EDIT* Yeah if your doing chat stuff on irc etc its better not to use root.

voyciz 03-03-2005 10:56 AM


Originally posted by EliotK
Not as long as you know what your doing, what can happen?

*EDIT* Yeah if your doing chat stuff on irc etc its better not to use root.

Sure, if you know what you're doing every time, then you are protected from yourself...but what about others? What about your system? It's supposed to be pretty dangerous to run X as root. Physical security is something you need too, what happens if you leave for a second and someone decides to mess with your computer? To protect yourself from your system like that, it'd be pretty tough; you'd need to read all the source code of every program you have on your computer and verify it's not gonna do anything you don't want it to. Then you'd need to read the source for each and every new program you get. That's pretty difficult if you're using a binary distribution. Plus, being connected to the internet while logged in as root for any more than a few seconds just seems like a bad idea. I'm no expert on the subject, so I can't go into detail, I just don't do it. To me, it's worth it to use "su".

EliotK 03-03-2005 11:01 AM

Ok i get your point, but what are the chances? Ive always logged in as root for my 2 years of using linux, no asshole has ever tried to hack me or break into my house and use my comp while im taking a leak.

voyciz 03-03-2005 11:07 AM

You know that for sure, EliotK? Because if they did a good job, then you'd never know the difference :).

EliotK 03-03-2005 11:16 AM

Yep I know that for sure, becuase Ive got nothing intresting anway except for a cedega rpm, but really who cares?

voyciz 03-03-2005 11:21 AM

The fact that you have an internet connection is interesting to some people. You could be being used as a mask, cracking into other people's systems through yours that way they're undetected.

EliotK 03-03-2005 11:23 AM

Didnt you read the last two words, who cares?

I really cant be bothered to debate this.
Anyway whats slackware like? Ive Been thinking about getting it.

voyciz 03-03-2005 11:29 AM

To answer your first question: a lot of people, me included.

For the second: I love Slackware, but haven't tried anything else...except I tried RH at first, but wasn't to happy with that. It's pretty easy to install and doesn't get in your way or do anything you don't want it to. Some people dislike its package management system, but I love it. It's nice and simple, nothing extra like dependency checking. If you want something that'll download software for you like apt-get, Swaret and Slapt-get are the most popular I believe. Also has nice little tools that make it easier to create your own. Plus, Slack has a simple init script structure, and I love that as well. Basically, Slack is simple and doesn't give you anything extra, and since it's Linux, highly configurable.

EliotK 03-03-2005 11:34 AM

Yeah it's a shame debian doesnt support any rpms, thats what put me off it, but im running it now anyways, I got slackware 9.1 once on my comp and it ran painfully.

voyciz 03-03-2005 11:36 AM

Painfully? Why? Recent versions of Slack include rpm, but last time I checked, it was experimental.

All times are GMT -5. The time now is 11:19 PM.