LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   Trying to install Nessus (https://www.linuxquestions.org/questions/debian-26/trying-to-install-nessus-521260/)

dellthinker 01-20-2007 05:15 PM

Trying to install Nessus
 
Code:

Errors were encountered while processing:
 uw-imapd
E: Sub-process /usr/bin/dpkg returned an error code (1)

Whats the problem? I followed the package instructions. apt-get install nessus nessusd -y

Any help? This is a Debian machine mind you. Just installed yesterday

farslayer 01-20-2007 06:41 PM

uw-imapd is an imap mail program, and is not part of nessus.

I wouldn't think this would be a dependancy for Nessus, so you must have it installed for some other reason...
uw-imapd - http://www.washington.edu/imap/

Code:

debian:~# apt-get install nessus nessusd
Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
  libgd2-noxpm libgdchart-gd2-noxpm libnasl2 libnessus2 nessus-plugins
Suggested packages:
  libgd-tools
Recommended packages:
  nmap snmp
The following NEW packages will be installed:
  libgd2-noxpm libgdchart-gd2-noxpm libnasl2 libnessus2 nessus nessus-plugins
  nessusd

0 upgraded, 7 newly installed, 0 to remove and 1 not upgraded.
Need to get 3169kB of archives.
After unpacking 17.6MB of additional disk space will be used.
Do you want to continue [Y/n]? n

apt did not ask to install uw-imapd and apt-cache shows it as not being installed on my system. .
Code:

debian:/etc/apt# apt-cache policy uw-imapd
uw-imapd:
  Installed: (none)
  Candidate: 7:2002edebian1-13
  Version table:
    7:2002edebian1-13 0
        500 ftp://ftp.uwsg.indiana.edu sid/main Packages

you also didn't specify which version of Debian you are trying to do this on, which might be helpful..
(stable/sarge/3.1r4 or testing/etch or unstalble/sid)

is uw-imapd something you need ? you could try removing it from your system first, and then try to install nessus again..

apt-get --purge remove uw-imapd remove uw-imapd and all of it's configuration files
apt-get clean && apt-get autoclean remove all files in the apt download cache in case theres one is corrupt
apt-get update download the latest package list from the apt repository
apt-get check check for broken dependancies
apt-get install nessus nessusd install nessus

That's what I would try first..


All times are GMT -5. The time now is 01:01 PM.