LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 07-10-2017, 11:51 PM   #1
joboy
Member
 
Registered: Jul 2009
Distribution: Debian, Ubuntu, Puppy, Mint
Posts: 430

Rep: Reputation: 5
Touchpad active while typing


Hi there,

I am running Linux Mint Debian 2 and got an annoying problem.
I am using a Thinkpad with touchpad, I already set to disable touchpad while typing, but I still interfere by the touchpad while typing causing lot of typo and screen jumps etc., I can reproduce this problem every time with terminal, while I typing with one hand I draw on the touchpad with another, both worked at the same time, any comment ?
 
Old 07-11-2017, 04:46 AM   #2
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,375

Rep: Reputation: 568Reputation: 568Reputation: 568Reputation: 568Reputation: 568Reputation: 568
Just to get a better handle on this....Which desktop environment are you using?
Quote:
I am using a Thinkpad with touchpad, I already set to disable touchpad while typing,
What steps did you take specifically?

Which Xorg input driver is serving the touchpad?
Code:
grep "Using input driver" /var/log/Xorg.0.log
What properties does xinput show for the touchpad device?
Code:
xinput list-props <toucpad_ID>
 
Old 07-11-2017, 10:41 AM   #3
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro / Parrot
Posts: 7,180

Rep: Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439
so what ya want to just kill that dang thing ?
Code:
#completely turn off the touchpad

xinput set-prop 12 "Device Enabled" 0
	synclient touchpadoff=1
	synclient VertEdgeScroll=0
	synclient TapButton1=0
        synclient TapButton2=0
	synclient TapButton3=0 &
I got that put in my startup file in Fluxbox and other desktops and WM I use.

Touchpad Synaptics

if that is what it is, if not then google whatever you get back from issuing that grep what do I got output.

Last edited by BW-userx; 07-11-2017 at 10:45 AM.
 
Old 07-12-2017, 01:32 AM   #4
joboy
Member
 
Registered: Jul 2009
Distribution: Debian, Ubuntu, Puppy, Mint
Posts: 430

Original Poster
Rep: Reputation: 5
Quote:
Originally Posted by ferrari View Post
Just to get a better handle on this....Which desktop environment are you using?

What steps did you take specifically?

Which Xorg input driver is serving the touchpad?
Code:
grep "Using input driver" /var/log/Xorg.0.log
What properties does xinput show for the touchpad device?
Code:
xinput list-props <toucpad_ID>
I am using the default Mint Debian with Cinnamon desktop in the setting UI to disable touchpad while typing, that worked on previous version I forgot which one.

=======================================================
[ 30.284] (II) Using input driver 'evdev' for 'Power Button'
[ 30.284] (II) Using input driver 'evdev' for 'Video Bus'
[ 30.285] (II) Using input driver 'evdev' for 'Video Bus'
[ 30.285] (II) Using input driver 'evdev' for 'Sleep Button'
[ 30.286] (II) Using input driver 'evdev' for 'HID 413c:3010'
[ 30.286] (II) Using input driver 'evdev' for 'Integrated Camera'
[ 30.287] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[ 30.288] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[ 30.388] (II) Using input driver 'evdev' for 'TPPS/2 IBM TrackPoint'
[ 30.389] (II) Using input driver 'evdev' for 'ThinkPad Extra Buttons'
[ 30.389] (II) Using input driver 'evdev' for 'BRLTTY 5.2dev Linux Screen Driver Keyboard'

=======================================================
 
Old 07-12-2017, 02:03 AM   #5
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,375

Rep: Reputation: 568Reputation: 568Reputation: 568Reputation: 568Reputation: 568Reputation: 568
Ok, well that confirms that the synaptics driver is in use for your touchpad. I'm not a Mint (or Cinammon user), but it does seem to be a known issue if the following is anything to go by...

https://github.com/linuxmint/Cinnamon/issues/6529

However, the synclient/syndaemon commands can be used to achieve the same eg
Code:
syndaemon -i 4 -d
Code:
synclient PalmDetect=1
https://wiki.archlinux.org/index.php...d_while_typing

and not hard to execute via a startup file if desired.
http://winaero.com/blog/manage-startup-apps-linux-mint/
 
Old 07-14-2017, 02:36 AM   #6
joboy
Member
 
Registered: Jul 2009
Distribution: Debian, Ubuntu, Puppy, Mint
Posts: 430

Original Poster
Rep: Reputation: 5
Thanks, I hope later update will fix the problem. I never like touchpad, I want to completely disable it and use the thumb stick instead, but I need the two buttons, hated that too built onto the pad.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] syndaemon and disabling touchpad while typing stormtracknole Slackware 5 06-02-2018 02:09 PM
[SOLVED] Disabled touchpad while typing? salparadise Slackware 6 11-16-2012 02:32 PM
[SOLVED] touchpad interfering with typing in Squeeze (Debian) Gnome. edbarx Linux - Laptop and Netbook 6 02-26-2012 06:52 AM
Touchpad disable/enable typing. zuriel45 Linux - Software 2 01-21-2011 09:42 AM
Disabling Touchpad while typing. nardz Linux - Desktop 4 01-24-2008 05:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 05:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration