-   Debian (
-   -   Total system freeze (

Kirmonkey 03-09-2007 03:28 PM

Total system freeze

Recently I have found that my system has been freezing at non-regular intervals. The freeze is total, the pointer won't move and the usual keyboard combinations such as ctrl+alt+backspace and alt+tab+f4 have no effect.

Upon rebooting and looking in var/log/messages and other logs there there is no indication of any problems, normal activity is logged then there is the reboot being logged, no errors in between.

I am running the following:

Debian etch

xorg.conf: (sorry, the insert quote button is not responding)

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

Section "Module"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"

Section "Device"
Identifier "S3 Savage"
Driver "savage"
VideoRam 16000
Option "UseFBDev" "true"

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-57
VertRefresh 43-60

Section "Screen"
Identifier "Default Screen"
Device "S3 Savage"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1152x768" "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 4
Modes "1152x768" "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 8
Modes "1152x768" "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 15
Modes "1152x768" "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 16
Modes "1152x768" "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 24
Modes "1152x768" "1024x768" "800x600" "640x480"

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"

Section "DRI"
Mode 0666

Any starting suggestions appreciated

It really is quite annoying you know.

comprookie2000 03-09-2007 05:30 PM

May Help may not;

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse" "CorePointer"
InputDevice "Synaptics Touchpad" "AlwaysCore"

Dutch Master 03-09-2007 05:40 PM

I suspect a problem with the driver for your videocard. Try the VESA driver for a start. If that's stable your videocard driver needs updating or re-installing at least. In the Device section is a line

Option "UseFBDev" "true"
Try "no" there ;) Or put a hash (#) in front of it. Reboot.

AwesomeMachine 03-10-2007 03:00 AM

Are you overclocking by any chance?

Kirmonkey 03-10-2007 03:59 AM

Thanks for all the suggestions.

Comprookie, I tried your solution with no luck

Dutch Master, The same issue occured with the vesa driver and the FBDev option

AwesomeMachine, I am not overclocking but I initially suspected overheating. I have spent the last 2 hours running puppy linux with no problems so...

Either my Debian installation is causing a hardware problem that cases the system to freeze; or there is a genuine software problem.

The cooling fans (it is a laptop) are not working particularly hard though...

I have tried running another browser as I initally suspected Firefox 2 was causing the problem but this is not the case. I will try and eliminate some other possibilities this morning.


Sepero 03-10-2007 04:04 AM

Dutch Master, may be correct. I had Very similar problems with my NV card. When I switched to regular old vesa, the lockups stopped immediately.

Also, it may theoretically be a hardware problem. harddrive/ram/motherboard/videocard/other?

craigevil 03-10-2007 07:21 AM

I had a similar problem a while back Etch would freeze but Sid didn't. Turned out to be mismatched ram that Sid could handle for some weird reason.

Try running a ram test.

Barring a hardware issues, updating your kernel and video driver may help.

Dutch Master 03-10-2007 08:07 AM

I made a small error regarding the UseFBDev option. These are Boolean options and thus the negative option should be "false"... If you hashed out the line entirely that error wouldn't have made a difference though, assuming you've rebooted.

Kirmonkey 03-10-2007 02:21 PM


I have made some progress in pinning down a probable cause but have as yet found no solution.

I have a broadband connection via a free and cheerful Speedtouch 330 ADSL modem manufactured by Thompson and provided by my ISP. If this is unplugged I can potter on the computer for hours at a time. If it is plugged in then the freeze happens. I haven't found a solution to this yet and I am also not 100% certain that it is the cause but it looks very likely.

I shall now go and Google...

Dutch Master 03-10-2007 02:46 PM

Here's another method of error research:
When the freeze happens, try logging in remotely via ssh from another machine. Install ssh on the offending PC before that! If the login succeeds, use the top command to find a program or service that takes unusual amount of system resources.

One more thing to investigate: are the network and videocard on the same interrupt? Move network or videocard to another slot or assign fixed, non-equal interrupts to either or both. Read the mobo manual to learn how.

Kirmonkey 03-10-2007 03:03 PM

Just for your information I am using a laptop. The ssh login sounds like a good plan though.

Kirmonkey 03-23-2007 06:59 AM

Problem overcome but not solved
Well, more for information than offering a future, much sought out,
answer for some desperate newbie.

I no longer have the problem with the speedtouch modem but I don't know what the cause of the problem was. As the system freezes where coming along regularly and were doing no good to the hardware in my system I went for the classic escape... The re-installation. Good in a way as I had the chance to remove all those 'tried once' applications that were lurking in the background.
Following the re-installation all was hunky-dory!

Thanks for all the suggestions.

All times are GMT -5. The time now is 07:33 AM.