LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 03-02-2009, 10:22 AM   #1
abd_bela
Member
 
Registered: Dec 2002
Location: algeria
Distribution: redhat 7.3, debian lenny
Posts: 622

Rep: Reputation: 31
the ssh answer is too slow


Hi,
When I connect to ssh server ( server running Redhat ) from debian it takes a long time to give me the prompt, while I receive the prompt rapidly when I connect from slackware or solaris?
thanks for help
 
Old 03-02-2009, 10:30 AM   #2
mbostwick
Member
 
Registered: Feb 2009
Location: Where ever life takes me
Distribution: gentoo,opensuse,ubuntu, arch
Posts: 110

Rep: Reputation: 18
How much ram does the sever have ? Is the machine far away? The reason there is a slow response usually has something to do with a lag in resources somewhere. Any ideas based on your setup ?
 
Old 03-02-2009, 04:27 PM   #3
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,686

Rep: Reputation: 124Reputation: 124
Nope, it's not distance... I connect to my Lenny fileserver (4 GB RAM) from my Etch desktop (2 GB RAM) and get a proper wait too. Mind you, the network is Gbit (including the Netgear switch, which was selected on presence of Gbit ports), cable length is only 15-20 meters apart. I suspect IPv6 to be the culprit instead...
 
Old 03-02-2009, 05:02 PM   #4
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora
Posts: 3,935
Blog Entries: 5

Rep: Reputation: Disabled
@abd_bela, your setup:
  • RHEL server running sshd
  • Debian client
  • Slackware client
  • Solaris client

When ssh'ing from Debian to RHEL, you have a long wait, but when ssh'ing from Slackware or Solaris to RHEL, things are normal? Correct?

If that's not correct, clearly explain. If that is correct, check your nameserver (/etc/resolv.conf) settings on the Debian client. Maybe it's taking a long time to resolve names, period.
 
Old 03-02-2009, 09:55 PM   #5
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Northeast Ohio
Distribution: linuxdebian
Posts: 7,243
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
Is ip6 enabled on your Debian box ?

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=341042

other things you can try.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=409360

http://en.kioskea.net/faq/sujet-1393...on-under-linux


you can browse the list for other possibilities
http://bugs.debian.org/cgi-bin/pkgre...openssh-client
 
Old 03-02-2009, 10:23 PM   #6
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,686

Rep: Reputation: 124Reputation: 124
Bingo, it was the avahi deamon. Disabling it solved my problem. link For Debian: edit /etc/default/avahi-daemon as per the instructions given and reboot. Not sure if it works the same way on Lenny, I presume it does.

Thx Farslayer, I missed the avahi thingy :-\
 
Old 03-03-2009, 11:16 AM   #7
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora
Posts: 3,935
Blog Entries: 5

Rep: Reputation: Disabled
Dutch_Master == abd_bela?

Or are you hijacking his thread?
 
Old 03-03-2009, 11:20 AM   #8
utanja
Member
 
Registered: Apr 2004
Location: Europe:Salzburg Austria USA:Orlando,Florida;
Distribution: Debian
Posts: 643

Rep: Reputation: 32
Quote:
Originally Posted by Dutch Master View Post
Bingo, it was the avahi deamon. Disabling it solved my problem. link For Debian: edit /etc/default/avahi-daemon as per the instructions given and reboot. Not sure if it works the same way on Lenny, I presume it does.

Thx Farslayer, I missed the avahi thingy :-\

Just saw this thread......I disabled avahi-daemon several months ago and it will speed up ssh in lenny as well as sid.....I use sysvconfig to disable...
 
Old 03-03-2009, 12:54 PM   #9
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Northeast Ohio
Distribution: linuxdebian
Posts: 7,243
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
Quote:
Originally Posted by anomie View Post
Dutch_Master == abd_bela?

Or are you hijacking his thread?
I'm betting Dutch_Master had the same or similar issue. That's the great thing about these forums, you may not actively be looking for a solution to a nusiance issue, then BAM you suddenly stumble upon an answer. Often from where you least expect it

Glad those links were useful for somebody, now we have to waid for abd_bela to respond to see if one of the links (or other responses) solves their issue as well.
 
Old 03-03-2009, 07:08 PM   #10
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,686

Rep: Reputation: 124Reputation: 124
Dutch_Master != abd_bela! Netherlands != Algeria too
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
APG (Automatic Password Generator) very slow to answer jmcollin92 Linux - Security 2 05-23-2006 01:23 PM
SLOW SSH connection adriaanbw Linux - Networking 1 04-27-2006 06:13 PM
ssh really slow one way. nephish Linux - Networking 5 12-25-2005 03:59 PM
ssh too slow ksgill Linux - Newbie 3 10-26-2004 04:44 PM
Slow SSH... Grim Reaper Linux - Security 17 09-25-2003 05:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 06:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration