LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 06-25-2010, 11:33 AM   #1
Mr. Alex
Senior Member
 
Registered: May 2010
Distribution: No more Linux. Done with it.
Posts: 1,238

Rep: Reputation: Disabled
Question TAB button doesn't work always


When I type in "sudo apt-get in" and press TAB, it completes word "install".
But when I logged in as super user and type in "apt-get in" and press TAB, it only beeps from system unit and doesn't complete "install". Why?

Debian 5.0.4 stable. Gnome. "gnome-terminal".
 
Old 06-25-2010, 11:49 AM   #2
paulsm4
LQ Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Look here
 
Old 06-26-2010, 01:36 AM   #3
Mr. Alex
Senior Member
 
Registered: May 2010
Distribution: No more Linux. Done with it.
Posts: 1,238

Original Poster
Rep: Reputation: Disabled
Thanks, but can't find an answer there...
 
Old 06-26-2010, 02:58 AM   #4
paulsm4
LQ Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Hi -

What part of "/etc/bash_completion" didn't work?

The advice about "apt-get install bash-completion" was good, except that it sounds like you already have it. It just doesn't work for "root".

I believe all you probably have to do is source /etc/bash_completion in root's environment (e.g. in root's .bashrc).

In any case, I'm hopeful you'll find SOMETHING useful in one of these links:

http://www.debian-administration.org...pletion_part_1

http://www.debian-administration.org...pletion_part_2

http://linuxhelp.blogspot.com/2005/0...asier-for.html

http://www.howtoforge.com/how-to-add...tion-in-debian

'Hope that helps .. PSM

PS:
Please post back what you find!
 
Old 06-26-2010, 11:14 PM   #5
j1alu
Member
 
Registered: Apr 2009
Distribution: debian gnu/linux
Posts: 798

Rep: Reputation: Disabled
Search for something looking similar like this:
Quote:
if [ -f /etc/bash_completion ]; then
. /etc/bash_completion
fi
in the users /home/user/.bashrc and copy/paste it to roots /root/.bashrc.
Or just copy the whole /home/user/.bashrc to /root, run 'source /root/.bashrc' and it should work.
 
1 members found this post helpful.
Old 06-27-2010, 01:36 AM   #6
Mr. Alex
Senior Member
 
Registered: May 2010
Distribution: No more Linux. Done with it.
Posts: 1,238

Original Poster
Rep: Reputation: Disabled
Smile

Quote:
Originally Posted by paulsm4 View Post
Please post back what you find!
I got it, thanks!
 
  


Reply

Tags
autocomplete, gnome, tab, terminal


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
TAB button doesn't work always Mr. Alex Debian 3 06-25-2010 07:15 PM
Alt-Tab does not work under Xfce or Gnome kosmik Linux - Desktop 1 09-02-2009 12:09 PM
ALT+TAB and Cedega - how to make it work? iro_number1 Linux - Software 4 02-22-2008 12:50 PM
tab button in textbox Four LQ Suggestions & Feedback 0 02-15-2008 12:07 AM
I want the TAB button to work like WinDoze mr.flywheel Mandriva 5 12-20-2004 05:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 05:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration