LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 10-14-2004, 12:38 AM   #1
azeini
LQ Newbie
 
Registered: May 2004
Distribution: Debian GNU/Linux
Posts: 12

Rep: Reputation: 0
System not booting after dist-upgrade to Sarge


Hi,

Today I made a dist-upgrade from Woody to Sarge. All went well it seems. After apt was finished, I made a reboot and that's when the problems began.
My system doesn't boot anymore but instead gets into a boot loop, where it shows the initial boot screen first, then some other information which I have always been seeing, but then I see the characters "LI"; lilo however doesn't start. Instread the whole procedure begins from the beginning.

I booted my system with KNOPPIX but can not find any strange things in the /boot directory or elsewhere. I tried installing lilo again with a "chroot," but it gives me the following message:

/dev/mapper/control: open failed: Permission denied
Is device-mapper driver missing from kernel?
/dev/mapper/control: open failed: Permission denied
Is device-mapper driver missing from kernel?
Incompatible libdevmapper 1.00.19-ioctl (2004-07-03)(compat) and kernel driver
Fatal: open /dev/hda: Permission denied

Any idea what could be wrong and what I would need to do?
You help is appreciated.
 
Old 10-14-2004, 09:48 AM   #2
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,017

Rep: Reputation: 52
usually, during the dist-upgrade if you use LILO, it tells you what to do after you answer YES. IIRC, it's ' /sbin/lilo for it to keep on working.

If you have Knoppix, get in, uninstall LILO, and reinstall it to your drive or install GRUB, to your hda or designated drive.

There is an explanation how to uninstall LILO and install GRUB in the Debian Configuration sticky at the top of this page, i think it is on page 2.
 
Old 10-14-2004, 11:41 AM   #3
azeini
LQ Newbie
 
Registered: May 2004
Distribution: Debian GNU/Linux
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks for your reply. But this is exactly the problem. LILO usually asks what to do, but it didn't during the dist-upgrade.
The second probelm is that if I try to issue the 'lilo' command, I get this:

/dev/mapper/control: open failed: Permission denied
Is device-mapper driver missing from kernel?
/dev/mapper/control: open failed: Permission denied
Is device-mapper driver missing from kernel?
Incompatible libdevmapper 1.00.19-ioctl (2004-07-03)(compat) and kernel driver
Fatal: open /dev/hda: Permission denied

Any idea why this keeps coming up?
 
Old 10-14-2004, 12:42 PM   #4
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,017

Rep: Reputation: 52
Hmm, maybe it asked you and you missed it, we don't know what you did that is giving you that kind of error, usually, a dist-upgrade is something uneventful.

You got 2 choices: waste 2-3 days reinventing the wheel or install the sarge net-installer, you should be thru in 2-3 hours from beginning to end.

Last edited by macondo; 10-14-2004 at 12:44 PM.
 
Old 10-14-2004, 01:09 PM   #5
azeini
LQ Newbie
 
Registered: May 2004
Distribution: Debian GNU/Linux
Posts: 12

Original Poster
Rep: Reputation: 0
Problem solved

Thanks for taking so much time macondo. It is good possible that I just missed the LILO question.

But I solved my problem. I booted my laptop with my Woody installation CD and issued "rescue root=/dev/hda7" at the boot prompt. Once booted into the system the rest was easy. I just needed to make a bit of mounting and then to reinstall my old lilo. That made the trick. I don't know why the idea of using the installation CD didn't cross my mind earlier

Thanks a lot again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get question: dist-upgrade vs upgrade Arodef Fedora 9 06-15-2012 02:33 PM
dist-upgrade sarge tp unstable: errors, hangs on boot haertig Debian 7 11-17-2005 04:57 PM
Did someone dist-upgrade this system? How can I tell? johnMG Debian 3 10-31-2005 05:08 PM
Help needed : Dual booting of Linux 8.0 after system upgrade akroy Linux - General 1 11-08-2003 01:01 AM
Error trying to dist-upgrade or upgrade KDE prophet621 Linux - Newbie 0 09-10-2003 05:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 11:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration