-   Debian (
-   -   System freeze, input devices not responding? (

R00ts 08-09-2004 02:01 AM

System freeze, input devices not responding?
For some reason, my system has been freezing up today and I can't figure out why. At first I thought it was my CPU overheating because my BIOS detected it at 99C (ouch), but after I swapped heat sinks I'm now running at about 50C, but I still got the freeze. It ususually happens after about 20 minutes or so, and my keyboard won't respond (the numlock light won't even come on) and although I can move my mouse cursor, if I try to click anything I get no action. But my music will still play, and my files will still download. Its very strange, almost as if my system decides to cut off my keyboard and mouse buttons. What on earth could be wrong here? The most recent changes I've done to my system:

Installed ATI drivers (yesterday)
Installed another 512MB of RAM (3 days ago)

Here's my /etc/X11/XF86Config-4 file just in case, but I didn't change anything on keyboard and mouse except for the identifier name, and up until now those settings have been working perfectly for me. The keyboard and mouse are brand new and have been working for 3 days without any problems (until now). Does anyone have any clue at all what could be wrong here? :study:


# XF86Config-4 (XFree86 X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
# This file is automatically updated on xserver-xfree86 package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xfree86
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#  cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
#  md5sum /etc/X11/XF86Config-4 > /var/lib/xfree86/XF86Config-4.md5sum
#  dpkg-reconfigure xserver-xfree86
Section "Files"
        FontPath        "unix/:7100"                    # local font server
        # if the local font server has problems, we can fall back on these
        FontPath        "/usr/lib/X11/fonts/misc"
        FontPath        "/usr/lib/X11/fonts/cyrillic"
        FontPath        "/usr/lib/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/lib/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/lib/X11/fonts/Type1"
        FontPath        "/usr/lib/X11/fonts/CID"
        FontPath        "/usr/lib/X11/fonts/Speedo"
        FontPath        "/usr/lib/X11/fonts/100dpi"
        FontPath        "/usr/lib/X11/fonts/75dpi"
Section "Module"
        Load    "GLcore"
        Load    "bitmap"
        Load    "dbe"
        Load    "ddc"
        Load    "glx"
        Load    "dri"
        Load    "freetype"
        Load    "int10"
        Load    "record"
        Load    "speedo"
        Load    "type1"
        Load    "vbe"
        Load    "extmod"
        #Load "extmod" but omit DGA extension
        SubSection "extmod"
          Option "omit xfree86-dga"
Section "InputDevice"
        Identifier      "Logitech 104-key keyboard"
        Driver          "keyboard"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xfree86"
        Option          "XkbModel"      "pc104"
        Option          "XkbLayout"    "us"
Section "InputDevice"
        Identifier      "Logitech Intellimouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
        Option          "Emulate3Buttons"      "false"
        Option          "ZAxisMapping"          "4 5"
Section "Device"
        Identifier      "ATI Radeon 9500 Pro"
        Driver          "fglrx" # ATI propriety drivers
# If X refuses to use the screen resolution you asked for, uncomment this
        #Option "NoDDC"
# === Video Overlay for the Xv extension ===
        Option "VideoOverlay" "on"
# === OpenGL Overlay ===
# Note: When OpenGL Overlay is enabled, Video Overlay will be disabled automatically
        Option "OpenGLOverlay" "off"
# if OpenGL acceleration doesn't work, try using "yes" here and disable the kernel agpgart driver
        Option "UseInternalAGPGART" "no"
Section "Monitor"
        Identifier      "Hitachi CML174"
        HorizSync      24-80
        VertRefresh    56-75
        Option          "DPMS"
Section "Screen"
        Identifier      "Default Screen"
        Device          "ATI Radeon 9500 Pro"
        Monitor        "Hitachi CML174"
        DefaultDepth    24
        SubSection "Display"
                Depth          1
                Modes          "1280x1024" "1024x768" "800x600" "640x480"
        SubSection "Display"
                Depth          4
                Modes          "1280x1024" "1024x768" "800x600" "640x480"
        SubSection "Display"
                Depth          8
                Modes          "1280x1024" "1024x768" "800x600" "640x480"
        SubSection "Display"
                Depth          15
                Modes          "1280x1024" "1024x768" "800x600" "640x480"
        SubSection "Display"
                Depth          16
                Modes          "1280x1024" "1024x768" "800x600" "640x480"
        SubSection "Display"
                Depth          24
                Modes          "1280x1024" "1024x768" "800x600" "640x480"
Section "DRI"
  Mode 0666
Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice    "Logitech 104-key keyboard"
        InputDevice    "Logitech Intellimouse"
Section "DRI"
        Mode    0666

sterrenkijker 08-09-2004 06:38 AM

Hmmm, cpu overheat? Recently I found on the site of my cpu's manufacturer (AMD) my cpu wil get damaged at 85 C. Cpu overheat can cause permanent damage to your processor. I think this is a good page to start...

I hope for you your processor isn't damaged!

Dead Parrot 08-09-2004 07:29 AM

Overheating CPU and sudden freezes may indicate bad hardware. You should probably install some hardware diagnosis progams and run some tests to make sure that everything is OK on the hardware side.

I've managed to wreck one motherboard using unsupported hdparm settings (had to buy a new motherboard). I've also heard that using incorrect refresh rates can physically damage your monitor. Other than that, Debian GNU/Linux should be quite hardware-friendly OS. Usually problems are caused by using cheap and low-quality hardware, not by using Debian.

m_yates 08-09-2004 10:31 AM

I had a heat damaged CPU once and it caused all sorts of strange lock ups. The problems were intermittant and they were not fixed until my CPU was replaced. It'd be a good bet that heat damage is the problem. Depending on your BIOS, you may be able to set the computer to shut down if the CPU temp gets too high. You can also set alarms or run commands when the CPU temp is too high by using "ksensors" in Debian.

R00ts 08-09-2004 10:57 AM

Yeah then the problem definitely seems to be permanent damage from CPU overheating. :( Dammit and I just had this CPU replaced recently too! :cry: Thanks for the help guys. I didn't think Debian was at fault but I wanted to make sure.

All times are GMT -5. The time now is 10:56 PM.