LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   System Beep gone w/ OSS & ALSA (https://www.linuxquestions.org/questions/debian-26/system-beep-gone-w-oss-and-alsa-158827/)

Outabux 03-17-2004 02:59 AM

System Beep gone w/ OSS & ALSA
 
After upgrading to 2.6.X in either ALSA or OSS Deprecated, the beeps for using the completion "TAB" are gone.

What has happened? In X, inside console; they are there, sound ok with alsa...:scratch:


Loaded 2.4.18 old kernel, beeps present.

When hot swapping cards into cardbus slots (xircom or flash ide) no beeps in either X or console in 2.6.X.

Please help, something I forgot or am I goin crazy....crazy for DEBIAN...militarily free!:D:

Outabux 03-19-2004 11:44 PM

Found some info on disabling that "annoying beep"; it says to go into what I believe is /etc/event/beep ? and run the command beep off ?.

That file is present in knoppix 3.3 install I think.
But its not present at all; even though in 2.4.18, works.
Any ideas?

She doesn't even beep when inserting pcmcia or cardbus cards at all, even in X.

Thanks again.

Outabux 03-19-2004 11:45 PM

also add by modprobing the pcm_oss_? drivers, two of them...I know this is a little shallow but they are for oss compatibility. That did not do it either. Sound as the same.

HappyTux 03-20-2004 01:27 AM

Re: System Beep gone w/ OSS & ALSA
 
Quote:

Originally posted by Outabux
After upgrading to 2.6.X in either ALSA or OSS Deprecated, the beeps for using the completion "TAB" are gone.


Do you have this option set in the configuration?
Code:

CONFIG_INPUT_PCSPKR=y

Outabux 03-20-2004 05:59 AM

Nope, Ill try It and get back to ya!

snacky 03-20-2004 06:17 AM

HappyTux has nailed it, this has nothing to do with Alsa. It is precisely the kernel config option he specified, under Device Drivers/Input Device Support/Misc.

Outabux 03-20-2004 08:00 AM

Im currently printing 300 sheets for a program for a Baptist convention for my mother. Just as soon as this HP4Plus gets done, I'll recompile.

I believe when I reviewed that particular option, it didn't have a very good description or one at least I could translate--oh well, in about an hour or two I'll reply. Thanx again for verifying further the explanation.

I recompile to remove an option in a subsection of a subsection of a subsection that I missed, ya got it.

Again thanx, yall a blessin.

Outabux 03-20-2004 10:47 AM

Well that did not do it. I tried inserting cards and using the completion tab...no dice.

Any more suggestions linuxquestions.org? Please help. I like the beeps to inform me if a pcmcia or cardbus card had been inserted and initiallized properly...one beep the another beep, good...one beep then two, BAD!

completion tab works in terminal in X, no pcmcia beeps at all.


Thanx Again. Outabux and Outatime and Outafeatures...:confused: :newbie: :scratch:

snacky 03-20-2004 03:51 PM

No, you're not REMOVING an option, you are enabling one. Are you sure you're doing the right thing?

Outabux 03-20-2004 08:55 PM

Yes, I enabled the pcspkr built-in. No luck. The reason I said that I would be removing something would be to kill to birds with one stone. I had discovered that while looking over my own posts in debian for acpi patch that I included my .config and the output of dmesg. Although I could not find it when I recompiled to enable the kernel option you described, I could not remember or find the one I had to remove.

I dunno, keepem comin...

I'll prolly start from scratch again...bf24 and exiting before tasksel and leaving exim broken and using rcconf to remove that symlink from the rc directories. I will then perform a distribution upgrade based upon a new sources.list and using my new .config and patch to configure the new kernel 2.6.4 n see what happens, making sure not to forget to apt-get install module-init-tools, alsa stuff, pcmcia-cs, microcode (I dunno why), and some other packages that I need to make the transition to 2.6.X.

Outabux 03-24-2004 07:03 AM

Got It! But More Problems...
 
With ALSA, all channels muted by default.

amixer set Master 100 unmute
amixer set PCM 100 unmute

solved problem

for some reason, changing volume in kde didn't do it, nor did adjusting aumix inside console before this install.

a caveat, when initializing bzflag, sound is not available unless i let the machine (i suppose) settle for a few moments, and then she's ready.

But my network going screwy again inside kde! What!

Anyway keep replying.


All times are GMT -5. The time now is 01:46 PM.