-   Debian (
-   -   Synaptic broken after updates (

leibniz 10-15-2006 01:55 PM

Synaptic broken after updates
Hey everyone:

I have a problem with Synaptic. Since updating, when I start it, it opens up a window and requests root password (like it always did.) However, it doesn't accept the root password; it just responds with "Incorrect password; please try again."

I know that the password is correct because it works fine on the command line. Synaptic also worked fine before the upgrade. I also know I can upgrade packages from the command line, so this is not really critical; I'm just used to using it, so I'd like to get it working.

I've search the forums and googled for similar problems, but didn't find anything helpful. The update that broke synaptic was full up libraries to update, but as there were many many packages upgraded, I didn't get a specific list of what exactly was updated, and therefore what might be responsible for this breakage.

Here are the specifics of my system:
AMD64 x2, Debian Etch, KDE 3.5
debian:~# dpkg -l | grep -i synaptic
ii synaptic 0.57.11 Graphical package manager
ii xserver-xorg-input-synaptics 0.14.6-1 Synaptics TouchPad driver for X.Org/XFree86

Thanks for any insight or help to this problem.

uselpa 10-15-2006 02:23 PM

Have you tried to enter your user password instead of the root password?

b0uncer 10-15-2006 02:26 PM

Does gksudo (I think that's what the graphical password-asker is called) work with other apps?

I'd imagine you could test it like this:

gksudo someapp
and put some fancy program name instead of someapp, like nautilus for example. Or, if it's not called gksudo, find out what it's called :)

davcefai 10-15-2006 02:28 PM

I had this last week. The problem is not Synaptic, you should find that any program using kdesu will behave the same. The solution is to apply all the KDE updates. One of them (I forget which) will fix the problem.

In the meantime use sudo synaptic to launch synaptic.

leibniz 10-15-2006 03:15 PM

Excellent. Thanks for that tip. Yes, that's what I've got. Some underlying library or authentication mechanism is not working properly. I thought I was all KDE updated, but perhaps I am missing something.

Nice workaround with sudo synaptic.

Thanks a bunch. When I find the exact solution, I'll post...


All times are GMT -5. The time now is 09:35 AM.