LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 10-15-2004, 11:18 AM   #1
elpresidente
LQ Newbie
 
Registered: Jun 2002
Posts: 15

Rep: Reputation: 0
Swap to console freezes box


Not sure if this is the best forum to ask for help but here goes...

I have newly installed sarge. Compiled and installed kernel 2.6.8. Installed ati driver (but it was running in software mode). Was able to get X working. At this time I was able to swap out of X to the console, logout to KDM and log in with any user. I then reinstalled ati driver using the AGPGART that came with the drivers instead the kernel AGPGART (which I was previously using). Now the ati driver runs great except that when I try to logout to KDM or swap to console it TOTALLY freezes my box. I can't even ssh in and kill processes. I have to power off and back on again.

Am running:
Debian Sarge (testing)
Kernel 2.6.8
ATI driver
X 4.3.1
KDM
Fluxbox

I assume it has to do with the driver. If that's the case, I'm not going to be happy Any suggestions would be very welcome.

BTW - Nice MB here. Had signed up a while back and burnt out my old fluxbox (what I call my linux boxes) so I haven't been around. Now I have a new fluxbox (FluxboxII), I'm going to have check in periodically.
 
Old 10-15-2004, 04:44 PM   #2
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
likely a conflict between the x driver and the console (fb?).
boot with fb deactvated.

sl mritch.
 
Old 10-15-2004, 04:52 PM   #3
elpresidente
LQ Newbie
 
Registered: Jun 2002
Posts: 15

Original Poster
Rep: Reputation: 0
Thanks for the reply.

I guess I'm not familar with fb. Can you tell me how to deactivate it? If not, no big deal. I'll look it up when I have more time. Will post back with results.
 
Old 10-15-2004, 06:09 PM   #4
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
no i really can't tell you.
the first thing i do when i install a sys is to compile a kernel (without fb). there has to be some bootoption video=<something> to turn it off. try video=vesa:off in your lilo.conf's append=" " line. also set vga=normal there. well, i'm guessing here, i hope it helps.

btw. you have fb (=framebuffer) enabled if you get that penguin at boot ;-)

sl mritch.
 
Old 10-16-2004, 12:09 PM   #5
elpresidente
LQ Newbie
 
Registered: Jun 2002
Posts: 15

Original Poster
Rep: Reputation: 0
Excellent information. I need to recompile the kernel anyway (for sound), so I'll make sure to do that. Thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
very strange swap partition label and empty text console whencat Fedora 4 08-07-2005 10:16 AM
Computer Freezes when going to Swap corepuncher Linux - General 1 05-24-2005 11:09 PM
launching the console freezes the KDE panel for a while (due to ADSL connection?) timo-l Linux - Networking 0 02-29-2004 05:56 AM
Mandrake 9.1 freezes even in console cyberhawk Linux - Hardware 8 06-24-2003 03:59 PM
Debian box freezes aliensub Linux - General 0 02-06-2003 06:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 11:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration