LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-17-2005, 10:02 AM   #1
ikarus
Member
 
Registered: Jun 2005
Distribution: mandrake 10.1
Posts: 97

Rep: Reputation: 15
Question Support for ATI All-in-wonder


Just installed "sarge" ( dual boot with windows XP) on a Pentium II 1GHz. I'm using the above video card and hoping to use the "composite video" monitor output for viewing videos on the TV, rather than the standard VGA monitor. On booting the system I'm getting the text mode video on the TV no problem, but as soon as the X server starts, this just turns to a non-synchronised red raster, leaving me with only standard VGA out on the connected monitor. My previous windows systems have all worked with this card without ( to my knowledge) any special drivers,

Is there anything I can tweak in the config files to get this working properly. I am not interested in support fot the TV tuner on this card, just plain old video out would be just fine!

IKarus
 
Old 08-17-2005, 11:53 AM   #2
gkiagia
Member
 
Registered: Oct 2003
Location: Greece
Distribution: Debian sid
Posts: 248

Rep: Reputation: 30
If I were you, I would go to www.ati.com and download the latest drivers.
Ati drivers provide options for configuring TV-out.
 
Old 08-18-2005, 04:51 AM   #3
ikarus
Member
 
Registered: Jun 2005
Distribution: mandrake 10.1
Posts: 97

Original Poster
Rep: Reputation: 15
Thanks gklagla. I have obtained the ati-driver-installer and tried to use it to resolve my problem. Unfortunately now I am left with a system which fails to run X at all ! If I knew how to get hold of the error log I would post it on here but this is a separate machine and not connected to the internet. I am quite prepared at this stage, to completely re-install Debian and the ATI drivers, but it is by no means clear to me at the moment as to how this should be done, The ATI release notes do some fairly good example run-throughs of typical installs but of course the one which applied to my own case was not at all clear to me.

I am completely new to Debian. Any advice would be much appreciated.

IKarus
 
Old 08-18-2005, 08:04 AM   #4
gkiagia
Member
 
Registered: Oct 2003
Location: Greece
Distribution: Debian sid
Posts: 248

Rep: Reputation: 30
I am sorry for the inconvenience.
If you can still access the machine in command line mode then try running xf86config as root.
This utility will generate a new X configuration file which will probably work if you choose the right options when it asks you.
Also, did the X server crash or the display went out of range? If it is the second case, then you've probably selected something wrong during the configuration.
The log files usually are in /var/log . You can try to copy the file to a floppy and then post it here?
 
Old 08-18-2005, 06:53 PM   #5
KimVette
Senior Member
 
Registered: Dec 2004
Location: Lee, NH
Distribution: OpenSUSE, CentOS, RHEL
Posts: 1,794

Rep: Reputation: 46
Try the open-source X.org driver. See http://gentoo-wiki.com/HOWTO_DRI_wit...Source_Drivers
 
Old 08-19-2005, 05:13 AM   #6
ikarus
Member
 
Registered: Jun 2005
Distribution: mandrake 10.1
Posts: 97

Original Poster
Rep: Reputation: 15
My log .........

XFree86 Version 4.3.0.1 (Debian 4.3.0.dfsg.1-14 20050601051219 fabbione@fabbione.net)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.29-pre2 i686 [ELF]
Build Date: 01 June 2005

This version of XFree86 has been extensively modified by the Debian
Project, and is not supported by the XFree86 Project, Inc., in any
way. Bugs should be reported to the Debian Bug Tracking System; see
<URL: http://www.debian.org/Bugs/Reporting >.

We strongly encourage the use of the "reportbug" package and command
to ensure that bug reports contain as much useful information as
possible.

Before filing a bug report, you may want to consult the Debian X FAQ:
XHTML version: file:///usr/share/doc/xfree86-common/FAQ.xhtml
plain text version: file:///usr/share/doc/xfree86-common/FAQ.gz

Module Loader present
OS Kernel: Linux version 2.4.27-2-686 (horms@tabatha.lab.ultramonkey.org) (gcc version 3.3.5 (Debian 1:3.3.5-12)) #1 Mon May 16 17:03:22 JST 2005
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Fri Aug 19 13:13:38 2005
(==) Using config file: "/etc/X11/XF86Config-4"
(==) ServerLayout "Server Layout"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "ATI Graphics Adapter"
(**) |-->Input Device "Mouse1"
(**) |-->Input Device "Keyboard1"
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc101"
(**) XKB: model: "pc101"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/:unscaled,/usr/X11R6/lib/X11/fonts/100dpi/:unscaled,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(++) using VT number 7

(II) Open APM successful
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.2
XFree86 Video Driver: 0.6
XFree86 XInput driver : 0.4
XFree86 Server Extension : 0.2
XFree86 Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x80000060, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 1106,0691 card 0000,0000 rev c4 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 1106,8598 card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:07:0: chip 1106,0686 card 1106,0000 rev 40 class 06,01,00 hdr 80
(II) PCI: 00:07:1: chip 1106,0571 card 1106,0571 rev 06 class 01,01,8a hdr 00
(II) PCI: 00:07:2: chip 1106,3038 card 0925,1234 rev 16 class 0c,03,00 hdr 00
(II) PCI: 00:07:3: chip 1106,3038 card 0925,1234 rev 16 class 0c,03,00 hdr 00
(II) PCI: 00:07:4: chip 1106,3057 card 0000,0000 rev 40 class 06,00,00 hdr 00
(II) PCI: 00:07:5: chip 1106,3058 card 1106,3058 rev 50 class 04,01,00 hdr 00
(II) PCI: 00:10:0: chip 1274,5000 card 4942,4c4c rev 01 class 04,01,00 hdr 00
(II) PCI: 00:13:0: chip 10ec,8139 card 1429,d010 rev 10 class 02,00,00 hdr 00
(II) PCI: 01:00:0: chip 1002,5144 card 1002,02aa rev 00 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x000c (VGA_EN is set)
(II) Bus 1 I/O range:
[0] -1 0 0x0000c000 - 0x0000c0ff (0x100) IX[B]
[1] -1 0 0x0000c400 - 0x0000c4ff (0x100) IX[B]
[2] -1 0 0x0000c800 - 0x0000c8ff (0x100) IX[B]
[3] -1 0 0x0000cc00 - 0x0000ccff (0x100) IX[B]
(II) Bus 1 non-prefetchable memory range:
[0] -1 0 0xe0000000 - 0xe1ffffff (0x2000000) MX[B]
(II) Bus 1 prefetchable memory range:
[0] -1 0 0xd8000000 - 0xdfffffff (0x8000000) MX[B]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:7:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(II) Host-to-PCI bridge:
(II) Bus -1: bridge is at (0:7:4), (-1,-1,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus -1 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus -1 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus -1 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(--) PCI:*(1:0:0) ATI Technologies Inc Radeon R100 QD [Radeon 7200] rev 0, Mem @ 0xd8000000/27, 0xe1000000/19, I/O @ 0xc000/8
(II) Addressable bus resource ranges are
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
[1] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) PCI Memory resource overlap reduced 0xd0000000 from 0xd7ffffff to 0xcfffffff
(II) Active PCI resource ranges:
[0] -1 0 0xe2000000 - 0xe20000ff (0x100) MX[B]
[1] -1 0 0xd0000000 - 0xcfffffff (0x0) MX[B]O
[2] -1 0 0xe1000000 - 0xe107ffff (0x80000) MX[B](B)
[3] -1 0 0xd8000000 - 0xdfffffff (0x8000000) MX[B](B)
[4] -1 0 0x0000ec00 - 0x0000ecff (0x100) IX[B]
[5] -1 0 0x0000e800 - 0x0000e83f (0x40) IX[B]
[6] -1 0 0x0000e400 - 0x0000e403 (0x4) IX[B]
[7] -1 0 0x0000e000 - 0x0000e003 (0x4) IX[B]
[8] -1 0 0x0000dc00 - 0x0000dcff (0x100) IX[B]
[9] -1 0 0x0000d800 - 0x0000d81f (0x20) IX[B]
[10] -1 0 0x0000d400 - 0x0000d41f (0x20) IX[B]
[11] -1 0 0x0000d000 - 0x0000d00f (0x10) IX[B]
[12] -1 0 0x0000c000 - 0x0000c0ff (0x100) IX[B](B)
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0 0xe2000000 - 0xe20000ff (0x100) MX[B]
[1] -1 0 0xd0000000 - 0xcfffffff (0x0) MX[B]O
[2] -1 0 0xe1000000 - 0xe107ffff (0x80000) MX[B](B)
[3] -1 0 0xd8000000 - 0xdfffffff (0x8000000) MX[B](B)
[4] -1 0 0x0000ec00 - 0x0000ecff (0x100) IX[B]
[5] -1 0 0x0000e800 - 0x0000e83f (0x40) IX[B]
[6] -1 0 0x0000e400 - 0x0000e403 (0x4) IX[B]
[7] -1 0 0x0000e000 - 0x0000e003 (0x4) IX[B]
[8] -1 0 0x0000dc00 - 0x0000dcff (0x100) IX[B]
[9] -1 0 0x0000d800 - 0x0000d81f (0x20) IX[B]
[10] -1 0 0x0000d400 - 0x0000d41f (0x20) IX[B]
[11] -1 0 0x0000d000 - 0x0000d00f (0x10) IX[B]
[12] -1 0 0x0000c000 - 0x0000c0ff (0x100) IX[B](B)
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0xe2000000 - 0xe20000ff (0x100) MX[B]
[6] -1 0 0xd0000000 - 0xcfffffff (0x0) MX[B]O
[7] -1 0 0xe1000000 - 0xe107ffff (0x80000) MX[B](B)
[8] -1 0 0xd8000000 - 0xdfffffff (0x8000000) MX[B](B)
[9] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[10] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[11] -1 0 0x0000ec00 - 0x0000ecff (0x100) IX[B]
[12] -1 0 0x0000e800 - 0x0000e83f (0x40) IX[B]
[13] -1 0 0x0000e400 - 0x0000e403 (0x4) IX[B]
[14] -1 0 0x0000e000 - 0x0000e003 (0x4) IX[B]
[15] -1 0 0x0000dc00 - 0x0000dcff (0x100) IX[B]
[16] -1 0 0x0000d800 - 0x0000d81f (0x20) IX[B]
[17] -1 0 0x0000d400 - 0x0000d41f (0x20) IX[B]
[18] -1 0 0x0000d000 - 0x0000d00f (0x10) IX[B]
[19] -1 0 0x0000c000 - 0x0000c0ff (0x100) IX[B](B)
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.2
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 2.0.2
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o": No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o": No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o": No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_vertex.o": No symbols found
(II) Module GLcore: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension GLX
(II) LoadModule: "dri"
(II) Loading /usr/X11R6/lib/modules/extensions/libdri.a
(II) Module dri: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading sub module "drm"
(II) LoadModule: "drm"
(II) Loading /usr/X11R6/lib/modules/linux/libdrm.a
(II) Module drm: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension XFree86-DRI
(II) LoadModule: "fglrx"
(II) Loading /usr/X11R6/lib/modules/drivers/fglrx_drv.o
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
compiled for 4.3.0.1, module version = 8.16.20
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.4
(II) ATI Radeon/FireGL: The following chipsets are supported:
RADEON 9000/9000 PRO (RV250 4966), RADEON 9000 LE (RV250 4967),
MOBILITY FireGL 9000 (M9 4C64), MOBILITY RADEON 9000 (M9 4C66),
RADEON 9000 PRO (D9 4C67), RADEON 9250 (RV280 5960),
RADEON 9200 (RV280 5961), RADEON 9200 SE (RV280 5964),
MOBILITY RADEON 9200 (M9+ 5C61), MOBILITY RADEON 9200 (M9+ 5C63),
FireGL 8800 (R200 5148), RADEON 8500 (R200 514C),
RADEON 9100 (R200 514D), RADEON 8500 AIW (R200 4242),
RADEON 9600 (RV350 4150), RADEON 9600 SE (RV350 4151),
RADEON 9600 PRO (RV360 4152),
MOBILITY RADEON 9600/9700 (M10/M11 4E50),
MOBILITY RADEON 9550 (M12 4E56), RADEON 9500 (R300 4144),
RADEON 9600 TX (R300 4146), FireGL Z1 (R300 4147),
RADEON 9700 PRO (R300 4E44), RADEON 9500 PRO/9700 (R300 4E45),
RADEON 9600 TX (R300 4E46), FireGL X1 (R300 4E47),
RADEON 9800 SE (R350 4148), RADEON 9550 (RV350 4153),
FireGL T2 (RV350 4154), RADEON 9800 PRO (R350 4E48),
RADEON 9800 (R350 4E49), RADEON 9800 XT (R360 4E4A),
FireGL X2-256/X2-256t (R350 4E4B),
MOBILITY FireGL T2/T2e (M10/M11 4E54), RADEON X300 (RV370 5B60),
RADEON X600 (RV380 5B62), FireGL V3100 (RV370 5B64),
MOBILITY RADEON X300 (M22 5460), MOBILITY FireGL V3100 (M22 5464),
RADEON X600 (RV380 3E50), FireGL V3200 (RV380 3E54),
MOBILITY RADEON X600 (M24 3150), MOBILITY RADEON X300 (M22 3152),
MOBILITY FireGL V3200 (M24 3154), RADEON X800 (R420 4A48),
RADEON X800 PRO (R420 4A49), RADEON X800 SE (R420 4A4A),
RADEON X800 XT (R420 4A4B), RADEON X800 (R420 4A4C),
FireGL X3-256 (R420 4A4D), MOBILITY RADEON 9800 (M18 4A4E),
RADEON X800 XT Platinum Edition (R420 4A50), RADEON X800 (R423 5548),
RADEON X800 PRO (R423 5549),
RADEON X800 XT Platinum Edition (R423 554A),
RADEON X800 SE (R423 554B), RADEON X800 XT (R423 5D57),
FireGL V7100 (R423 5550), FireGL V5100 (R423 5551),
MOBILITY RADEON X800 XT (M28 5D48), MOBILITY FireGL V5100 (M28 5D49),
RADEON X800 XL (R430 554D), RADEON X800 (R430 554F),
RADEON X850 XT Platinum Edition (R480 5D4D),
RADEON X850 PRO (R480 5D4F), RADEON X850 XT (R480 5D52),
MOBILITY FireGL V5000 (M26 564A), MOBILITY FireGL V5000 (M26 564B),
FireGL V5000 (RV410 5E48), FireGL V3300 (RV410 5E49),
RADEON X700 XT (RV410 5E4A), RADEON X700 PRO (RV410 5E4B),
RADEON X700 SE (RV410 5E4C), RADEON X700 (RV410 5E4D),
RADEON X700 (RV410 5E4F), MOBILITY RADEON X700 (M26 5652),
MOBILITY RADEON X700 (M26 5653), RADEON 9100 IGP (RS300 5834),
RADEON 9000 PRO/9100 PRO IGP (RS350 7834),
MOBILITY RADEON 9000/9100 IGP (RS300M 5835),
RADEON XPRESS 200 (RS400 5A41), RADEON XPRESS 200M (RS400 5A42),
RADEON XPRESS 200 (RS480 5954), RADEON XPRESS 200M (RS480 5955),
RADEON XPRESS 200 (RS482 5974), RADEON XPRESS 200M (RS482 5975),
RADEON XPRESS 200 (RC410 5A61), RADEON XPRESS 200M (RC410 5A62)
(II) Primary Device is: PCI 01:00:0
(II) ATI Proprietary Linux Driver Version Identifier:8.16.20
(II) ATI Proprietary Linux Driver Release Identifier: @@UNRELEASED_AND_UNSUPPORTED_DRIVER@@
(II) ATI Proprietary Linux Driver Build Date: Aug 16 2005 00:14:49
(II) ATI Proprietary Linux Driver Build Information: autobuild-rel-r6-8.16.1-driver-lnx-206829
(--) Assigning device section with no busID to primary device
(EE) No devices detected.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to submit@bugs.debian.org.
 
Old 08-19-2005, 08:31 AM   #7
gkiagia
Member
 
Registered: Oct 2003
Location: Greece
Distribution: Debian sid
Posts: 248

Rep: Reputation: 30
Quote:
(--) PCI:*(1:0:0) ATI Technologies Inc Radeon R100 QD [Radeon 7200] rev 0, Mem @ 0xd8000000/27, 0xe1000000/19, I/O @ 0xc000/8
The problem is right here.
It seems that you have a radeon 7200 but in the log it says:
Quote:
(II) ATI Radeon/FireGL: The following chipsets are supported:
RADEON 9000/9000 PRO (RV250 4966), RADEON 9000 LE (RV250 4967),
MOBILITY FireGL 9000 (M9 4C64), MOBILITY RADEON 9000 (M9 4C66),
RADEON 9000 PRO (D9 4C67), RADEON 9250 (RV280 5960),
RADEON 9200 (RV280 5961), RADEON 9200 SE (RV280 5964),
MOBILITY RADEON 9200 (M9+ 5C61), MOBILITY RADEON 9200 (M9+ 5C63),
FireGL 8800 (R200 5148), RADEON 8500 (R200 514C),
RADEON 9100 (R200 514D), RADEON 8500 AIW (R200 4242),
RADEON 9600 (RV350 4150), RADEON 9600 SE (RV350 4151),
RADEON 9600 PRO (RV360 4152),
MOBILITY RADEON 9600/9700 (M10/M11 4E50),
MOBILITY RADEON 9550 (M12 4E56), RADEON 9500 (R300 4144),
RADEON 9600 TX (R300 4146), FireGL Z1 (R300 4147),
RADEON 9700 PRO (R300 4E44), RADEON 9500 PRO/9700 (R300 4E45),
RADEON 9600 TX (R300 4E46), FireGL X1 (R300 4E47),
RADEON 9800 SE (R350 4148), RADEON 9550 (RV350 4153),
FireGL T2 (RV350 4154), RADEON 9800 PRO (R350 4E48),
RADEON 9800 (R350 4E49), RADEON 9800 XT (R360 4E4A),
FireGL X2-256/X2-256t (R350 4E4B),
MOBILITY FireGL T2/T2e (M10/M11 4E54), RADEON X300 (RV370 5B60),
RADEON X600 (RV380 5B62), FireGL V3100 (RV370 5B64),
MOBILITY RADEON X300 (M22 5460), MOBILITY FireGL V3100 (M22 5464),
RADEON X600 (RV380 3E50), FireGL V3200 (RV380 3E54),
MOBILITY RADEON X600 (M24 3150), MOBILITY RADEON X300 (M22 3152),
MOBILITY FireGL V3200 (M24 3154), RADEON X800 (R420 4A48),
RADEON X800 PRO (R420 4A49), RADEON X800 SE (R420 4A4A),
RADEON X800 XT (R420 4A4B), RADEON X800 (R420 4A4C),
FireGL X3-256 (R420 4A4D), MOBILITY RADEON 9800 (M18 4A4E),
RADEON X800 XT Platinum Edition (R420 4A50), RADEON X800 (R423 5548),
RADEON X800 PRO (R423 5549),
RADEON X800 XT Platinum Edition (R423 554A),
RADEON X800 SE (R423 554B), RADEON X800 XT (R423 5D57),
FireGL V7100 (R423 5550), FireGL V5100 (R423 5551),
MOBILITY RADEON X800 XT (M28 5D48), MOBILITY FireGL V5100 (M28 5D49),
RADEON X800 XL (R430 554D), RADEON X800 (R430 554F),
RADEON X850 XT Platinum Edition (R480 5D4D),
RADEON X850 PRO (R480 5D4F), RADEON X850 XT (R480 5D52),
MOBILITY FireGL V5000 (M26 564A), MOBILITY FireGL V5000 (M26 564B),
FireGL V5000 (RV410 5E48), FireGL V3300 (RV410 5E49),
RADEON X700 XT (RV410 5E4A), RADEON X700 PRO (RV410 5E4B),
RADEON X700 SE (RV410 5E4C), RADEON X700 (RV410 5E4D),
RADEON X700 (RV410 5E4F), MOBILITY RADEON X700 (M26 5652),
MOBILITY RADEON X700 (M26 5653), RADEON 9100 IGP (RS300 5834),
RADEON 9000 PRO/9100 PRO IGP (RS350 7834),
MOBILITY RADEON 9000/9100 IGP (RS300M 5835),
RADEON XPRESS 200 (RS400 5A41), RADEON XPRESS 200M (RS400 5A42),
RADEON XPRESS 200 (RS480 5954), RADEON XPRESS 200M (RS480 5955),
RADEON XPRESS 200 (RS482 5974), RADEON XPRESS 200M (RS482 5975),
RADEON XPRESS 200 (RC410 5A61), RADEON XPRESS 200M (RC410 5A62)
This is the wrong driver because it doesn't seem to support your gpu
 
Old 08-19-2005, 11:40 AM   #8
KimVette
Senior Member
 
Registered: Dec 2004
Location: Lee, NH
Distribution: OpenSUSE, CentOS, RHEL
Posts: 1,794

Rep: Reputation: 46
The proprietary ATI drivers will not work with any Radeon chipset prior to the 8500. I went with the open-source driver on my system because I have an AiW8500DV AND a n ATI 7500PCI card.
 
Old 08-19-2005, 11:18 PM   #9
ikarus
Member
 
Registered: Jun 2005
Distribution: mandrake 10.1
Posts: 97

Original Poster
Rep: Reputation: 15
Thanks all for replies. Just looked at the open source page. Very daunting and well beyond my capabilities!
Maybe this is where Debian and me should part company - it's certainly not for noobs like me.

IKarus
 
Old 08-20-2005, 05:18 PM   #10
KimVette
Senior Member
 
Registered: Dec 2004
Location: Lee, NH
Distribution: OpenSUSE, CentOS, RHEL
Posts: 1,794

Rep: Reputation: 46
It's not beyond your capabilities -- REALLY!
 
Old 08-23-2005, 10:08 AM   #11
alexr186
Member
 
Registered: Jul 2003
Location: Maine, USA
Distribution: Suse 9.1 Pro
Posts: 122

Rep: Reputation: 15
It is not to bad, just follow the directions and if you have any questoins then ask google or us. It is all about learning. The more you learn the better it makes you.
 
Old 10-13-2005, 10:28 AM   #12
m_pahlevanzadeh
Member
 
Registered: Sep 2002
Location: Iran/Tehran
Distribution: Debian
Posts: 94

Rep: Reputation: 28
ATI company has changed its own policy.I can't download Radeon 9200 driver.
Do you have it?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
help lost 3D support on my laptop with ATI M7 Lleb_KCir Linux - Hardware 11 09-22-2005 11:35 AM
ATI OpenGL support? phrenicNerve Fedora 5 01-10-2005 02:54 PM
ATI [lack of] support jbeiter Linux - Hardware 0 11-09-2004 08:38 AM
3D support on an ATI IGP 340m!!! scoob_e LinuxQuestions.org Member Success Stories 5 06-22-2004 01:05 AM
ATI Rage Pro Support punt Linux - General 2 08-08-2001 01:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 06:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration