LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 06-10-2011, 11:37 AM   #1
qrange
Member
 
Registered: Jul 2006
Location: Belgrade, Serbia
Distribution: Debian
Posts: 693

Rep: Reputation: 28
sudo tab autocomplete doesn't work


when I use sudo, command does not auto-complete with 'tab'.

perhaps its some sort of security measure? I'd like to turn it off, because its just annoying.
older versions of debian didn't have such problem.

using debian_testing_amd64.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 06-10-2011, 01:12 PM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,570

Rep: Reputation: 510Reputation: 510Reputation: 510Reputation: 510Reputation: 510Reputation: 510
do you have bash_completion installed and enabled for your user?
 
2 members found this post helpful.
Old 06-10-2011, 01:56 PM   #3
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,141

Rep: Reputation: 329Reputation: 329Reputation: 329Reputation: 329
Your problem is that the "command" in your input line is sudo and, once the command is entered, all the tab completion works for is file paths. You might try sudo /sbin/<tab> (if the command you want is in /sbin).
 
Old 06-10-2011, 02:01 PM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Slackware
Posts: 14,873
Blog Entries: 2

Rep: Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805
The better auto-completion was one of the reasons I switched from bash to zsh.
 
Old 06-11-2011, 03:05 AM   #5
qrange
Member
 
Registered: Jul 2006
Location: Belgrade, Serbia
Distribution: Debian
Posts: 693

Original Poster
Rep: Reputation: 28
installing bash_completion solved it, thanks.
 
Old 11-05-2012, 09:02 AM   #6
JohannesMa
LQ Newbie
 
Registered: Nov 2012
Posts: 1

Rep: Reputation: Disabled
It's now
Code:
bash-completion
instead of
Code:
bash_completion
.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TAB button doesn't work always Mr. Alex Debian 3 06-25-2010 06:15 PM
enable autocomplete tab key function AIX 5.3 watcher69b AIX 2 03-10-2009 10:35 AM
How can I disable autocomplete or tab complete? JeffreyMoore Linux - General 4 11-09-2008 06:12 PM
Tab autocomplete magic_ghost Linux - Software 1 03-17-2006 12:04 PM
Tab autocomplete like windows shell? lerceon Linux - Newbie 2 04-17-2005 09:25 PM


All times are GMT -5. The time now is 04:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration