LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-29-2005, 03:25 AM   #1
linx win
Member
 
Registered: Jan 2004
Posts: 390

Rep: Reputation: 31
Strange sound problem after installing Gnome


I am using Knoppix 3.8. I installed Gnome 2.10 and removed kde 3.3 completely. Every thing works fine except sound. The system sounds does work, Totam also works, and even when I move the mouse on an mp3 file the music starts playing but xmms does not work and gives me the following message:
Please check that:

Your soundcard is configured properly
You have the correct output plugin selected
No other program is blocking the soundcard

. Moreover, the sound applet does not start and got the following message:
No volume control elements and/or devices found.
I ran alsaconf but did not help. After searching and reading some posts here I blacklisted snd_intel8x0m ran alsaconf and restarted X, I got the sound volume applet to work and its error message to disapear. But still xmms and also realplayer do not work.

After reboot, I have to run alsaconf again even that I did: alsactl store. Here are the results of lsmod before and after alsaconf:
--------------------------Before alsaconf--------------------
root@box:/home/knoppix# lsmod | grep snd
snd_intel8x0 30400 0
snd_ac97_codec 68088 1 snd_intel8x0
snd_pcm_oss 47904 0
snd_pcm 77828 3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer 23684 1 snd_pcm
snd_page_alloc 11268 2 snd_intel8x0,snd_pcm
snd_mixer_oss 18688 1 snd_pcm_oss
snd 46308 6 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss
soundcore 11104 3 snd,i810_audio
root@box:/home/knoppix#
--------------------------After---------------------------
snd_intel8x0 30400 2
snd_ac97_codec 68088 1 snd_intel8x0
snd_pcm_oss 47904 1
snd_mixer_oss 18688 1 snd_pcm_oss
snd_pcm 77828 3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer 23684 1 snd_pcm
snd 46308 8 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore 11104 2 snd
snd_page_alloc 11268 2 snd_intel8x0,snd_pcm
r

Can any body help?
 
Old 08-29-2005, 04:09 AM   #2
exit3219
Member
 
Registered: May 2005
Location: Moldova
Distribution: Kubuntu
Posts: 199

Rep: Reputation: 30
Gnome uses ESD. Make sure you choose the right output plugin in XMMS. It must be 'eSound output plugin'. Choose it in Preferences > Output plugin section.

Hope it helps!

(BTW, does Rhythmbox work?)
 
Old 08-29-2005, 10:15 AM   #3
linx win
Member
 
Registered: Jan 2004
Posts: 390

Original Poster
Rep: Reputation: 31
exit3219

Thanks alot for a quick one. Yes, it did work, I am enjoying my favorite song now. How about Realplayer and the sound volume applet? I mean how can I make them work without alsaconf after every boot?
 
Old 09-01-2005, 07:25 AM   #4
exit3219
Member
 
Registered: May 2005
Location: Moldova
Distribution: Kubuntu
Posts: 199

Rep: Reputation: 30
Put 'alsactl store' and 'alsactl restore' in your init scripts, to load the appropriate mixer settings automatically when U boot.
 
Old 09-08-2005, 07:41 AM   #5
linx win
Member
 
Registered: Jan 2004
Posts: 390

Original Poster
Rep: Reputation: 31
exit3219

Thanks for reply. However, I do not know how to put them in the init. Would you plese tell me how?
 
Old 09-08-2005, 10:22 AM   #6
McCloud
Member
 
Registered: Sep 2004
Distribution: Debian Etch
Posts: 179

Rep: Reputation: 30
I think it is enough to do a 'alsaconf' and set the mixer using alsamixer. After you have done that, you use the command 'alsactl store'. This will save the settings. Normally, it will reload these settings automatically when you boot (as you can see in '/etc/init.d', there are alsa daemons that startup at boot).

Good luck!
 
Old 09-08-2005, 12:43 PM   #7
exit3219
Member
 
Registered: May 2005
Location: Moldova
Distribution: Kubuntu
Posts: 199

Rep: Reputation: 30
Yeah, what McCloud said is true. BTW, what distro do you use? Most of them create the init scripts you need by default.
 
Old 09-08-2005, 03:04 PM   #8
linx win
Member
 
Registered: Jan 2004
Posts: 390

Original Poster
Rep: Reputation: 31
Thanks for reply.

Yes. there is a file in /etc/init.d for alsa, but it fails to start alsa during PC bootup due to a conflict with esound. I removed the esound package and got all media programs working very well without blacklisting any module, but I lost Gnome sounds which seems to need esound. Is there a way to get Gnome sounds to use alsa instead of esound?

I am using knoppix 3.8. I have installed gnome 2.10 and removed kde.
 
Old 09-09-2005, 06:11 AM   #9
linx win
Member
 
Registered: Jan 2004
Posts: 390

Original Poster
Rep: Reputation: 31
I have followed the procedure shown in this thread:
http://www.linuxquestions.org/questi...70#post1767970

and got every thing working fine except realplayer. But, I got it workig from the command line as follows:

> realplay

Can some one help here?

By the way, only sound is not working in realplayer. Video is working fine in all cases.

Last edited by linx win; 09-09-2005 at 06:45 AM.
 
Old 09-09-2005, 09:13 AM   #10
exit3219
Member
 
Registered: May 2005
Location: Moldova
Distribution: Kubuntu
Posts: 199

Rep: Reputation: 30
Realplayer is not my forte, sorry. Maybe it's like XMMS, you just have to select the right sound output module?
Anyway, I don't know for sure.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange sound problem TomalakBORG SUSE / openSUSE 1 11-28-2005 08:48 PM
strange Gnome desktop keyboard problem... Hosiah Linux - Newbie 1 04-16-2005 02:30 PM
Gnome - strange key press problem Horos23 Linux - Software 3 03-04-2005 05:05 AM
strange, strange alsa problem: sound is grainy/pixellated? fenderman11111 Linux - Software 1 11-01-2004 06:16 PM
Strange gnome-panel problem cosiek Linux - Software 0 12-13-2003 07:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 11:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration