LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 06-24-2018, 06:29 AM   #1
jmh72
LQ Newbie
 
Registered: Aug 2017
Location: Eastern Europe
Distribution: Debian 9
Posts: 22

Rep: Reputation: 0
Strange Internet no connect


Hi. I have a problem. Last night, when I went to bed, the Internet worked fine on my laptop. This morning, not so.

The wifi on my tablet (using now) is fine, and my TV works fine. But on my laptop, which I only use ethernet on, will not work.

Things I remember and have tried:
- Reset router
- Disabled IPv6
- Removed iptables and ufw
- Searched online

Ifconfig showed an ipv6 address before I disabled it, and it looked like half an ipv6 address listed in the inet field.

What I did last night: removed apache. Deleted ntp and ml-sensors from /etc/init.d. (A few other startups like hardware temperature sensors, etc. Nothing serious or network related.)

Could someone help me with this please?
 
Old 06-24-2018, 06:42 AM   #2
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 14,976
Blog Entries: 9

Rep: Reputation: 4240Reputation: 4240Reputation: 4240Reputation: 4240Reputation: 4240Reputation: 4240Reputation: 4240Reputation: 4240Reputation: 4240Reputation: 4240Reputation: 4240
Quote:
Originally Posted by jmh72 View Post
Things I remember and have tried:
- Reset router
- Disabled IPv6
- Removed iptables and ufw
- Searched online

Ifconfig showed an ipv6 address before I disabled it, and it looked like half an ipv6 address listed in the inet field.

What I did last night: removed apache. Deleted ntp and ml-sensors from /etc/init.d. (A few other startups like hardware temperature sensors, etc. Nothing serious or network related.)
ntp nothing serious? well i guess it's all relative.
there's quite a lot you're not telling us:
- why and how disable ipv6?
- you cannot remove iptables, it's part of the kernel, afaiu. anyhow, show us exactly what you did there.
- searched - and found - what?
- why did you have apache installed in the first place, and what exactly did you uninstall?
- which debian version?

just for starters, show us
Code:
ping -c3 8.8.8.8
ping -c3 google.com
and how are you connecting to the network.

edit:
in the end, you just need to undo what you did.
i hope you took some notes.
and in the future, do backups before things go pear-shaped.

Last edited by ondoho; 06-24-2018 at 06:45 AM.
 
Old 06-24-2018, 07:49 AM   #3
jmh72
LQ Newbie
 
Registered: Aug 2017
Location: Eastern Europe
Distribution: Debian 9
Posts: 22

Original Poster
Rep: Reputation: 0
ntp is not mandatory.

Apt remove ufw also removed ip tables.

Searched for solutions.

It's not relevant why I had apache installed.

Stretch

I can't ping Google's DNS servers.

Thanks for your help.
 
Old 06-24-2018, 02:23 PM   #4
jmh72
LQ Newbie
 
Registered: Aug 2017
Location: Eastern Europe
Distribution: Debian 9
Posts: 22

Original Poster
Rep: Reputation: 0
Well, after hours of testing this is what I've got.

There's no routing table information. (route - n)

With 8.8.8.8 in resolve.conf or without, ping www.google.com reports connect: no network connection. The nameserver gets changed to ipv6 after I change it to 8.8.8.8, even if I disable ipv6 in sysctl.conf.

I've tried changing the interfaces to managed in Network Manager.conf... that did nothing.

I've tried listing the interfaces in /etc/network/interfaces, that changed nothing.

I turned off dhcp in the router, and that changed nothing too.

I tried connecting to my tablet hot-spot, and I still couldn't get through to the Internet.

There are no firewall rules stopping anything, including port 53.

Tech support factory reset the router for me. Still can't get through.

The strange thing is, my TV uses the same Internet, and it's been working fine all day.

Can someone with more experience please help with this problem? Many thanks.
 
Old 06-24-2018, 02:58 PM   #5
jmh72
LQ Newbie
 
Registered: Aug 2017
Location: Eastern Europe
Distribution: Debian 9
Posts: 22

Original Poster
Rep: Reputation: 0
Update and closed.

Update.

I just had a good idea and booted up my Huawei mini router. My laptop connected without a hitch.

So, even though my tablet connects to my primary router, something in the router or service is blocking my laptop via WiFi and Ethernet.

The tech guys will have to figure it out when they come here tomorrow.

Closed.
 
Old 06-24-2018, 05:11 PM   #6
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 4,705

Rep: Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872
At a minimum, examining the IP address assigned and default route is a good place to start. These commands can provide that information:
Code:
ip address
Code:
ip route
If the above check out, you can try pinging other hosts on the LAN, and then pinging a well-known internet address as part of the initial diagnostics.

If it's just name resolution not working, check for a valid nameserver...
Code:
grep "name" /etc/resolv.conf
This basic info can help others to assist further. (Better than blindly turning things off or disabling them without a clear understanding of what's actually wrong.)

Last edited by ferrari; 06-24-2018 at 05:12 PM.
 
Old 06-25-2018, 01:02 AM   #7
jmh72
LQ Newbie
 
Registered: Aug 2017
Location: Eastern Europe
Distribution: Debian 9
Posts: 22

Original Poster
Rep: Reputation: 0
Thank you.
 
Old 04-07-2020, 04:19 AM   #8
MrRobinson1
LQ Newbie
 
Registered: Nov 2019
Posts: 2

Rep: Reputation: 0
You have to remove your old connection. I mean, you need to remove your laptop IP address from your router received IP, and to start a new connection. It worked for me very well
 
Old 04-07-2020, 08:03 PM   #9
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 16,434
Blog Entries: 27

Rep: Reputation: 4963Reputation: 4963Reputation: 4963Reputation: 4963Reputation: 4963Reputation: 4963Reputation: 4963Reputation: 4963Reputation: 4963Reputation: 4963Reputation: 4963
Quote:
But on my laptop, which I only use ethernet on, will not work.
Have you tested the ethernet cable or tried using a different, known-good one?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Installed Ubunto 16.04 on machine. The network work, can ping my router and connect to LAN. Can't connect to internet phantom21 Linux - Networking 7 04-30-2016 01:00 AM
Connect my netbook to wireless but it wont connect to the internet but it did . Haydn456MJW Linux - Newbie 7 01-26-2011 05:56 PM
Able to connect to default Gateway, Unable to connect to internet Dumb.Coder Linux - Newbie 11 04-14-2009 04:22 AM
connect to internet trough wireless others connect to me with lan Amir Menesy Linux - Wireless Networking 1 11-13-2007 08:28 PM
can't connect to the internet:linux dont read my internet address droplsh Linux - General 1 02-29-2004 07:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 12:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration