LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 10-15-2004, 10:45 AM   #1
microsoft/linux
Senior Member
 
Registered: May 2004
Location: Sebec, ME, USA
Distribution: Debian Etch, Windows XP Home, FreeBSD
Posts: 1,445
Blog Entries: 9

Rep: Reputation: 48
startx/alias problems


two questions

1. Everytime i type startx I get a bunch of blank scrolling that I can't stop. ANy wasy to fix it? I'd like to be able to load my desktop

2.I've set up the ls alias's in root, but when I'm in normal user, I can't get it to work. I've edited the .bashrc file in ~ and it still won't work. Any ideas?
 
Old 10-15-2004, 12:44 PM   #2
corbintechboy
Member
 
Registered: Sep 2003
Location: Kentucky
Posts: 480
Blog Entries: 1

Rep: Reputation: 51
Hello,
I had this problem and I did not have X fully installed. Try apt-get install x-window-system.
 
Old 10-16-2004, 08:18 AM   #3
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 47
2. Post what you put in ~/.bashrc

BTW, after editing .bashrc did you either
1) log out and back in or
2) source ~/.bashrc

Last edited by darthtux; 10-16-2004 at 08:19 AM.
 
Old 10-16-2004, 04:13 PM   #4
microsoft/linux
Senior Member
 
Registered: May 2004
Location: Sebec, ME, USA
Distribution: Debian Etch, Windows XP Home, FreeBSD
Posts: 1,445

Original Poster
Blog Entries: 9

Rep: Reputation: 48
yes I logged out and logged back in, I'll post the output in little while, I have to get it so I can read it in my Windows partition.
 
Old 10-16-2004, 09:11 PM   #5
microsoft/linux
Senior Member
 
Registered: May 2004
Location: Sebec, ME, USA
Distribution: Debian Etch, Windows XP Home, FreeBSD
Posts: 1,445

Original Poster
Blog Entries: 9

Rep: Reputation: 48
heres what my user .bashrc file says

Quote:
# ~/.bashrc: executed by bash(1) for non-login shells.

# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)

# for examples


# If running interactively, then:
if [ "$PS1" ]; then


# don't put duplicate lines in the history. See bash(1) for more options

# export HISTCONTROL=ignoredups


# check the window size after each command and, if necessary,

# update the values of LINES and COLUMNS.

#shopt -s checkwinsize


# enable color support of ls and also add handy aliases
if [ "$TERM" != "dumb" ]; then
eval `dircolors -b`a
lias ls='ls --color=auto'
alias dir='ls --color=auto --format=vertical'

alias vdir='ls --color=auto --format=long'

fi
# some more ls aliases
alias ll='ls -l' --color=auto'

alias la='ls -A' --color=auto'

alias l='ls -CF' --color=auto'

# set a fancy prompt
PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '

# If this is an xterm set the title to user@host:dir

case $TERM in
xterm*)

PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME}: ${PWD}\007"'

;;
*)
;;
esac


# enable programmable completion features (you don't need to enable

# this, if it's already enabled in /etc/bash.bashrc).

#if [ -f /etc/bash_completion ]; then

# . /etc/bash_completion

#fi

fi
 
Old 10-16-2004, 09:15 PM   #6
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 47
Change
lias ls='ls --color=auto'
to
alias ls='ls --color=auto'

EDIT: your "a" was on the previous line. Delete that too.

Last edited by darthtux; 10-16-2004 at 09:17 PM.
 
Old 10-16-2004, 09:42 PM   #7
microsoft/linux
Senior Member
 
Registered: May 2004
Location: Sebec, ME, USA
Distribution: Debian Etch, Windows XP Home, FreeBSD
Posts: 1,445

Original Poster
Blog Entries: 9

Rep: Reputation: 48
nope, I went and checked my .bashrc file under linux and that's corrected, I must have copied it wrong. Any other ideas?
 
Old 10-16-2004, 11:36 PM   #8
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 47
It may have something to do with the extra single quote in the ll, la, and l lines.
 
Old 10-17-2004, 07:44 PM   #9
microsoft/linux
Senior Member
 
Registered: May 2004
Location: Sebec, ME, USA
Distribution: Debian Etch, Windows XP Home, FreeBSD
Posts: 1,445

Original Poster
Blog Entries: 9

Rep: Reputation: 48
Quote:

alias ll='ls -l' --color=auto'

alias la='ls -A' --color=auto'

alias l='ls -CF' --color=auto'
the quotes in red, blue or lime green?

Last edited by microsoft/linux; 10-18-2004 at 09:53 AM.
 
Old 10-18-2004, 12:16 AM   #10
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 47
It is the blue or middle one you need to remove.

When using the LQ color tags the closing color tag shouldn't have an =color.
 
Old 10-19-2004, 02:37 PM   #11
microsoft/linux
Senior Member
 
Registered: May 2004
Location: Sebec, ME, USA
Distribution: Debian Etch, Windows XP Home, FreeBSD
Posts: 1,445

Original Poster
Blog Entries: 9

Rep: Reputation: 48
I removed those apostrophes and it still doesn't do anything. any other ideas?
 
Old 10-19-2004, 06:43 PM   #12
Ghost_runner
Member
 
Registered: Jun 2004
Location: Kansas City, MO
Distribution: Mint (Cinnamon)
Posts: 276

Rep: Reputation: 30
add the line in your /etc/profile (at the end) you can use if/fi to check if its there, but i just make sure both root/ftp/and my user have one

source $HOME/.bashrc
 
Old 10-25-2004, 02:19 PM   #13
microsoft/linux
Senior Member
 
Registered: May 2004
Location: Sebec, ME, USA
Distribution: Debian Etch, Windows XP Home, FreeBSD
Posts: 1,445

Original Poster
Blog Entries: 9

Rep: Reputation: 48
I'm sorry, add what line to where. The last post is kind of confusing. Could you restate that?
 
Old 10-25-2004, 09:34 PM   #14
Ghost_runner
Member
 
Registered: Jun 2004
Location: Kansas City, MO
Distribution: Mint (Cinnamon)
Posts: 276

Rep: Reputation: 30
there should be a file in the /etc directory called profile. It is called by bash shells (and other shells, but not sure which all) the final line can read

source $HOME/.bashrc
 
Old 10-27-2004, 10:49 AM   #15
microsoft/linux
Senior Member
 
Registered: May 2004
Location: Sebec, ME, USA
Distribution: Debian Etch, Windows XP Home, FreeBSD
Posts: 1,445

Original Poster
Blog Entries: 9

Rep: Reputation: 48
Thank you, I'll see if that works
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Alias question (2 commands for one alias) gflores Linux - Newbie 3 01-21-2006 01:40 AM
re-startx problems PSIPHON Slackware 3 07-20-2005 11:33 PM
problems with startx ttilt Linux - General 1 02-23-2005 08:14 AM
Apache alias / subdirectories problems cavingreer Linux - Software 2 10-18-2004 04:16 PM
startx problems... kurrupt Debian 1 07-16-2004 09:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration