LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 07-27-2007, 05:46 PM   #1
eco2geek
Member
 
Registered: Feb 2003
Location: Portland, OR
Distribution: openSUSE 10.3, among others
Posts: 141
Blog Entries: 1

Rep: Reputation: 15
Starting other OSes thru KDE's "Restart Computer" button


KDE will allow you to start other OSes via its "Restart Computer" button, if you have GRUB installed (or LILO) and select your boot manager in the KControl > Login Manager > Shutdown > Boot Manager dropdown list. For some reason, it's not working on my computer, although GRUB's set up and working just fine, and it displays the choices I could make.

Did anyone have a similar problem, and how did you fix it? It works fine in PCLinuxOS on another box. I don't see any special GRUB section or "kdmrc" section that governs this.

(On an unrelated, uh, note, it looks like the "alsaconf" utility is now broken, as of today's dist-upgrade of Lenny. Fortunately, sound still works fine.)
 
Old 07-27-2007, 07:33 PM   #2
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,147

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Not an answer, but I'm having the same problem on Fedora 7 after the latest KDE upgrade. So I'd suspect a KDE problem rather than a Debian one.

Oh, I presume you're using KDE as you display manager. (Fedora defaults to using GDM instead of KDE. I know nothing about the Debian defaults, so I thought I'd ask.)
 
Old 07-27-2007, 07:35 PM   #3
Daws
Member
 
Registered: May 2006
Location: UK
Distribution: Debian, Linux From Scratch
Posts: 416
Blog Entries: 1

Rep: Reputation: 30
Quote:
Did anyone have a similar problem, and how did you fix it?
Yep a while ago. If I remember correctly I had to change grub's menu.lst. More specifically the "default" option, usually it's set to "default 0". Change it to read "default saved".

No guarantees though...
 
Old 07-27-2007, 08:27 PM   #4
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 59
In Debian testing, if you install both Gnome & KDE, GDM will be the default display manager. To get KDM as the display manager I install a bare bones system (select only "standard system" in tasksel), then add the x-window-system, kde-core, kdm, libgnome2-perl, gnome-system-tools, synaptic, hal, pmount, usbmount, alsa, alsa-utils, mozilla-firefox and mozilla-thunderbird (which installs the ice rodents).

Last edited by Junior Hacker; 07-27-2007 at 08:30 PM.
 
Old 07-27-2007, 08:33 PM   #5
eco2geek
Member
 
Registered: Feb 2003
Location: Portland, OR
Distribution: openSUSE 10.3, among others
Posts: 141
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Daws
Yep a while ago. If I remember correctly I had to change grub's menu.lst. More specifically the "default" option, usually it's set to "default 0". Change it to read "default saved".
Yes, that did it. Now to change "timeout 15" to "timeout 5" and be happy with it. Thanks.

(For some reason, PCLinuxOS manages to do this when you manually choose the OS, both without using "default saved" (it has "default 0"), and without waiting the defined timeout period. Maybe this has something to do with its version of grub.)

<edit> By the way, if you've already got both kdm and gdm installed (try "apt-get install kdm" if you don't, and let Debian take care of the dependencies) and you want to change display managers, it's as simple as running

dpkg-reconfigure xdm

as root.

Last edited by eco2geek; 07-27-2007 at 08:47 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie install: Why does computer hang on "starting pcmcia" on boot? JayBlade Red Hat 3 06-02-2007 10:55 AM
Lost "Shutdown" and "Restart" From system menu in FC6 Nader1 Linux - Software 3 02-12-2007 04:40 PM
"My Computer" button oneandoneis2 General 3 08-01-2005 08:45 PM
Getting "GRUB version 0.93................." when i restart my computer.. Coolioarchfiend Linux - Newbie 6 03-02-2004 08:02 AM
<input type="button" disabled="true" > does not work in ns4.7 or 4.9 cybercop12us Programming 2 11-29-2002 08:31 AM


All times are GMT -5. The time now is 04:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration