Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Debian This forum is for the discussion of Debian Linux.


  Search this Thread
Old 01-24-2011, 10:48 AM   #1
Registered: Aug 2003
Distribution: Debian Testing / kubuntu
Posts: 88

Rep: Reputation: 21
Squeeze + Pulseaudio + Alsa and USB Midi device causes Pulseaudio crash


I've got a rather special problem with my sound setup in Squeeze. At the moment i'm totally stuck and i'm looking for some good hints what i could do to better understand the problem i'm having.

I've got a fully updated squeeze with all pulseaudio, alsa and jack config files beeing the defualt. I purged all packages today and reinstalled them.
The problem is, that my pulseaudio server crashes always after ten minutes of playing sound with any application.

I've got an internal sound card playing my sound and a external usb midi interface attached (Midisport 2x2).

The crash seems alsa and midisport related. Because every time when the crash happens, i'm getting the following message in my syslog:

pulseaudio[6370]: module.c: Failed to load  module "module-alsa-card" (argument: "device_id="1" name="usb-0763_1002-00-M2x2" card_name="alsa_card.usb-0763_1002-00-M2x2" tsched=yes ignore_dB=no card_properties="module-udev-detect.discovered=1""): initialization failed.
My /var/log/messages says at the same time:
pulseaudio[6370]: pid.c: Stale PID file, overwriting.
Next line in syslog is:
pulseaudio[6376]: pid.c: Daemon already running.
And the connection of my application to pulseaudio is gone. If i restart the application, everything works fine for another 10 minutes.

Any idea, why pulseaudio wants to load that module, although, i'm not using it?

What to do to get the module loaded correctly or not loaded at all?

The funny thing is, that pulseaudio wants to load my midi device although i'm not using it at that particular moment! The midi interface just works fine, if i use it with rosegarden, and no crashes there.

BTW: I've got the midisport-firmware installed

Last edited by mad4linux; 01-26-2011 at 04:58 AM. Reason: added solved tag
Old 01-26-2011, 04:57 AM   #2
Registered: Aug 2003
Distribution: Debian Testing / kubuntu
Posts: 88

Original Poster
Rep: Reputation: 21
Thumbs up Solved

The solution to this was just too easy.
After reading the pulseaudio website again, i've found out, that pulse audio is running in system mode on Squeeze (correct me if i'm wrong).
Because i've updated my machine from etch to squeeze, my user was a member of the the audio group.
Now, with pulseaudio, only pulse should be a member of the audio group, if pulseaudio is running in system mode.
So i just deleted my user from the audio group in /etc/group and everything works fine now!

Last edited by mad4linux; 01-26-2011 at 04:58 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Installed/removed pulseaudio, lost ALSA jefm Debian 10 03-22-2012 05:32 PM
PulseAudio snarled after sleep. May crash flash? brianpbarnes Linux - Software 5 09-22-2010 04:44 PM
Winecfg crashes on sound tab with Pulseaudio and no 'sounddrivers' without pulseaudio William (Dthdealer) Linux - Software 5 06-13-2010 08:30 AM
[Debian Squeeze]Some problems concerning Pidgin Empathy Pulseaudio Keessince1988 Linux - Desktop 0 02-19-2010 03:25 PM
Mandriva: how to disable pulseaudio and enable Alsa veezee Linux - Hardware 5 09-16-2009 09:21 AM > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 05:30 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration