LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 10-18-2009, 02:33 PM   #1
frenchn00b
Senior Member
 
Registered: Jun 2007
Location: E.U., Mountains :-)
Distribution: Debian, Etch, the greatest
Posts: 2,546

Rep: Reputation: 57
Cool Squeeze Debian: how to use the kbluetooth ?


Hello,

I installed kbluetooth, and run it with sux.

But into the tray, there is nothing that is really capable to do something.
bluemon is grey and others too
I use jwm

I tried from console, to run bluemon, but bluemon windows displays not my nokia mobile phone (it works)

any ideas/clues how to get bluetooth working, are highly welcome ?
 
Old 11-17-2009, 07:27 AM   #2
zhjim
Senior Member
 
Registered: Oct 2004
Distribution: Debian Squeeze x86_64
Posts: 1,748
Blog Entries: 11

Rep: Reputation: 233Reputation: 233Reputation: 233
Did you had your bluetooth working under lenny? You sure know that squeeze is testing branch right now....
I once had bluetooth going on etch and had the same problem that I could not do very much with it. Beside connect my phone to it.
I guess you need a program to handle the connection or something like this.
 
Old 11-17-2009, 08:12 AM   #3
jim_p
Member
 
Registered: Aug 2009
Distribution: Debian testing
Posts: 556

Rep: Reputation: 127Reputation: 127
Kbluetooth does not work in testing/unstable. It can't "open" the bluetooth device.
Use blueman instead.
 
Old 11-17-2009, 02:32 PM   #4
frenchn00b
Senior Member
 
Registered: Jun 2007
Location: E.U., Mountains :-)
Distribution: Debian, Etch, the greatest
Posts: 2,546

Original Poster
Rep: Reputation: 57
Quote:
Originally Posted by jim_p View Post
Kbluetooth does not work in testing/unstable. It can't "open" the bluetooth device.
Use blueman instead.
well it seems that :

KDE bluetooth not working

gnome bluetooth: gnome-bluetooh-manager and assistant
work only under gnome. Forget about flubox.

Nothing works if you didnt install gnome.

So the resutls:
fluxbox can forget about bluetooth

Last edited by frenchn00b; 11-17-2009 at 03:03 PM.
 
Old 11-17-2009, 03:03 PM   #5
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Stretch Amd64
Posts: 1,477

Rep: Reputation: Disabled
So did you look at blueman as jim_p suggested?.

Code:
ade@Pc1:~$ apt-cache depends blueman
blueman
  Depends: libbluetooth3
  Depends: libc6
  Depends: libcairo2
  Depends: libglib2.0-0
  Depends: libgtk2.0-0
  Depends: libpango1.0-0
  Depends: libstartup-notification0
  Depends: python
  Depends: dbus
  Depends: bluez
  Depends: obex-data-server
  Depends: python-gtk2
  Depends: python-dbus
  Depends: python-gobject
  Depends: python-notify
  Depends: notification-daemon
    notification-daemon-xfce
    notify-osd
    xfce4-notifyd
  Recommends: python-gconf
  Recommends: policykit-1
  Recommends: libpulse-mainloop-glib0
Doesn't look too bad for dependencies,here's what i get when i try to install on Testing using Fluxbox:

Code:
ade@Pc1:~$ aptitude -s install blueman
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading extended state information      
Initializing package states... Done
Reading task descriptions... Done  
The following NEW packages will be installed:
  blueman bluez{a} libbluetooth3{a} libnl1{a} libopenobex1{a} obex-data-server{a} 
The following packages are RECOMMENDED but will NOT be installed:
  libpulse-mainloop-glib0 policykit-1 python-gconf 
0 packages upgraded, 6 newly installed, 0 to remove and 20 not upgraded.
Need to get 1,300kB of archives. After unpacking 4,821kB will be used.
Do you want to continue? [Y/n/?] n
Abort.
This is with 'recommends' and 'suggests' disabled in apt.
 
Old 11-18-2009, 01:37 PM   #6
frenchn00b
Senior Member
 
Registered: Jun 2007
Location: E.U., Mountains :-)
Distribution: Debian, Etch, the greatest
Posts: 2,546

Original Poster
Rep: Reputation: 57
swiftly: I have
Code:
ii  blueman                              1.21-1                     A Graphical bluetooth manager
ii  bluetooth                            4.42-2                     Bluetooth support
ii  bluez                                4.42-2                     Bluetooth tools and daemons
ii  bluez-alsa                           4.42-2                     Bluetooth ALSA support
ii  bluez-cups                           4.42-2                     Bluetooth printer driver for CUPS
rc  bluez-gnome                          0.27-1                     Bluetooth utilities for GNOME
ii  bluez-gstreamer                      4.42-2                     Bluetooth GStreamer support
ii  bluez-hcidump                        1.42-1+b1                  Analyses Bluetooth HCI packets
ii  bluez-utils                          4.42-2                     Transitional package
ii  gnome-bluetooth                      2.27.5-1                   GNOME Bluetooth tools
ii  kdebluetooth                         1.0~beta8-6+b1             KDE Bluetooth Framework
ii  libbluetooth3                        4.42-2                     Library to use the BlueZ Linux Bluetooth sta
ii  libgnome-bluetooth2                  2.27.5-1                   GNOME Bluetooth tools - support library
ii  libkbluetooth0                       1.0~beta8-6+b1             Bluetooth library for KDE
ii  libpam-blue                          0.9.0-2.3                  PAM module for local authenticaction with bl
ii  mplayer-skin-blue                    1.6-2                      blue skin for mplayer
ii  python-bluez                         0.17-1                     Python wrappers around BlueZ for rapid bluet
ii  blueman                              1.21-1                     A Graphical bluetooth manager
ii  bluetooth                            4.42-2                     Bluetooth support
ii  bluez                                4.42-2                     Bluetooth tools and daemons
ii  bluez-alsa                           4.42-2                     Bluetooth ALSA support
ii  bluez-cups                           4.42-2                     Bluetooth printer driver for CUPS
rc  bluez-gnome                          0.27-1                     Bluetooth utilities for GNOME
ii  bluez-gstreamer                      4.42-2                     Bluetooth GStreamer support
ii  bluez-hcidump                        1.42-1+b1                  Analyses Bluetooth HCI packets
ii  gnome-bluetooth                      2.27.5-1                   GNOME Bluetooth tools
ii  kdebluetooth                         1.0~beta8-6+b1             KDE Bluetooth Framework
ii  libbluetooth3                        4.42-2                     Library to use the BlueZ Linux Bluetooth sta
ii  libgnome-bluetooth2                  2.27.5-1                   GNOME Bluetooth tools - support library
ii  libkbluetooth0                       1.0~beta8-6+b1             Bluetooth library for KDE
ii  dbus                                 1.2.16-2                   simple interprocess messaging system
ii  dbus-x11                             1.2.16-2                   simple interprocess messaging system (X11 de
ii  libaudclient2                        2.1-1+b1                   audacious dbus remote control library
ii  libdbus-1-3                          1.2.16-2                   simple interprocess messaging system
ii  libdbus-glib-1-2                     0.82-2                     simple interprocess messaging system (GLib-b
ii  libdbus-qt-1-1c2                     0.62.git.20060814-2        simple interprocess messaging system (Qt-bas
ii  libeggdbus-1-0                       0.5-2                      D-Bus bindings for GObject
ii  libndesk-dbus-glib1.0-cil            0.4.1-2                    CLI implementation of D-Bus (GLib mainloop i
ii  libndesk-dbus1.0-cil                 0.6.0-3                    CLI implementation of D-Bus
ii  libnet-dbus-perl                     0.33.6-1+b1                Extension for the DBus bindings
ii  libpolkit-dbus2                      0.9-4                      library for accessing PolicyKit via D-Bus
ii  libqt4-dbus                          4:4.5.3-4                  Qt 4 D-Bus module
ii  python-dbus                          0.83.0-1                   simple interprocess messaging system (Python
ii  python-qt4-dbus                      4.6-1                      DBus Support for PyQt4
ii  python                               2.5.4-2                    An interactive high-level object-oriented la
ii  python-beagle                        0.3.9-1                    Python bindings for beagle
ii  python-bluez                         0.17-1                     Python wrappers around BlueZ for rapid bluet
ii  python-cairo                         1.8.6-1                    Python bindings for the Cairo vector graphic
ii  python-central                       0.6.12+nmu1                register and build utility for Python packag
ii  python-crypto                        2.0.1+dfsg1-4              cryptographic algorithms and protocols for P
ii  python-dbus                          0.83.0-1                   simple interprocess messaging system (Python
ii  python-gconf                         2.28.0-1                   Python bindings for the GConf configuration 
ii  python-gdata                         1.1.1-1                    Google Data Python client library
ii  python-gdbm                          2.5.2-1.1                  GNU dbm database support for Python
ii  python-glade2                        2.16.0-1                   GTK+ bindings: Glade support
ii  python-gmenu                         2.28.0-1                   an implementation of the freedesktop menu sp
ii  python-gnome2                        2.28.0-1                   Python bindings for the GNOME desktop enviro
ii  python-gnomeapplet                   2.26.0-1                   Python bindings for the GNOME panel applet l
ii  python-gnomedesktop                  2.26.0-1                   Python bindings for the GNOME desktop librar
ii  python-gnomekeyring                  2.26.0-1                   Python bindings for the GNOME keyring librar
ii  python-gobject                       2.20.0-1                   Python bindings for the GObject library
ii  python-gst0.10                       0.10.17-1                  generic media-playing framework (Python bind
ii  python-gtk2                          2.16.0-1                   Python bindings for the GTK+ widget set
ii  python-libxml2                       2.7.6.dfsg-1               Python bindings for the GNOME XML library
ii  python-minimal                       2.5.4-2                    A minimal subset of the Python language (def
ii  python-notify                        0.1.1-2+b1                 Python bindings for libnotify
ii  python-numpy                         1:1.3.0-3                  Numerical Python adds a fast array facility 
ii  python-paramiko                      1.7.4-0.1                  Make ssh v2 connections with python
ii  python-pkg-resources                 0.6.6-1                    Package Discovery and Resource Access using 
ii  python-pyorbit                       2.24.0-2                   A Python language binding for the ORBit2 COR
ii  python-qt4                           4.4.4-6                    Python bindings for Qt4
ii  python-qt4-common                    4.4.4-6                    Shared files for PyQt4
ii  python-qt4-dbus                      4.6-1                      DBus Support for PyQt4
ii  python-rdflib                        2.4.2-1                    RDF library containing an RDF triple store a
ii  python-reportbug                     4.8                        Python modules for interacting with bug trac
ii  python-sip4                          4.7.9-2                    Python/C++ bindings generator runtime librar
ii  python-support                       1.0.4                      automated rebuilding support for Python modu
rc  python-twisted-core                  8.2.0-3                    Event-based framework for internet applicati
ii  python-wnck                          2.26.0-1                   Python bindings for the WNCK library
ii  python-xdg                           0.17-0.1                   Python library to access freedesktop.org sta
ii  python2.5                            2.5.4-2                    An interactive high-level object-oriented la
ii  python2.5-minimal                    2.5.4-2                    A minimal subset of the Python language (ver
ii  libcairo-perl                        1.061-1                    Perl interface to the Cairo graphics library
ii  libcairo2                            1.8.8-2                    The Cairo 2D vector graphics library
ii  libcairo2-dev                        1.8.8-2                    Development files for the Cairo 2D graphics 
ii  libcairomm-1.0-1                     1.8.0-1                    C++ wrappers for Cairo (shared libraries)
ii  libcairomm-1.0-dev                   1.8.0-1                    C++ wrappers for Cairo (development files)
ii  libmono-cairo2.0-cil                 2.4.2.3+dfsg-2             Mono Cairo library (for CLI 2.0)
ii  libpixman-1-0                        0.16.2-1                   pixel-manipulation library for X and cairo
ii  libpixman-1-dev                      0.16.2-1                   pixel-manipulation library for X and cairo (
ii  python-cairo                         1.8.6-1                    Python bindings for the Cairo vector graphic
ii  libevent-1.4-2                       1.4.12-stable-1            An asynchronous event notification library
ii  libknotificationitem-1-1             4:4.3.2-1                  library for new way of handling system tray
ii  libnotify1                           0.4.5-1                    sends desktop notifications to a notificatio
ii  libstartup-notification0             0.10-1                     library for program launch feedback (shared 
ii  libzephyr4                           3.0~rc.2544-1              Project Athena's notification service - non-
ii  notification-daemon                  0.4.0-2                    a daemon that displays passive pop-up notifi
ii  specto                               0.2.2-3.1                  Unobtrusive update notification program
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Squeeze Repositories drakeman007 Linux - Newbie 15 11-19-2010 09:24 PM
Fun with soundcards under Debian squeeze fabien-jl Debian 2 10-18-2009 04:13 AM
[SOLVED] sound is not working properly on debian testing(squeeze) mf93 Linux - Hardware 2 10-10-2009 09:39 AM
tcsh segfault, Debian squeeze kaz2100 Debian 2 10-01-2009 07:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 01:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration