-   Debian (
-   -   Soundless Enemy Territory (

thecrazydood 03-14-2006 12:00 AM

Soundless Enemy Territory
Hi everyone.

I'm using Debian Unstable with kernel 2.6.15 and ALSA.

My sound is working fine in everything but Enemy Territory and that's because it is using /dev/dsp when there is no such device; as far as I can tell, /dev/snd is my sound card.

I tried making a soft link between /dev/dsp and /dev/snd but it didn't work.

All feedback is welcome. =)

thecrazydood 03-14-2006 12:51 AM

This has actually developed into something a lot more confusing.

I soon found out /dev/snd was a directory and tried the cat /dev/urandom thing on all the entries inside to see if i could find out which one was my card. None worked.

Sound is working for XMMS, MPlayer and so on so I'm wondering just what in the hell my sound card is actually be represented as in /dev.

thecrazydood 03-14-2006 01:00 AM

I fixed this with some help from the users in #linux at IRCnet.

All I needed was to load the module snd_pcm_oss to get OSS emulation for ALSA.

I thought I'd already tried it with asla-oss but clearly not.

dracae 03-14-2006 07:59 AM

This is an extremely common problem. If you had googled it, you would have come up with
echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss

All times are GMT -5. The time now is 04:45 AM.