LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 06-03-2016, 07:45 PM   #1
AdbekunkusMX
LQ Newbie
 
Registered: Nov 2014
Posts: 11

Rep: Reputation: Disabled
Sound through speakers stops working on Stretch, headphones work


Hi all.

I just installed Debian Stretch on an Acer Aspire E1. After a few minutes into a session sound stops comming out from the laptop speakers, although it plays over headphones or external speakers (connected through 3.5mm port). I've noticed it happens when changing the volume of a youtube or other site video. Last time it happend I ran dmesg and noticed this:
Code:
Jun  3 17:58:13 sophus kernel: [ 2042.987363] perf interrupt took too long (2592 > 2500), lowering kernel.perf_event_max_sample_rate to 50000
I don't know if it is related.

My soundcard:
Code:
lspci|grep -i audio
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler HDMI Audio
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 01)
My kernel is 4.5.0-2-amd64. Any ideas?
 
Old 06-04-2016, 12:34 AM   #2
kiyop
Member
 
Registered: Jun 2015
Distribution: Debian, Arch
Posts: 56

Rep: Reputation: Disabled
Have you read https://wiki.debian.org/Sound ?
 
Old 06-05-2016, 02:40 PM   #3
AdbekunkusMX
LQ Newbie
 
Registered: Nov 2014
Posts: 11

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by kiyop View Post
I have now. It was very enlightening but not particularly useful. I know now that the problem probably stems from PulseAudio, so the real question is how I diagnose it.
 
Old 06-05-2016, 04:37 PM   #4
AdbekunkusMX
LQ Newbie
 
Registered: Nov 2014
Posts: 11

Original Poster
Rep: Reputation: Disabled
Update on this (hopefully someone has experienced this as well): audio through speakers goes mute after 5 minutes or so of playing simultaneously a flash/html5 video on firefox and an mp3 file on totem. I still get both streams on headphones. There is nothing useful on any of the files in /var/log. Any ideas of how to diagnose/solve this?

EDIT: here's the contents of /etc/pulse/client.conf:
Code:
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.

## Configuration file for PulseAudio clients. See pulse-client.conf(5) for
## more information. Default values are commented out.  Use either ; or # for
## commenting.

; default-sink =
; default-source =
; default-server =
; default-dbus-server =

; autospawn = yes
; daemon-binary = /usr/bin/pulseaudio
; extra-arguments = --log-target=syslog

; cookie-file =

; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB

; auto-connect-localhost = no
; auto-connect-display = no
I notice that the default input and output have no value and are commented. I tried running /usr/lib/pulseaudio/pulse/gconf-helper and I got this:
Code:
(process:1687): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
GConf Error: No D-BUS daemon running


(process:1687): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
GConf Error: No D-BUS daemon running
and nothing else happend except the PS1 turned into a ! as if expecting something; I had to Ctrl+C to get back to the terminal. I have been trying to make speakers work again by restarting both alsa and pulseaudio from the terminal to no avail. Any ideas?? Please help, it's rather annoying. Thanks in advance.

Last edited by AdbekunkusMX; 06-05-2016 at 04:48 PM. Reason: More info
 
Old 04-10-2018, 02:19 PM   #5
msimko81
LQ Newbie
 
Registered: Apr 2018
Posts: 2

Rep: Reputation: Disabled
Hi, I have the same problem with stopping sound from speakers and the same message in syslog (haven't checked with headphones though).
Running on ubuntu 16-04.

AdbekunkusMX, have you found a solution to this? Thanks for any input.
 
Old 04-11-2018, 06:01 PM   #6
AdbekunkusMX
LQ Newbie
 
Registered: Nov 2014
Posts: 11

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by msimko81 View Post
Hi, I have the same problem with stopping sound from speakers and the same message in syslog (haven't checked with headphones though).
Running on ubuntu 16-04.

AdbekunkusMX, have you found a solution to this? Thanks for any input.
Hi. Sorry for the delay.

I quite frankly don't remember how I solved this issue (or if I solved it, for that matter); that box is long gone.

However I did experience a quite similar problem on my current laptop (Dell Inspiron 5667 with Intel sound card) and the following steps solved it:

1. Install libsamplerate0.
2. Uncomment the following lines in /etc/pulse/daemon.conf:
Code:
allow-module-loading
resample method =
avoid-resampling
3. Set "resample-method ="; I used "src-sinc-best-quality". The whole list of options is here: http://www.mega-nerd.com/SRC/faq.html
4. Create /etc/modprobe.d/alsa.conf with the following contents:
Code:
options snd-hda-intel model=headset-mic
(I can't quite remember exactly what this does, to be honest).
5. PROFIT!!

Hope it works for you. Cheers!
 
Old 04-13-2018, 06:21 AM   #7
msimko81
LQ Newbie
 
Registered: Apr 2018
Posts: 2

Rep: Reputation: Disabled
Hi, thanks for a hint.

I have tried that but unfortunately it doesn't help.

Meantime I have noticed that my wireless connection also drops at the same time as the sound. And it is always accompanied with the message in syslog
Quote:
perf interrupt took too long (2592 > 2500), lowering kernel.perf_event_max_sample_rate to 50000
Moreover, my CD-ROM opens randomly. Even though there is no medium inserted and I don't use any program that shall open it.

Probably I will try a fresh reinstall of the system...
 
Old 04-13-2018, 11:04 PM   #8
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005
There's a weird thing if the sound is muted in totem, it's muted globally, and nothing will unmute it but going into totem and raising the volume.
 
Old 06-30-2018, 12:51 AM   #9
murmylon
LQ Newbie
 
Registered: Jun 2018
Posts: 1

Rep: Reputation: Disabled
I had been having the same issue (sound through headphone jack but not speakers). The solution posted by AdbekunkusMX, to use libsamplerate0, worked for me. My daemon.conf file didn't have the line 'avoid-resampling' so I added it.

Thanks very much!
 
Old 06-30-2018, 12:44 PM   #10
AdbekunkusMX
LQ Newbie
 
Registered: Nov 2014
Posts: 11

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by murmylon View Post
I had been having the same issue (sound through headphone jack but not speakers). The solution posted by AdbekunkusMX, to use libsamplerate0, worked for me. My daemon.conf file didn't have the line 'avoid-resampling' so I added it.

Thanks very much!
I'm glad it worked for you; I'm now marking the tread as solved.
 
  


Reply

Tags
sound, testing


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] After Ubuntu 15.10 dist-upgrade, sound only comes through onboard speakers, doesn't work with headphones? Rotten194 Linux - Laptop and Netbook 8 02-23-2016 06:25 PM
Microphone not working (Skype) - Splitting Sound via Headphones and Speakers Rhapsody Gentoo 0 03-29-2012 02:33 AM
Sound seems to be confused with itself. Speakers work fine, headphones are buggy. WickDaddy Ubuntu 4 08-14-2011 01:51 PM
Speakers work, headphones don't tommyttt Linux - Newbie 3 01-20-2011 02:47 AM
Sound from speakers not from headphones crimsontide Linux - Hardware 2 12-21-2006 09:55 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration